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Chapter 1 
 

System Overview  
1 

 

 
The Optical Vector Analyzer (OVA) fully analyzes the optical properties of fiber 

optic components, modules, and subsystems, providing comprehensive 

characterization based on a complete transfer function measurement. The OVA 

software uses a complete vector model of the optical field, including polarization 

state and optical phase, to characterize the device under test. The OVA’s optical phase 

measurements make the characterization of the dispersive effects of components 

significantly less complicated than it has been in the past. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
When equipped with all options, the instrument will measure the complete matrix 

transfer function (Jones matrix) of the device under test. From this measurement, 

any linear parameter can be extracted and graphed, including insertion loss, 

polarization dependent loss (PDL), group delay, chromatic dispersion, optical phase, 

and polarization mode dispersion (PMD) as a function of wavelength. The full 

measurement, including all parameter calculations, is accomplished using a single 

sweep of the internal tunable laser. 
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The OVA may also be operated as an Optical Frequency Domain Reflectometer 

(OFDR), if the user purchases this option. By reconfiguring the hardware and data 

processing algorithms, the OVA can be utilized to measure the full scalar response 

of an optical system, including both phase and amplitude information in terms of 

the system transfer function. This allows the data to be presented for both the time 

domain and the frequency domain. For a complete discussion of how the OFDR 

measures these values, see Chapter 7‚ “Optical Frequency Domain Reflectometer,” 

on page 95. 

 
Overview of Operation 

The vast majority of fiber optic systems and components support two polarization 

modes, and in general each input polarization mode can couple into either one of 

the output modes. Therefore fiber optic devices are best characterized using a 2 x 

2 complex matrix, generally referred to as a Jones matrix,1 which fully describes 

all of the linear characteristics of the device: 
 
 
 

J   = a   b  
. 

c    d  
 

The quantities a, b, c and d are the four scalar transfer functions, and  represents 

optical frequency. The Jones matrix represents the complete mathematical 

description of the propagation of light through the device. It is equivalent to the 

transfer function of linear systems theory.2 The Jones matrix contains all of the 

typical parameters such as insertion loss, group delay, polarization dependent loss, 

and polarization mode dispersion, as well as more subtle effects such as a second 

order PMD that may exist in the device. The Jones matrix encapsulates all optical 

properties in a single compact matrix that is fundamentally rigorous, making it an 
 
 

1  For detailed information about the Jones matrix, see Swindell, W. ed. Polarized Light, 

(Dowden, Hutchington & Ross, Inc., Stroudsburg PA, 1975, pp. 187-233), where the original 

papers by R.C. Jones have been reprinted. 

2  The term “Jones matrix” has been used to describe the matrix optical transfer function, as 

well as a normalized matrix that describes only the evolution of the polarization state. In the 

context of this manual and the OVA, the term is used to refer to the former, as the Jones 

matrix measured by the instrument contains all amplitude, phase and polarization informa- 

tion. 
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ideal tool for modeling and understanding fiber optic systems. A more detailed 

 

1 

discussion of the Jones matrix appears in Chapter 9. 

 

The Control Software 
The OVA control software uses the measured Jones matrix to compute and display 

a variety of parameters, including all industry standard parameters for characterizing 

optical components. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-1. OVA control software main window. 
 

The control software plots various curves depending on the parameter selected from 

the pull-down menu at the top of a plot window. Please see “Parameter Calculations” 

on page 217 for complete parameter definitions. 
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1 
 
 
 
 
 
 
 

 
Figure 1-2. Graph area with the Title Bar pulled down for 

selecting the parameter to plot. 

 
The following parameters are calculated and displayed by the OVA control software: 

 

• Insertion Loss (For a complete definition, see “Insertion loss” on 

page 217). 

• Group Delay (See page 218). 

• Chromatic Dispersion (See page 219). 

• Polarization Dependent Loss (See page 220). 

• Polarization Mode Dispersion (See page 220). 

• Linear Phase Deviation (See page 223). 

• Quadratic Phase Deviation (See page 224). 

• Jones Matrix Element Amplitudes (See page 225). 

• Jones Matrix Element Phases (See page 225). 

• Time Domain (Amplitude), (See page 225). 

• Time Domain (Wavelength), (See page 226). 

• Min/Max Loss (See page 227). 

• Second Order Polarization Mode Dispersion, (See page 221). 

• Phase Ripple Linear (See page 228). 

• Phase Ripple Quadratic (See page 229). 
 

The control software also provides many tools for data acquisition, manipulation, 

and display. Data acquisition modes include single scan, multiple scan (averaging), 

continuous scan, and real-time mode. There are also two different filtering methods 

for reducing measurement noise. Postprocessing allows the user to change the 
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resolution bandwidth without the need to redo the measurement. Graph windows 

 

support the display of up to three different data sets simultaneously, and include 
powerful zoom and cursor features. 

1 
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Chapter 2 
 
 

 

Assembly and Startup 

2 
The Optical Vector Analyzer is shipped with everything needed to conduct device 
characterizations, including the measurement instrument and all supporting 

hardware, software, documentation, and cables. 
 

Read and follow all assembly and startup instructions before attempting to operate 

the Optical Vector Analyzer. 
 

 
Warning  The protection provided by the equipment may be impaired 

if the equipment is used in a manner not specified by the 

               manufacturer, resulting in serious injury or death. 
 
 

Components List 

All models of the Optical Vector Analyzer are shipped with these components: 
 
 
 

 
Optical Vector Analyzer instrument 

 
 
 
 
 
 

One (1) USB cable to connect the OVA instrument to the PC 



8   Chapter 2 

Assembly and Startup 

 

 
 
 
 

One (1) power cord for the OVA instrument (Plus two (2) 

more, if you ordered the PC and monitor) 
 
 
 

2 

         OVA laptop PC (or desktop PC, shown below)

 

 

 
 

           Laptop power supply 
 
 
 
 
 
 

OVA desktop PC (or laptop PC, shown above) 
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17-inch flat panel monitor (with desktop only) 
 

 

2 
 
 
 

         Monitor-PC interface cable (with desktop only) 

     Keyboard (with desktop only) 

 

                Mouse (with desktop only) 

        Fiber polarization controller 

 

 
Gold reflector 
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Luna Technologies mouse pad 
 
 

 

2 
             OVA User Guide

 

 
 
 

             Software recovery CD-ROM 

        Optical fiber connector cleaner 

 
 
 

Optical fiber bulkhead connector cleaners 
 
 
 
 
 

If components are missing or damaged, contact Luna Technologies toll free at 

866-586-2682 or by e-mail at support@lunatechnologies.com. 

mailto:support@lunatechnologies.com
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Assembling the OVA 
 

 
Important  

The instrument should always be fully assembled before 

                 turning power on to any of its components. 
 

 
To assemble  the OVA 

 

1 Remove all the OVA components from the shipping containers and 

verify that no components are missing. (See “Components List” on 

page 7.) 
 

2 Place the OVA on a stable surface free of excessive vibrations and 

capable of supporting the weight of the entire unit. For the weight and 

dimensions of the unit, see Appendix A‚ “Specifications,” on page 275. 
 

 
Important  

Place the OVA away from walls or objects that will restrict 

                 the air flow through the fan duct on the back of the unit. 
 

 

3 Unpack and set up the desktop or laptop PC according the 

manufacturer’s instructions provided. If you purchased a desktop PC, 

connect the monitor, keyboard, and mouse to the PC, using the cables 

provided. For user-supplied PCs, see “Minimum PC Requirements” on 

page 276. 

 
Important  Do not turn the power on to the PC yet. 

Do not connect the instrument to the PC until instructed. 

               Do not place the laptop  on top of the instrument. 
 

 

4 If printouts are desired, connect a local printer to a printer port (parallel 

or USB) on the back panel of the PC using the proper cable for the 

printer. For information on printing, see “Printing” on page 82. 
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5 If necessary, install the drivers for local or network printers that will be 

used for printing data sheets. 

 

Important  
Do not install any software on the OVA PC other than a 

printer driver or software supplied by Luna Technologies. 

               Third-party software installed on the PC may impair the 
proper function of the OVA. 

 

 

6 Optional: To connect the OVA to a network, attach a network cable (not 

provided) to the ethernet port on the back panel of the PC. 
 

7 Do not connect the OVA instrument to the PC with the USB cable until 

instructed in the next section. 
 

8 On the front of the instrument, there are plastic caps installed to protect 

the ports. Leave these caps on when the instrument is not in use. To 

remove the cap for measurements, turn it counterclockwise. 
 

9 Attach the power cords provided to the instrument and to the laptop (or 

PC and monitor). To ensure safe operation, place the instruments to 

allow easy disconnection of the power cord. Note that the OVA requires 

surge-protected, grounded outlets. 
 

 
 

The OVA is now fully assembled. 

 

Startup 

1 Once the OVA instrument is fully assembled (except for the USB cable 

connecting the instrument to the PC), allow the equipment to stabilize 

at room temperature, between 10–35 ºC. 
 

2 Turn on the PC, allowing it to fully load up Microsoft® Windows® XP. 
 

3 If you purchased a PC from Luna Technologies, it comes with the OVA 

control software already installed. If not, install the OVA software now. 

(From the Luna Technologies CD provided, open the OVA folder and 

run setup.exe, following on-screen instructions.) 
 

4 Ensure that the OVA is powered OFF. 
 

5 Connect the OVA to the PC using a standard USB cable (provided). 
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6 Turn on the OVA using the power switch on the front panel. 

 

7 The PC will automatically detect the device and display the “Found New 

Hardware Wizard” dialog window: 
 
 
 

2 
 
 
 
 
 
 
 
 
 
 
 
 
 

8 Select the “No, not this time” option and click the “Next” button to 

continue. A new window, similar to the one below, will be displayed: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9 Select the “Install from a list or specific location (Advanced)” option 

and click the “Next” button. 
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10 A new window, similar to the one below, is displayed: 

 

 
 
 
 
 
 

2 
 
 
 
 
 
 
 
 

 
11 Select the “Search for the best driver  in these locations” option and 

check the “Include  this location in the search”  checkbox. Click the 

“Browse” button to select the location of the driver. 
 

12 Browse to the location where the instrument software was installed (e.g. 

C:\Program Files\Luna Technologies\OVA v#.#) and then into the 

“USB_Drivers” sub-directory. Click “OK”. 
 

13 Another dialog box will alert the user to wait while the Wizard searches. 

When it becomes available, click the “Next” button to continue. 
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14 An alert dialog similar to the one below will be displayed: 

 
 
 
 
 

 

2 
 

 
 
 
 
 
 
 
 

15 Click the “Continue  Anyway” button to proceed. A new window will 

be displayed: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

16 Click the “Finish” button to complete installation of the driver. 
 
 

Important  
It is helpful to make a note of which USB port you used 

for the OVA instrument. If the instrument is ever connected 

               to a different USB port, it may require that this driver 
installation procedure be completed again. 
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17 Double-click the OVA desktop icon or select OVA Software 

from the Luna  Technologies program group in the Windows® Start 
menu. An initial window will appear for a few moments while the user 

interface is initialized. 
 

 
If the control software is started when the instrument is not 

powered on, a communication failure error message 

opens. However, the software can be used in desktop 
Important 

analysis mode when the instrument is not powered by 

clicking OK in the message box. 

To operate in normal mode, turn on the instrument. The 

software automatically detects the instrument and displays 

a message. The system can then be used normally. 
 

 

Once the control software is running, the OVA is ready for alignment and calibration. 

(See “Aligning the OVA Optics” on page 33 and “Calibrating the System” on 

page 34.) Do not attempt to perform measurements before aligning and calibrating. 
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Chapter 3 
 
 

 

Software Guide 
 
 

The control software is the primary interface between the user and the instrument. 

It provides all of the necessary tools to calibrate and align the system and to perform 

complete, all-parameter measurements of fiber-coupled optical devices. It also 

contains a variety of powerful features for data manipulation and display. 
 

This chapter provides an overview of the location and function of all controls and 

indicators included in the control software. Chapter 4‚ “Performing Measurements,” 

on page 33 provides greater detail on how to use the OVA to perform specific 

measurement tasks. Chapter 5‚ “Data Processing and Display,” on page 55 more 

fully describes how to process the data and manipulate plots. 
 
 

 
 
 
 

Important 

If the control software is started when the instrument is not 

powered on, a communication failure error message 

opens. However, the software can be used in desktop 

analysis mode when the instrument is not powered by 

clicking OK in the message box. 

To operate in normal mode, turn on the instrument. The 

software automatically detects the instrument and displays 

a message. The system can then be used normally. 
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Window Features 
 

 
 
 
 
 
 
 
 
 

3 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3-1. OVA control software main window. The figure above shows most of the 

buttons and fields active. However, when the software starts, most 

buttons and fields are unavailable because no data is in active memory yet. 
 

The main window is composed of 7 functional areas: 
 

1 The System Control  area contains fields and menus that control the 

OVA instrument and set test parameters. 
 

2 The Data Processing  area contains controls for setting the resolution 

of filters and buttons for applying filters to the acquired data. 
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3 The Display Options area allows the user to synchronize the horizontal 

axes and X-axis cursors of both graphs. 
 

4 The Matrix  Memory  Functions  area contains controls that allow the 

user to work with up to three data sets simultaneously. 
 

5 The System Status  Bar at the bottom of the screen displays system 

messages such as error, laser status, and calibration status information. 
 

6 The two Graph areas contain plots of test data. The pull-down menu 

at the top of each graph allows the user to select which parameter is 

displayed. Buttons to the lower left of each graph adjust plot axes, 

cursors, legend, and zoom. The lower center pull-down menu controls 

X-axis units. 
 

7 The Menu Bar contains additional commands for loading and saving 

data files, printing, controlling calibration and alignment, and for setting 

various measurement and display options. 
 

System Control 

The System Control area of the main window contains fields and menus that control 

the OVA instrument and set test parameters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 3-2. The System Control area in the main OVA software window. 

 
• The Type of Measurement pull-down menu allows the user to 

choose the type of measurement: reflection or transmission. The 
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proper hardware configurations for these measurements will be 

described in Chapter 4‚ “Performing Measurements,” on page 33. 

• The Center Wavelength (nm) field allows the user to set the center 

wavelength of a scan. To set this parameter, type in a number within 

the wavelength range of the instrument. If the user enters values 

outside the range of the instrument, the software replaces them with 

values within the instrument’s range. (See the specifications given 

on our website at www.lunatechnologies.com. for standard instru- 

ment wavelength ranges.) 

• The Wavelength Range (nm) field allows the user to set the range 

of the scan. The wavelength range determines the number of 

nanometers that will be analyzed during the next measurement. A 

drop-down list contains the range options available for the OVA 

model in use. 

• The Scan Range (nm) field shows the starting and ending wave- 

lengths that will be scanned, as determined by the center wave- 

length and wavelength range entered by the user in the two fields 

above this field. 

• The DUT Length Find Method pull-down menu allows the user to 

choose either the Narrowband or Broadband method of determin- 

ing DUT length. The two length-finding methods are described 

under “Finding the DUT Length” on page 44. 

• The Length of DUT (m) field shows the length of the device under 

test. It is automatically updated by the software when the user 

clicks Find, or the user can enter it manually. If the user selects 

Options > Automatically  Find DUT Length, this field will be 

automatically updated each time a normal or averaging scan is per- 

formed. 

• Continuous Scan Mode, when checked, causes the OVA to repeat- 

edly make another measurement upon the completion of the previ- 

ous measurement. The graph displays are continuously updated after 

each measurement. Note that this mode will operate more quickly if 

one of the graph areas is turned off. (See Figure 3-8 on page 25.) 

This mode is started and stopped by pressing the Scan button. 

• Enable Averaging, when checked, causes the OVA to acquire mul- 

tiple measurements of the Jones matrix and use the average result to 

http://www.lunatechnologies.com/
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compute the displayed parameters. The number of measurements 

that will be acquired and averaged is set by the user in the field 

labeled #. 

• The Scan button starts the measurement of the device under test. 

This same button is used to stop scanning when operating in Con- 

tinuous or Real-Time Mode. The user may scan either before or 

after setting up filters. 
 

Data Processing 

The Data Processing  area of the OVA main window contains controls for setting 

the resolution bandwidth of filters and buttons for applying filters to the acquired 

data. 
 
 
 

 
 

Figure 3-3. The Data Processing area in the main OVA software window. 

 
• In the Filter Resolution BW (pm or GHz) field, the user can 

define the bandwidth of an acausal Gaussian filter (described under 

“The Smoothing Filter” on page 79) that can be applied to the data. 

The filter is applied to the measurement when the Options > 

Always Apply Filter menu item is checked or when the user clicks 

Apply Filter in the Data Processing area. 
 

 

Note  
By default, the Filter Resolution BW, the TD Window Res 
BW, and the Convolved Res BW are all displayed in units 

               of picometers. To change the units to gigahertz, select 
Options  > Resolution BW Units > Gigahertz  (GHz). 
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• Clicking the Apply Filter button applies the acausal Gaussian 

smoothing filter discussed immediately above to all active matrices. 

• Clicking the Time Domain button opens a window displaying the 

impulse response of the selected matrix in the time domain. The 

window provides fields and cursors for adjusting this filter. For 

more information, see “The Time Domain Filter” on page 70. 

• The Matrix for Res BWs Below pull-down menu allows the user 

to select which of the active memory locations will be used for the 

following two data fields. 

• The TD Window Res BW (pm or GHz) field indicates the resolu- 

tion bandwidth set by the time domain filter applied in the Time 

Domain Window. See “The Time Domain Filter” on page 70 for a 

detailed description of this filter. 

• The Convolved Res BW (pm or GHz) field indicates the overall 

wavelength (or frequency) resolution of the data in the memory 

location selected by Matrix for Res BWs Below, taking into 

account both the smoothing and the time domain filters, if applied. 

It is calculated by taking the square root of the sum of the squares 

of the Filter Resolution BW and the TD Window Res BW. More 

details are given under “The Convolved Resolution Bandwidth” on 

page 81. 
 

Display Options 
 

 
 

 
 

Figure 3-4. Display Options area in the main OVA software window. 

 
• Clicking the Sync X-Axes button synchronizes the X-axes of both 

graphs displayed. This feature adjusts only the X-axis scale. The Y- 

axis scale is not affected. If both graphs have X or cross-hair cur- 

sors on when Sync X-Axes is clicked, the cursor style and location 

will also synchronize to the selected graph. 
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• The To field is used to specify whether the software will synchro- 

nize to the top or bottom graph. 
 

Matrix Memory Functions 

The Matrix  Memory  Functions  allow the user to work with up to three data sets 

concurrently in local memory. 
 

 
 

                                                                3 
 

Figure 3-5.  Matrix Memory Functions area in the main OVA software window. 

 
• Checkboxes under Active Matrices show which of the three data 

sets in local memory are superimposed in each graph window. 

Matrix names and Details buttons are grayed out when no data is 

stored in that location. In the example above, data is loaded in 

Matrices A and B, but only A is selected and graphed; Matrix C has 

no data in it. 

• Clicking the Details buttons shows the user the measurement con- 

ditions for the data loaded in that matrix. 

• The Operations lines allow the user to copy data from matrix A to 

B or C. The original data in Matrix A remains in A until new data is 

acquired. 

 
 
 

Important 

New scans are automatically loaded into Matrix A, 

overwriting any data there. To avoid losing data, copy data 

to Matrix B or C, or save it to a file, before performing a 

new scan. 

Note that scans already in Matrix B and C memory cannot 

be swapped. 
 

 

Graphs 

Each Graph area contains controls for selecting the content of the graph and for 

manipulating how the graph is displayed. 
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Figure 3-6. One of two graph areas in the main OVA software window. By default, 

Matrix A is shown in blue, Matrix B red, and Matrix C yellow. 

 
• The Title Bar at the top of each graph is a pull-down menu allow- 

ing the user to select which parameter is graphed. These parameters 

are defined under “Parameter Calculations” on page 217. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3-7. The Title Bar, or parameter selection pull-down menu, at the top of 

each graph area, before (above) and during selection. 
 

• The Graph On/Off Control in the upper right hand corner of each 

graph allows the user to turn off the graphs. When a graph window 
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is turned off, newly scanned data will not be updated in that graph 

window. Turning one graph off allows Continuous Mode and 

Real-Time Mode to operate more quickly. 
 
 
 
 
 

Figure 3-8.  Graph On/Off Control: graph on (left) and graph off (right). 
 

• The X-Axis Label below each graph is a pull-down menu that 

allows the user to select the X-axis units. 
 

 
 
 
 
 
 
 
 

Figure 3-9. X-axis units pull-down menu, before and during selection. 
 

• Buttons to the lower left on each graph allow the user to adjust plot 

axes, cursors, and zoom, and to show or hide a legend. Table 3-1 

describes the function of each button and gives a page number for 

further explanation. 
 

Table 3-1: Graph area buttons  and their function. 
 

Button Description Page 

  
 

Sets the scale of the X-axis to display the full range of the data set. 

 
 

63 

  
 

Sets the scale of the Y-axis to display the full range of the data set. 

 
 

63 
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Button Description Page 

 
 

 
Sets the mouse cursor to a cross-hair that allows the user to move 

graph cursors. 

 
 

66 

 Allows the user to select from the following zoom tools that appear 

in a pop-up menu. A blue border surrounds the selected tool. 
 

 
 
 

Allows the user to click and drag to define a 

“zoom window” in both the X and Y dimen- 

sions. 
• 

Allows the user to click and drag a zoom 

area in the X-axis only. This is the default 

tool active in each graph. 
• 

Allows the user to click and drag a zoom 

area in the Y-axis only. 

Returns the graph to the full scale of all data. 

Zooms in (magnifies) from the point where 

the cursor is located. 
• 

Zooms out from the point where the cursor is 

located. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

64 

 
 

 
Lets the user pan around the data in a graph window by clicking 

on the graph and dragging the cursor. 

 
 

66 
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Toggles the plot legend on or off. The color, style, and width of a 

line may be changed in a menu accessed by clicking within the 

legend. (See “Changing graph style and color” on page 68.) 

 
 

68 

 
 

 
Opens a graph in a full-screen window. (This button does not 

appear in OFDR software.) 

 
 

68 

 Toggles two vertical cursor lines on or off. 

(Note that in optional OFDR software, upper graph vertical cursors 

control the data displayed in the lower graph. See “Updating Lower 

Graph” on page 120.) 

 
 

67 

  
 

Toggles two horizontal cursor lines on or off. 

 
 

67 

  
Toggles twin locked cursor on and off. Regardless of where these 

cursors are dragged, they will intersect the first graph at a data 

point. 

 
 

67 

  
Brings cursors into the viewed portion of the graph. By default, 

cursors appear at 10% and 90% of the X- or Y-axis range. They 

may be dragged by selecting the cross-hair cursor, . 

 
 

67 

 Recalculates the linear and quadratic phase deviation plots. 

Because cursors are attached to the first matrix plotted, only the 

plot of the first matrix displayed is valid. To calculate the phase 

deviation of Matrix C, for example, deselect Matrices A and B in 

the checkboxes in the Matrix Memory Functions area. Then set 

the cursors to the appropriate positions and press the recalculate 

button. Note that this button only appears when either linear or 

quadratic phase deviation is displayed. 

 
 
 
 

68 
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 Allows the user to select from the pop-up menu shown below to 

adjust the appearance of the X-axis scale and grid. Note that this 

button only appears in the Time Domain  Window  or when one 

graph is viewed in the full screen view. 

 
 
 
 
 
 
 

69 

 Allows the user to select from the pop-up menu shown above to 

adjust the appearance of the Y-axis scale and grid. Note that this 

button only appears in the Time Domain  Window  or when one 

graph is viewed in the full screen view. 

 
 

69 

  
Moves the vertical cursors to the peak of the regions highlighted. 

This button is available in the OFDR software (“Optical Frequency 

Domain Reflectometer” on page 95), but not the OVA software. 

 
 

67 

 The center button recalculates the data in the lower graph area 

based on the data in the upper graph highlighted by the yellow (left) 

or orange (right) vertical cursor. These buttons appear in the upper 

left of the lower graph only when the vertical cursors are on in the 

upper graph. Clicking the left button will automatically recalculate 

the lower graph based on the yellow cursor in the upper graph if 

Options  > Display  Options  > Auto-Update Lower Graph is 

checked. Otherwise, the user must click either the yellow or the 

orange button and then hit the recalculate (center) button. Words 

to the left of these buttons show which trace is being displayed in 

the lower graph. 

This button is available in the OFDR software (“Optical Frequency 

Domain Reflectometer” on page 95), but not the OVA software. 

 
 
 
 
 
 
 

120 
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The Menu Bar 

The menu bar contains additional commands for controlling calibration, alignment, 

and for setting various measurement and display options. Menu bar commands are 

organized into five menus. 
 

The File menu 

• Load Data File loads a binary Jones matrix data file previously 

saved by the OVA. A dialog box appears allowing the user to select 

the file, followed by a second dialog box which is used to select 

which of the three matrix memory locations will store the data. (See 

“Loading Saved Data” on page 60 for more information.) 

• Specify Device Descriptor  allows the user to enter information 

about the device under test. This information will appear in the 

upper right heading of printouts. It will also appear in the header of 

spreadsheet files. (See “Printing” on page 82 for more information.) 

• Select Data Save Options calls up a dialog box allowing the user 

to specify which parameters should be included in any saved 

spreadsheet file, and whether or not a binary Jones matrix file 

should be saved as well. The user may select the file extensions for 

both the spreadsheet and binary files. Also in this window, the user 

selects whether or not to apply the current smoothing filter to the 

spreadsheet output. (See “Saving Data” on page 58 for more infor- 

mation.) 

• Save Data Files saves measurement data according to the selec- 

tions in the Select Data Save Options dialog box. (See “To save 

data” on page 59 for more information.) 

• Save Software Settings saves user-selected settings from the 

Options menu and the System Control area; these settings are 

retained the next time the software is run. 

• Print  Data Sheet prints the two graphs as they are displayed. (For 

more information, see “Printing” on page 82.) 

• Exit exits the OVA control software. 

 
The Edit menu 

• Cut may be used to cut user-selected numbers in fields and axes 

and paste them to the clipboard. 

• Copy copies selected numbers from a field or axis to the clipboard. 
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• Paste pastes numbers from the clipboard to a field or axis value. 

• Clear removes selected data from a field or axis value without 

copying it to the clipboard. 
 

The Options  menu 

• Enable High Dynamic Range Averaging, when checked, uses the 

high dynamic range. When unchecked, the normal range is used. If 

this option is grayed out in the menu, it means the higher dynamic 

range was not purchased with the instrument. For more information 

on dynamic range averaging, see page 248. 

• Resolution BW Units toggles the units of the resolution bandwidth 

displays between picometers (pm) and gigahertz (GHz). The default 

setting is picometers. 

• Auto Calibration Settings calls up a dialog box where the user 

may toggle automatic calibration on and off, as well as specify the 

time interval for automatic calibration. (For more information, see 

“Automatic Calibration” on page 42.) 

• Enable Real-Time Mode or Disable Real-Time Mode turns on or 

off Real-Time Mode. (For more information, see “Real-Time 

Mode” on page 52.) 

• Apply Time Domain Window, when checked, applies the Time 

Domain Window settings from Matrix A to newly acquired data. 

For this to function properly, the user must first adjust the Time 

Domain Window and check the Retain Settings box. (See “Apply- 

ing the time domain filter” on page 74.) 
 

Turning Apply Time Domain Window on (checked) and off also updates 

the data currently displayed. If the Apply Time Domain Window is not 

checked (turned off), the Time Domain Resolution Bandwidth will equal 

the minimum resolution of the data. 
 

• Apply Time Domain Hanning  Window allows the user to toggle 

the frequency domain Hanning window on (checked) and off. (See 

“Time Domain Hanning Window” on page 246 for more informa- 

tion.) 

• Always Apply Smoothing Filter, when checked, automatically 

applies the smoothing filter specified by Filter Resolution BW in 

the Data Processing area to current and newly acquired data. When 
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this option is not selected, the Apply Filter button must be clicked 

to apply the filter. (For more information, see “The Smoothing Fil- 

ter” on page 79.) 

• Autoscale Plot Axes. When this option is selected, the plot axes 

automatically scale to include the entire data set in a graph window 

when a new measurement is performed. This option is ignored dur- 

ing operation in Real-Time Mode. 

• Automatically  Find DUT Length. When this option is selected, 

the length of the DUT is automatically found when the Scan button 

is pressed in normal and averaging mode. However, the OVA will 

not automatically find the DUT length in Continuous or Real- 

Time Mode operation. For these modes, the user must click Find 

or enter a DUT length manually in the System Control area. (See 

“Finding the DUT Length” on page 44 for more information.) 

• Remote Interface Setup opens a dialog box allowing the user to 

select a GPIB or TCP/IP interface. It also allows the user to set the 

interface address. The default setting is 1. (For more information on 

remote operation, see “Remote Control Setup Configuration” on 

page 136.) 

• Specify Compression Settings is only available as a purchased 

option. Otherwise it will not appear in the Options menu. For more 

information, see “Pulse Compression” on page 53. 

 
The Tools menu 

• Turn  Laser ON or Turn  Laser OFF allows the user to turn the 

laser on and off. Note that turning on the OVA hardware automati- 

cally turns on the laser. 

• Use OVA as Light Source performs a sweep of the laser through 

the wavelengths specified in the System Control  area, without per- 

forming a scan. This command allows the OVA to function as a tun- 

able light source. Depending on the wavelength range setting, this 

command can take up to 15 seconds to complete. 

• Internal Calibration initiates an instrument calibration that does 

not require the user to connect a reference fiber or polarization con- 

troller. A dialog box allows the user to specify calibration parame- 

ters. (For more information, see “To perform an internal 

calibration” on page 40.) 
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• Full Calibration fully calibrates the system. This requires the user 

to connect either a reference patchcord or polarization controller. A 

dialog box allows the user to specify calibration parameters. (For 

more information, see “To perform a full calibration” on page 37.) 

• Reload Cal Data File allows the user to reload a calibration file 

into memory, should an attempted calibration fail. The OVA soft- 

ware looks for an appropriate calibration file based on the Type of 

Measurement specified in the System Control area. 

• Align Optics performs an alignment of the internal optics of the 

OVA. (See “Aligning the OVA Optics” on page 33 for more infor- 

mation.) 

• Last Calibration Information calls up a dialog box showing the 

conditions and time of the most recent full and internal calibrations. 

(For more information, see “Information on the Last Calibration” 

on page 44.) 

• Check Warm-Up Time displays a timer which counts down one 

hour from the time the OVA hardware was powered on. For optimal 

measurement accuracy and calibration stability, the OVA should be 

allowed to warm up for one hour prior to performing measure- 

ments, even though the laser ready LED will come on before one 

hour has elapsed. 

• Reset Hardware allows the user to reset the OVA hardware with- 

out having to turn off the device. This should only be used in the 

rare event that the device becomes non-responsive. This is useful 

for reestablishing a link to the OVA unit without turning the laser 

off and back on, which would require the laser to warm up again. 

This command will close the software and thus requires the user to 

restart the OVA software. 

 
The Help menu 

• About OVA displays information about the current software ver- 

sion and contact information for Luna Technologies. 
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Performing Measurements 
 
 

Setting Up 
The front panel of the Optical Vector Analyzer contains the power switch and the 

optical connectors necessary to perform reflection and transmission measurements. 

The third connector (marked “aux”) is available for Luna Technologies to customize 

the system at the purchaser’s request. 
 

Four LEDs on the front panel indicate the state of the instrument: 
 

• The Power LED lights when the power is on. 

• Laser On lights after the laser has been turned on. 

• Scanning lights whenever the laser is scanning. 

• USB lights after a scan, while the OVA unit is sending data to the 

PC. 

 
Aligning the OVA Optics 

 

In order to perform accurate measurements, the internal optics of the OVA must be 

properly aligned. The three conditions that require an alignment to be performed 

are listed below. 

 
Alignment must  be performed... 

 

1 When the instrument is initially set up for the first time. 
 

2 Whenever the OVA is physically moved from one location to another. 
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3 Whenever the indicator in the System Status Bar 

is visible. 
 

 
 
 

Important 

Immediately following alignment, the OVA will tend to drift 

out of calibration as the internal mechanical components 

settle. It is highly recommended that the automatic 

calibration interval be set to 0.25 hours for at least one hour 

following alignment (see “To configure automatic 

calibration” on page 42). 
 

 

To align the OVA optics 
 

1 Ensure that the OVA unit is powered on and that the laser is on and ready. 

4 2 Select Tools > Align Optics. 

A dialog box appears instructing the user to disconnect devices. The user may 

opt to Cancel or click OK to continue. 
 

If OK is selected, alignment begins. A status bar shows the progress of the 

alignment. When the alignment is complete, the software returns to the main 

window. 

3 When the alignment is complete, the software will prompt the user to 

perform an internal calibration. It is strongly recommended to select 

“yes” after this prompt. The conditions for this internal calibration are 

determined by the settings previously entered under Tools > Internal 

Calibration. (For more information, see “To perform an internal 

calibration” on page 40.) 

 
Calibrating the System 

The OVA system must be calibrated prior to performing measurements. The OVA 

calibration removes the effects of the measurement network to ensure that the 

measured Jones matrix represents only the device under test. 
 

Calibration Files 

Transmission and reflection measurements each require an independent calibration. 

The most recent calibrations for each measurement type are stored in files, which 

are loaded by the control software upon start-up. If the software is unable to locate 

at least one calibration file, a dialog box will appear to alert the user that a calibration 
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must be performed before a measurement can take place. In this event, the Scan 

button will be unavailable until a calibration has been performed. 
 

Calibration files are saved to the same directory as the OVA.exe file. The default 

directory for OVA.exe is “C:\Program Files\Luna Technologies\OVA” 
 

Calibration Types 

The OVA has two types of calibration. One is a complete transfer function 

measurement, that will remove all instrument network effects from the measurement, 

up to and including the connectors on the front panel. This requires an external 

reference device, and is termed a “full calibration.” In addition to the full calibration, 

there is also an “internal calibration.” An internal calibration is only possible once 

a full calibration has been performed. The internal calibration process corrects for 

any internal drift in the system that has occurred since the last full calibration. It 

will not calibrate out the front panel connector effects if they have been disconnected 

and reconnected since the last full calibration. 
 

The OVA control software can be configured to execute internal calibrations 

automatically at a user-specified time interval. For further information on this 

feature, see “Automatic Calibration” on page 42. 
 

When performing a full calibration, the user has the option of whether or not to 

calibrate for polarization dependent loss. Calibration for PDL requires the use of 

the supplied polarization controller as a reference device, and the user must move 

the polarization controller paddles at prescribed points in the calibration process. If 

the system is not to be calibrated for PDL, the polarization controller is not necessary 

and the calibration process takes less time. 
 

For instructions on selecting these calibration options, see “The Calibration 

Procedure” on page 37. 
 

Conditions that Require Calibration 

In a typical laboratory or manufacturing environment, a full calibration should be 

performed at least once every 72 hours. It is also recommended that an internal 

calibration be performed every 1 to 4 hours. This is easily accomplished by turning 

on the automatic calibration and setting the time interval appropriately (see “To 

configure automatic calibration” on page 42). 
 

The need to recalibrate is largely determined by the surrounding environmental 

conditions. If the temperature is fluctuating rapidly, it may be necessary to set the 
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automatic calibration interval to something less than one hour. If the surrounding 

temperature is very stable, a longer interval may suffice. 
 

A full calibration must be performed whenever the surrounding temperature has 

changed by more than 5 degrees C, or whenever an internal calibration fails to 

bring the instrument back into calibration (see “To check the calibration” on 

page 42). 
 

Following an alignment, the software will prompt the user to perform an internal 

calibration. It is strongly recommended to select “yes” after this prompt. 
 

In certain cases the control software will detect that the internal optics of the 

instrument have drifted, and it will alert the user via the System Status Bar indicator 

. When this occurs an internal calibration will typically suffice. 
 

Considerations Prior to Calibrating 

Take the following considerations into account when calibrating to ensure that the 

calibration is appropriate for the device or devices to be measured, and that the 

subsequent measurements are as accurate as possible. 
 

1 For devices with a narrow pass band (< 5 nm), choose a calibration range 

that is at least twice as wide as the device passband. 
 

2 Effects due to the front panel connectors on the OVA can be removed 

from the measurement by cutting the calibration fiber and splicing the 

device under test into the measurement path, rather than connecting the 

device to the OVA directly. 
 

By connecting a device to the OVA directly, loss measurements are limited by 

the connector repeatability, which can be 0.3 dB or greater for both insertion 
loss and PDL. 

 

3 Calibration is most accurate if the length of the reference fiber (in the 

polarization controller) is close to the same length as the device under 

test, to within 2 m. For long devices, cut the reference fiber and splice 

in a section of standard fiber (Corning SMF 28 or equivalent) that is 

equal to the device length for calibration. Then remove the section when 

performing measurements, and splice the device under test in its place. 
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The Calibration Procedure 

 

To perform  a full  calibration 
 

1 Ensure that the OVA unit is powered on and that the laser is on and ready. 

Select Tools > Check Warm-Up Timer  to make sure the instrument 

is ready. 

2 If the laser is not already on, select Tools > Turn Laser  ON. 
 

By default, the laser comes on when the OVA hardware is turned on. If the laser 

was off, it may take a few minutes to warm up. The Laser Ready light on the 

front of the instrument comes on when the laser reaches operating temperature. 
 

3 Select Tools > Full Calibration. 
 

The following dialog box appears: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-1. Full calibration parameters dialog box. 
 

4 To calibrate for all parameters, including polarization dependent loss 

(PDL), leave the Calibrate System for PDL indicator ON. This option 

requires the use of the supplied polarization controller. 
 

- OR - 
 

If PDL accuracy is not of concern, click the Calibrate System for PDL indicator 

to OFF. With this option the user may substitute a fiber patch cord for the 

polarization controller. 
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5 Select Transmission or Reflection from the Type of Measurement 

pull-down menu. Calibration in reflection requires the supplied gold 

reflector. 
 

6 Type in the Center  Wavelength  appropriate for the device(s) to be 

tested following calibration. 
 

7 Select the desired Wavelength  Range from the pull-down menu. 
 

Note that in order to perform measurements over a broader wavelength range 

than the one selected during calibration, it is necessary to recalibrate. 

8 Enter the Number of Averages to perform. A larger number of averages 

will take more time to calibrate, but will result in more accurate 

measurement data. 
 

9 Click Continue. 
 

The instrument performs several internal scans. Next a prompt appears 

instructing the user to connect the polarization controller, and, if calibrating in 

reflection, the gold reflector. 

10 Before making connections, be sure to clean all fiber optic connectors. 

(See “Cleaning Connectors” on page 255.) 
 

11 For a Transmission calibration, connect the polarization controller to 

the Source and Detector  connectors on the front panel of the OVA. 
 

For a Reflection calibration, connect one end of the polarization controller to 

the Source connector, and connect the other end to the gold reflector. 

12 Align the connector key to fit in the groove in the bulkhead adaptor. 

Turn the screw ring around the connector clockwise until it is just 

tightened. 

13 Click OK. 
 

If the Calibrate System for PDL indicator is OFF, the system will indicate 

when the calibration is complete. 
 

- OR - 
 

If the Calibrate System for PDL indicator is ON, pop-up windows instruct the 

user to change the position of the paddles twice. Here is an example of a paddle 

orientation change sequence: 
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Figure 4-2. Polarization controller, in the beginning paddle position. 

 

 
 

 

Figure 4-3. First paddle position change. 
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4  
Figure 4-4. Second paddle position change. 

 

14 Click OK in the dialog box indicating that the instrument has been 

successfully calibrated. 
 

After calibrating, it is a good idea to check if the calibration was successful. (See 

“Checking the Calibration” on page 41.) 

 
To perform  an internal  calibration 

 

1 If a full calibration has not been performed within the past 72 hours, 

choose a full calibration rather than an internal calibration. 
 

2 Ensure that the OVA unit is powered on and that the laser is on and ready. 

Select Tools > Check Warm-Up Timer  to make sure the instrument 

is ready. 
 

3 If the laser is not already on, select Tools > Turn  Laser  ON. 
 

By default, the laser comes on when the OVA hardware is turned on. If the laser 

was off, it may take a few minutes to warm up. The Laser Ready light on the 

front of the instrument comes on when the laser reaches operating temperature. 

4 Select Tools > Internal Calibration. 
 

The following dialog box appears: 
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Figure 4-5. Internal calibration parameters dialog box. 4 
5   Type in the Center  Wavelength  appropriate for the device(s) to be 

tested following calibration. 
 

6   Select the desired Wavelength  Range from the pull-down menu. 
 

Note that the available range for the internal calibration must lie within the range 

of the previous full calibration. The Center Wavelength  and Wavelength 

Range will be coerced to fall within the available range. 
 

7 Enter the Number of Averages to perform. A larger number of averages 

will take more time to calibrate, but will result in more accurate 

measurement data. 
 

8   Click Continue. 
 

The system will perform the necessary internal calibration scans and indicate 

when the calibration is complete. 
 

Checking the Calibration 

It is a good idea to check the calibration once it is complete to ensure that the system 

will provide accurate data. The following procedure can be used to check both full 

and internal calibrations. 
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To check  the calibration 

 

1 In the case of a full calibration, leave the reference device (patchcord, 

polarization controller, and/or gold reflector) connected to the OVA. 
 

- OR - 
 

In the case of an internal calibration, remove any device that may be connected 

to the OVA. Connect the Source and Detector ports via standard single mode 

fiber (if calibrating in transmission) or connect the supplied gold reflector to the 

Source port (if calibrating in reflection). Note that the use of connectors can 

influence the measurement, so it is recommended that the fiber or reflector be 

spliced into the current front panel connection. 
 

2 Perform a measurement, following the instructions under “To perform 

a single-scan measurement” on page 49. 
 

3 Display the insertion loss graph, following instructions under 

“Manipulating Plots” on page 62. Check that the insertion loss measures 

a nominal value of zero to within the measurement accuracy of the 

instrument. 
 

If PDL has been calibrated, also check the PDL graph to ensure that it also 

displays a nominal value of zero to within the measurement accuracy of the 

instrument. 
 

Automatic Calibration 

The OVA is capable of automatically calibrating itself to compensate for any system 

drift due to changes in the surrounding environment. The automatic calibration 

consists of an internal calibration that occurs at a user-specified time interval. The 

automatic calibration uses the internal calibration settings that are set in the internal 

calibration parameters dialog box (see Figure 4-5 on page 41). Note that in order to 

change the settings, an internal calibration must be performed for new settings to 

take effect. 

 
To configure automatic calibration 

 

1 Follow the instructions “To perform an internal calibration” on page 40, 

setting the internal calibration parameters to the desired values for the 

automatic calibration. 
 

2 Select Options  > Auto Calibration Settings. 
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The following dialog box appears: 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-6. The Automatic Calibration Settings dialog box. 

 

3 To turn automatic calibration on, click to ensure the Auto Calibration 

(On/Off) indicator is lit: . 
 

-OR- 
 

To turn automatic calibration off, click to ensure the Auto Calibration 

(On/Off) indicator is off: . 
 

4 Select the desired frequency for the automatic calibration from the 

Calibration Interval (hrs) drop-down menu. The menu choices are 

0.25, 0.5, 1, 2, 4, or 8 hours. 
 

5 Click OK to complete the automatic calibration configuration. 
 

When the specified interval has elapsed, the prompt shown below will appear. 
 

 
 
 
 
 
 
 
 
 

Figure 4-7. The automatic calibration prompt. 
 

Clicking the Calibrate Now button will start an internal calibration immediately. 

If there is no user response, the calibration will begin after 10 seconds. 
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Note that if the OVA instrument is scanning, the automatic calibration prompt 

will not appear until the scans are completed. 

 
Information on the Last Calibration 

The user may verify the time and conditions of the last calibration by selecting Tools 

> Last Calibration Information. The dialog box shown below appears, showing 

the type, wavelength range, number of averages, DUT length, and time of the most 

recent full calibration. The user can click on the Internal Calibration tab to check 

those conditions. Note that the user must click on the third tab to close this window. 
 
 
 

4 
 

 
 
 
 
 
 
 
 
 

Figure 4-8. The Last Calibration Information window. 
 

 

Finding the DUT Length 
Because the OVA is an interferometric measurement system, the length of the device 

under test (DUT) must be known prior to the measurement. If the length is known 

to within 0.1 m, the user may input the value manually. Otherwise, the instrument 

can measure the length of the device. 
 

Please note that for transmission measurements, the length is defined as the length 

of fiber between the Source and Detector connectors on the front panel of the OVA. 
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For reflection measurements, the device length is defined as the length of fiber 

between the Source connector and the point of reflection within the device. 

 
 

Important 

For the OVA instrument to operate properly, the total 

device length (including leads) must not be greater than 

the specification of your instrument for a transmission 

measurement, or half that length for a reflection 

measurement. 
 

 

Length Measurement Methods 

In order to measure the length of the device correctly, the user must select one of 

two measurement methods: Broadband and Narrowband. In general, broadband 

is used for devices that may stop a small portion of the light, but pass light over 

most wavelengths. (A bare fiber is the limiting case of a broadband device.) 

Narrowband is used for devices that pass a small portion of light, but stop light at 

most wavelengths. The descriptors “broad” and “narrow” are relative to the current 

scan range setting of the instrument. See Figure 4-9 for representations of typical 

broadband and narrowband loss curves. 
 

Selecting the proper DUT length finding method does require some knowledge about 

the spectral properties of the DUT prior to measurement. In most cases, simply 

knowing the type of device is enough information to select the proper DUT length 

finding method. Table 4-1 shows the correct DUT length finding method for various 

common devices. 
 

Table 4-1: DUT length finding methods for common devices 
 

 
 
 

 
Broadband 

Single mode fiber 

Coupler input to output 

Bragg grating in transmission 

Thin film filter in reflection 

Interleaver 

Polarization controller 
 
 

Narrowband 
Bragg grating in reflection 

Thin film filter in transmission 
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If nothing is known about the device, try either method, and repeat the measurement. 

If the method selection is incorrect, the measured length will generally not be 

repeatable. A repeatable measurement is most likely a correct measurement. 
 

For more detailed information about how the OVA measures the length of the device, 

see “The OVA Device Length Finding Methods” on page 236. 
 

 
Broadband  Narrowband 

 
 

For these two cases, either 

method is likely to work 

because about 1/2 of the light 

4 
is passed and 1/2 is stopped.

 

 
 
 
 
 

 
wavelength 

 
 
 
 
 

 
wavelength 

 
 
 
 
 
 
 
 

wavelength wavelength 

 
 
 
 
 
 
 

 
wavelength wavelength 

 

 
 

Limit: Bare fiber 
 
 
Limit: No transmission 

 

 
wavelength wavelength 

 
Figure 4-9. Typical broadband and narrowband loss curves 
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The Device Length Measurement Procedure 

 

To find  the length  of the DUT 
 

1 Be sure that the instrument has been aligned (See “Aligning the OVA 

Optics” on page 33) and calibrated (See “The Calibration Procedure” 

on page 37) within the recommended time period.) 
 

2 Before connecting the device to the OVA, be sure to clean all fiber optic 

connectors. (See “Cleaning Connectors” on page 255.) 
 

3 Connect the device to the OVA. A transmission device must be 

connected to both the Source and Detector  connectors. A reflection 

device need only be connected to the Source detector. 
 

4 Select Transmission or Reflection from the Type of Measurement 

pull-down menu in the System Control  area. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-10. The settings for finding the length of the DUT are set 

in the System Control area of the main screen 
 

5 Enter an appropriate Center  Wavelength  and select a Wavelength 

Range from the pull-down menu. 
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If the desired scan range falls outside the range of the most recent calibration, 

either select a different scan range or recalibrate the OVA. 

 
 

Important 

For narrowband devices, the DUT length find algorithm 

may fail if the correct wavelength range is not specified. 

If this range does not include the passband of the device, 

no light will be passed and the instrument will not be able 

to find the length. 
 

 

6 Select Broadband or Narrowband from the DUT Length  Find 

Method  pull-down menu. 
 

7 Click the blue button marked Find, next to Length  of DUT. 
 

The system then updates the Length  of DUT field. 

 

High Dynamic Range Averaging 
The OVA may be purchased with an option for enhanced dynamic range averaging, 

which extends the loss measurement range. Please read “High Dynamic Range 

Averaging” on page 248 to ascertain whether high dynamic range averaging is 

advantageous for a given measurement. 

 
To use high dynamic  range averaging 

 

1 Make sure Options > Enable High Dynamic Range Averaging is on, 

or checked. If this option is grayed out, it was not purchased with the 

software. 
 

2 Follow the instructions below for “Averaging Mode” on page 50. 

 
Acquiring Data 

The OVA has four different options for data acquisition: single scan, averaged scans, 

continuous mode, and real-time mode. Each mode performs a complete measurement 

of the Jones matrix of the device under test, and all parameters are available from 

measurements done in any mode. 
 

 
Important  Before testing, clean the fiber optic connectors with the 

appropriate cleaner to guard against errors. For 

instructions, see “Cleaning Connectors” on page 255. 
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Single-Scan Mode 

The single-scan measurement represents the basic functionality of the OVA. In this 

mode the instrument performs a single sweep of the laser over the selected 

wavelength range, and acquires the Jones matrix of the device under test over that 

range. 
 

To perform  a single-scan measurement 
 

1 Ensure that the OVA unit is powered on and that the laser is on and ready. 

Select Tools > Check Warm-Up Timer  to make sure the instrument 

is ready. 
 

2 If the laser is not already on, select Tools > Turn Laser  ON. 
 

By default, the laser comes on when the hardware is turned on. If the laser was 

off, it may take a few minutes to warm up. The Laser  Ready light comes on 

when the laser reaches operating temperature. 
 

3 Be sure that the instrument has been aligned (See “Aligning the OVA 

Optics” on page 33) and calibrated (See “The Calibration Procedure” 

on page 37) within the recommended time period. 
 

4 Before connecting the device to the OVA, be sure to clean all fiber optic 

connectors. (See “Cleaning Connectors” on page 255.) 
 

5 Connect the device to the OVA. A transmission device must be 

connected to both the Source and Detector  connectors. A reflection 

device need only be connected to the Source detector. 
 

6 Select Transmission or Reflection from the Type of Measurement 

pull-down menu in the System Control  area. 
 

7 Enter an appropriate Center  Wavelength  and select a Wavelength 

Range from the pull-down menu. 
 

If the desired scan range falls outside the range of the most recent calibration, 

either select a different scan range or recalibrate the OVA. 

8 Enter the length of the device (including leads) in the Length of DUT 

field. 
 

- OR - 
 

To have the OVA find the length of the DUT, follow steps seven (7) and eight 

(8) under “The Device Length Measurement Procedure” on page 47. 
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- OR - 

 

To have the OVA find the length of the DUT automatically before each scan, 

select Broadband or Narrowband from the DUT Length  Find Method pull- 

down menu. Then select Options > Automatically Find DUT Length. A check 

mark by this menu item indicates that the OVA will measure the DUT length 

before each scan. 
 

9 Check the Options menu for functions to be applied to the scan, such 

as automatic filters or autoscaling. These may also be applied after 

scanning. 
 

10 Click Scan. 
 

The instrument performs the measurement and the software displays the test 

data. 
 

Averaging Mode 

Averaging multiple scans is an effective way to reduce measurement noise and 

increase measurement accuracy. 

 
 

Important 

The device under test must not move or change during 

scanning. Therefore care must be taken not to bump the 

device or expose it to excessive vibrations, especially 

when scanning long wavelength ranges and/or averaging 

large numbers of scans. 
 

 

To average multiple scans 
 

1 In the System Control area of the main window, click to select Enable 

Averaging, then type the number of scans to average in the # field. 
 

2 Follow the same measurement procedure as was outlined above under 

“To perform a single-scan measurement” on page 49. 
 

3 A dialog box appears showing the status of the scans. The scans may 

be stopped by clicking Cancel in this dialog box. 
 

When scanning is completed, the software displays the average of the specified 

number of scans. 
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Continuous Scan Mode 

Continuous scan mode takes advantage of the fast measurement speed of the OVA 

to monitor devices whose properties may change slowly with time. It is particularly 

useful for short (<5 nm) scan ranges, where the update rate is fast enough to allow 

for near real-time device monitoring. 
 
 

Important  
For accurate measurements, the device must change 

slowly enough that its properties remain constant while 

               data is acquired. The blue “Scanning” LED on the OVA 
turns on during data acquisition, indicating this time scale. 

 

 

When continuous scan mode is operating, the user cannot move data from Matrix 

A to Matrix B or C. To move data, stop scanning by clicking the grayed Scan button 

in the System Control  area. Then click the A->B or A->C button in the Matrix 

Memory  Functions  area. To resume continuous scanning, click the Scan button 

again. 

 
To scan continuously 

 

1 In the System Control  area of the main window, select Continuous 

Scan Mode. 
 

2 Optional: To gain more speed, set the Graph On/Off Control  in the 

upper right corner of one of the graphs to the off position: . 
 

3 Follow the same measurement procedure as was outlined above under 

“To perform a single-scan measurement”. 
 
 

Important  
Even if Options  > Automatically Find DUT Length  is 

selected, the OVA software will not find the length of the 

               DUT automatically in continuous or real-time mode. It must 
be entered or measured before scanning. 

 
 

The Scan button will turn gray during continuous scanning. 

The active graph window(s) will update after each scan. 

4 To stop scanning, press the grayed Scan button again. 
 

The data stored in local memory will be from the last measurement. 
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Real-Time Mode 

Real-time mode disables several software features in order to acquire data as quickly 

as possible. Like continuous mode, it is most useful for short (<5 nm) scan ranges. 

The menu and graph controls that are enabled will not take effect until after real- 

time scanning is stopped. 
 

The filters selected under the menu settings Options  > Apply Time Domain 

Window and Options > Always Apply Filter will be applied during real-time mode. 

Deselecting these filter options will allow real-time mode to operate more quickly. 

 
 

Important 

4 

When turning on Options  > Apply  Time Domain 

Window,  be sure to adjust this filter for Matrix  A in the 

Time Domain  Window  and select the Retain Settings 

checkbox. Otherwise the default time domain filter will 

apply. 
 

 

Users should note that the OVA software will not check if the system goes out of 

calibration or alignment during real-time mode. Nor will the system perform 

automatic calibrations. Ensure that the system has been aligned and calibrated before 

entering real-time mode. The user may perform a single scan after exiting real-time 

mode to verify that the system is still aligned and calibrated. 

 
To perform  real-time  scans 

 

1 Select Options  > Enable  Real-Time  Mode. 
 

2 To gain more speed, set the Graph On/Off Control  in the upper right 

corner of one of the graphs to the off position: . 
 

3 Select the parameter(s) to be displayed in the active plot window(s). 

Note that the parameter selection cannot be changed while scanning in 

real-time mode. 
 

4 Make any desired menu changes before scanning, as changes cannot be 

made during real-time mode scanning. For example, turn filters on 

(checked) or off (not checked) under the menu settings Options > Apply 

Time Domain Window and Options  > Always Apply Filter. As 

always, Options > Time Segment Length must be set before scanning. 

Note that autoscaling does not function during real-time mode. 
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5 Follow the same measurement procedure as was outlined above under 

“To perform a single-scan measurement”. 
 
 

Important  
Even if Options  > Automatically Find DUT Length  is 

selected, the OVA software will not find the length of the 

               DUT automatically in continuous or real-time mode. It must 
be entered or measured before scanning. 

 

 

The Scan button will turn gray while scanning in real-time mode. 

The active graph window(s) will update after each scan. 

6 During scanning, the user may press “Ctrl-F5” to display the Update 

Rate indicator (shown below) in the System Status  Bar.  4 
 

 

7 To stop scanning, press the Scan button again. 
 

The data stored in local memory will be from the last measurement. 

 
Pulse Compression 

The OVA may be purchased with the option to compress the impulse response when 

performing scans. If purchased, this may be set by selecting Options  > Pulse 

Compression  Settings. The following dialog box appears. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-11. Pulse compression settings dialog box. 
 

The user must enable compression in the dialog box above, and enter the Average 

Dispersion (ps/mm), Reference Wavelength (nm), and Dispersion Slope (ps/nm2) 
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prior to scanning. These values are generally known, but may also be calculated 

following the procedure below. (For theoretical background, see “Pulse 

Compression” on page 250.) 
 

Calculating Average Dispersion and Dispersion Slope 

To calculate or confirm the average dispersion and dispersion slope of the DUT, the 

user may follow the steps below, using Luna Technologies’ OFDR software: 

1 Measure the DUT using OFDR software. 
 

2 Save the group delay data in a text file. 
 

3 Using appropriate curve analysis software, fit the group delay data to a 

line. The slope of this line is the Average Dispersion,  da, in ps/nm. 

4 Subtract da from the group delay curve. 

5 Perform a second order fit on the remaining curve versus  – ref , 

where ref  is the Reference  Wavelength,  or the center of the 
wavelength window. 

 

6 Multiply the second order coefficient by two (2) to obtain the Dispersion 

Slope, ds , in ps/nm2. 
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Data Processing and Display 
 
 

Once a measurement has been performed, the OVA control software provides many 

tools for manipulating and displaying measured data. Up to three data sets may be 

stored in the local memory of the software, or data may be saved to a file in either 

a binary or spreadsheet format. Data stored in the local memory of the software can 

be used to display any of the parameters described under “Parameter Calculations” 

on page 217. The software also provides two independent filters for smoothing the 

data and reducing measurement noise. Also included are powerful zoom and cursor 

features to enhance the usefulness of the display. 
 

Examples in this chapter use data provided with the software and compiled from 

actual measurements using the OVA. These sample data files are located in the 

directory “C:\Program  Files\Luna Technologies\OVA Software\Sample Data.” 

 
Matrix Memory Functions 

 

The OVA control software allows the user to store up to three data sets in active 

memory. These three memory locations are denoted Matrices A, B and C. The most 

recent measurement is always stored in Matrix A. 
 
 

Important  
New scans are automatically loaded into Matrix A, 

overwriting any data there. To avoid losing data, see 

               “Moving Data in Local Memory” below, or “Saving and 
Loading Data Files” on page 57. 

 

 

Moving Data in Local Memory 

Data from Matrix  A may be moved to Matrix  B or C by clicking the oval labeled 

A->B or A->C, respectively, under the Operations column of the Matrix Memory 

Functions  area shown in Figure 5-1. The original data in Matrix  A remains in A 

until new data is acquired. Note that scans already in Matrices  B and C cannot be 

swapped. 
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Figure 5-1. The Matrix Memory Functions area in the main OVA software window. 

 

Displaying Stored Data 

The control software can display any combination of Matrices  A, B, and C 

simultaneously in the graph windows. By default the data in Matrix  A is plotted 

as a blue curve, Matrix  B is red, and Matrix  C is yellow. In the example in Figure 

5-1 above: 

5 1 Matrix  A contains data, as indicated by the white name and checkbox 
and the blue Details buttons. Matrix  A is being graphed, as indicated 
by the filled-in checkbox. To clear this graph, click to clear the checkbox 

by Matrix  A. 

2 Matrix  B also contains data but is not being graphed. Clicking in the 

second checkbox adds Matrix  B to the graph window. 
 

3 Matrix  C has no data in it, as indicated by the grayed name and lack 

of a Details button. To overlay a third plot, the user would have to load 

data into Matrix  C. 
 

When data is loaded into local memory (by selecting File > Load Data File), it is 

automatically displayed in the graph window. However, when data is moved within 

local memory (by clicking A->B or B->C), the user must then click in the 

corresponding Active Matrices  checkbox to display the moved data. 
 

Matrix Details 

Clicking the Details buttons in the Matrix  Memory  Functions  area calls up the 

window shown in Figure 5-2. This window lists the System Control values that were 

set by the user prior to scanning the data in that matrix. 
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Figure 5-2. Matrix Details window. 

 

Saving and Loading Data Files 
The OVA control software provides two different options for saving data files. One 

is a binary data format that completely captures the measured Jones matrix data and 

stores it in a format that can be loaded back into the control software at a later time 

for further manipulation. This format does not store filter settings, as the filters may 

be set to any value once the data has been loaded back into the control software. 
 

The second format is a text file in a tab-delimited spreadsheet format. The content 

of this file is selected by the user from the list of all calculated parameters and reflects 

user-selected filter settings. (See step 5 under “To specify options for saving data” 

on page 58 for instructions on applying filters to spreadsheets.) Data saved in the 

spreadsheet format cannot be loaded back into the control software. 
 

It is highly recommended that the binary data format be chosen over the spreadsheet 

format for data archives. The binary format stores all measurement information, 

whereas the spreadsheet format stores only a subset of the measured information 

because it can incorporate filter settings. Furthermore, a spreadsheet file can always 

be generated from a binary file at a later date, but a binary file cannot be generated 

from a spreadsheet file. Finally, other data analysis software packages available from 
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Luna Technologies accept only the binary data format produced by the OVA control 

software. 

 
Saving Data 

Prior to saving data, the user may customize the format, content, and file extensions 

of saved data files. The following procedure sets options that will affect how the 

command File > Save Data saves measurement data. 

 
To specify  options for saving  data 

 

1 Select File > Select Data Save Options 
 

The Select Data Save Options dialog box shown below opens. 
 

 
 

5 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 5-3. Select Data Save Options dialog box. 
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2 To save a binary Jones matrix data file, ensure that the Save Raw 

Measurement Data checkbox is checked. In order to save only a binary 

data file, click the Clear  All button under the Spreadsheet Selections. 
 

 
Important  

A saved binary data file includes only the original data from 

a scan, not data that has been filtered. 

 
 

- OR - 
 

To save a spreadsheet file only, click to clear the Raw Measurement Data 

checkbox and check the desired Spreadsheet Selections. 
 

3 To change the extension of the binary data file, type the extension in 

the Raw Data File Extension text box. 
 

To change the extension of the spreadsheet file, type the extension in the 

Spreadsheet File Extension  text box. 
 

4 Select the types of data to be included in spreadsheet files by clicking 

to select or clear the spreadsheet data option checkboxes. If all options 

are cleared then no spreadsheet file will be saved. 
 

5 Select whether or not to Apply Smoothing Filter  to Spreadsheet 

Output. When this box is checked, the smoothing filter will be applied 

according to the Filter Resolution BW set in the Data Processing area. 

If Options > Apply Time Domain Filter is checked, the Time Domain 

Window will be applied to the data as well. 
 

6 Click OK. 
 

The control software saves the selected options. 

 
To save data 

 

1 Select File > Save Data Files. 
 

A dialog box appears. 
 

2 Select the file destination and enter a file name. The file extension(s) 

will be added automatically according to the configuration set using File 

> Select Data Save Options. 
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If the Save Raw Measurement Data checkbox (in the File > Select Data Save 

Options window) is checked, the software will append “.bin” (or another user- 

specified extension) to the file name and save the raw Jones matrix data. If at 

least one of the Spreadsheet Data Save Options is checked, the software will 

append “.txt” (or another user-specified extension) to the file name and save 

spreadsheet data. If both of these options are checked, the software will save 

two files with the same file name but different extensions. 
 

3 Click Save. 
 

Loading Saved Data 

Only data saved in the binary Jones matrix format can be loaded into the control 

software. Sample data files are located in the directory “C:\Program Files\Luna 

Technologies\OVA Software\Sample Data.” 

 
To load a saved data file 

 

1 Select File > Load Data File from the pull-down menu. 
 

2 In the dialog box that appears, choose the desired file and click Open. 

(To follow the examples in this chapter, open the file “C:\Program 

Files\Luna Technologies\OVA Software\Sample Data\Bragg 

Reflection.dat.”) 
 

The Matrix  Selection dialog box opens: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-4. The Matrix Selection dialog box appears after 

selecting File > Load Data File. 
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3   Select a target matrix memory location for the data file, and then click 

Continue.  (In the examples in this chapter, Matrix  A was selected.) 
 

If the user selects a matrix that already contains data, the software will ask for 

confirmation to overwrite that data. Clicking Yes overwrites the data. Clicking 

No gives the user a chance to select a different matrix destination or to cancel. 
 

The selected matrix memory location becomes active and the data appears in 

the graphs in the main window. 
 

Spreadsheet File Data Values by Column 

Table 5-1 shows the order in which the measured parameters appear in the columns 

of a spreadsheet file. If any of the parameters are not selected to save under File > 

Select Data Save Options, parameters in later columns shift over to the left. 
 

Table 5-1: Spreadsheet Output 
 

Column Value Column Value 

1 or a Wavelength (nm) 14 or n JM Element a Phase 

2 or b Frequency (GHz) 15 or o JM Element b Phase 

3 or c Insertion loss (dB) 16 or p JM Element c Phase 

4 or d Group delay (ps) 17 or q JM Element d Phase 

5 or e Chromatic Dispersion (ps/nm) 18 or r X-axis - Time (ns) 

6 or f Polarization Dependent Loss (dB) 19 or s Time Domain (Amplitude) (GW/J) 

7 or g Polarization Mode Dispersion (ps) 20 or t Time Domain (Wavelength) (nm) 

8 or h Linear Phase Deviation (rad) 21 or u Max Loss (dB) 

9 or i Quadratic Phase Deviation (rad) 22 or v Min Loss (dB) 

10 or j JM Element a Amplitude 23 or w Second Order PMD (ps2) 

11 or k JM Element b Amplitude 24 or x Phase Ripple Linear (rad) 

12 or l JM Element c Amplitude 25 or y Phase Ripple Quadratic (rad) 

13 or m JM Element d Amplitude   
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Manipulating Plots 
The OVA control software gives the user great control over the content and 

appearance of the data plots. This section covers plot selection, zooming and scaling 

tools, and cursors. 
 

Plot Selection 

The user can control the content of the two graphs in the main window from a list 

of parameters in the Title Bars. By default, the top graph displays insertion loss, 

and the bottom graph displays group delay. 
 

To change the content  of a graph  window 
 

1 Click on the Title Bar of the graph. A drop-down list of the available 

plot parameters appears. 

5 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-5. Graph window showing the Title Bar pulled down 

for parameter selection. 
 

2 Drag the cursor to the desired parameter from the list. 
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3 The content of the graph changes, as do the title and the axis labels (if 

necessary). 

 
 
 
 

Important 

The cursors are used to calculate the linear and quadratic 

phase deviation plots. Because cursors are attached to the 

first matrix plotted, only the plot of the first matrix displayed 

is valid. So to calculate the phase deviation of Matrix C, 

for example, deselect Matrices A and B in the checkboxes 

in the Matrix  Memory  Functions area. Then set the 

vertical cursors to the appropriate positions and press the 

recalculate button, . 
 

 

Scaling Plot Axes 

The OVA control software provides several ways for adjusting the scaling of the 

graph windows. 

Autoscaling 5 
 

Autoscaling refers to the automatic adjustment of plot axes so that all of the data 

fits in the graph window. 
 

By default, the graph windows will autoscale when new data is acquired, either by 

performing a measurement or loading a data file. To toggle this feature on and off 

select Options > Autoscale Plot Axes. A check mark next to this selection indicates 

that autoscaling is turned on. 
 

At other times, the user may rescale each plot axis independently by using the X- 

and Y-axis autoscale buttons,         and        , located in the lower left corner of each 

graph window. 

 
Manual scaling 

 

The plot axes may be scaled manually by double-clicking on either the lowest or 

highest value labeled on the axis and typing in a new value. To accept the new value, 

press enter or click anywhere in the screen. 
 

Note that by using this method it is possible to flip the graph so that increasing values 

on the X-axis run from right to left, and increasing values on the Y-axis run from 

top to bottom. Typically this is to be avoided, so be sure to enter appropriate values. 
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Synchronizing  X-axes 

 

Clicking the Sync X-Axes button in the Display Options area synchronizes the X- 

axes of both graphs to the graph area selected in the To field. This feature adjusts 

only the X-axis scale. The Y-axis scale is not affected. Note that the two graphs must 

be displayed in the same units in order to synchronize them. 
 

 
 

 
 

Figure 5-6. Display Options area in the main OVA software window. 
 

If both graphs have X or cross-hair cursors on when Sync X-Axes is clicked, the 

cursor style and location will synchronize to the graph selected in the To field. 

 
Using zoom tools 

 

There are six available zoom tools, which are accessible by clicking the zoom menu 

button,  , located in the lower left corner of each graph window. 
 

When this button is clicked, a pop-up window containing the six zoom tools opens: 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-7. Zoom tools pop-up menu. A blue border surrounds the selected tool. 

 

The zoom window  tool: 

This tool allows the user to zoom in on a rectangular region of the graph window. 

To use this tool, first select it from the zoom menu button. Then click in the graph 

window and hold the mouse button to define one corner of the rectangular region. 

Then drag the mouse cursor and note that a dotted box appears with corners defined 
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by the original click position and the current mouse cursor position. Drag the box 

around the desired region of the graph window and release the mouse button. Both 

the X- and Y-axis scales adjust so that the selected region fills the entire graph 

window. 
 

The X-axis zoom tool: 
 

This tool allows the user to zoom in on a region of the X-axis only, without adjusting 

the Y-axis scale. This is the default tool active in each graph when the software is 

opened. 
 

To use this tool, first select it from the zoom menu button. Then click in the graph 

window and hold the mouse button to define one edge of the desired X-axis region. 

Drag the mouse cursor to the other edge of the desired region and note that a fixed 

vertical dotted line appears where the original click occurred, and another follows 

the mouse cursor. When the cursor is positioned at the other edge of the desired 

region, release the mouse button. The X-axis scale adjusts to show only the selected 

region. 

 
The Y-axis zoom tool: 

 

This tool allows the user to zoom in on a region of the Y-axis only, without adjusting 

the X-axis scale. 
 

To use this tool, first select it from the zoom menu button. Then click in the graph 

window and hold the mouse button to define one edge of the desired Y-axis region. 

Drag the mouse cursor to the other edge of the desired region, and note that a fixed 

horizontal dotted line appears where the original click occurred, and another follows 

the mouse cursor. When the cursor is positioned at the other edge of the desired 

region, release the mouse button. The Y-axis scale adjusts to show only the selected 

region. 

 
The return  to full  zoom tool: 

 

Selecting this button from the zoom menu returns the graph to the full scale of all 

data. 

 
The zoom in tool: 

 

This tool allows the user to zoom in (magnify) the graph from the point where the 

cursor is clicked. 
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To use this tool, first select it from the zoom menu button. Then click once to magnify 

once; or click, hold and release to magnify several times at the cursor location. 

 
The zoom out tool: 

This tool allows the user to zoom out from the point where the cursor is clicked. 

To use this tool, first select it from the zoom menu button. Then click once to zoom 

out once; or click, hold and release to zoom out several times at the cursor location. 

 
The pan tool: 

 

This tool lets the user pan around the data in a graph window. To use this tool, first 

select it from the button menu, then click on the graph and drag the cursor. 
 

Using Cursors and Legends 

5 Cursors 

The OVA software offers three types of cursors. By default, vertical cursors and twin 
locked cursors appear at 10% and 90% of the X-axis range. Horizontal cursors appear 

at 10% and 90% of the Y-axis range. To move the cursors, select the cross-hair,        , 

then click, drag, and release the cursor. 
 

When any of the cursors are on, a legend appears in the upper right corner giving 

the exact location of the cursors in the units currently selected. The legend also 

indicates the distance between the two cursors (dX for vertical cursors, dY for 

horizontal cursors, and dX and dY for twin locked cursors). 
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Figure 5-8. Graph window with vertical cursors appearing at the default location. 

The legend at the upper right gives the precise location 

of the cursors and the distance between them (dX in this case). 

 
Vertical  cursors: 

 

Clicking this button toggles two vertical cursors on or off. 
 

Horizontal cursors: 
 

Clicking this button toggles two horizontal cursors on or off. 
 

Twin locked  cursors: 
 

Clicking this button toggles twin locked cursors on and off. Regardless of where 

these cursors are dragged, they will intersect the graph at a data point on the first 

matrix displayed. So to use twin locked cursors on Matrix C, for example, deselect 

Matrices  A and B in the checkboxes in the Matrix  Memory  Functions  area. 
 

Bring  cursors to center: 
 

Clicking this button brings the active cursors into the viewed portion of the graph. 
 

Move cursors to peak: 
 

Clicking this button moves the two vertical cursors to the peaks of the regions 

highlighted by each cursor. Simply click on this button when the vertical cursors 

are on. 
 

(Note that this button is available in the OFDR software, but not the OVA software.) 
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Legend 

 

A plot legend can be displayed by clicking the          button in the graph window. 

The legend lists the matrix, parameter, and color of all plots currently displayed. 

 
Changing  graph style and color 

 

The user may change the color or line style of an individual graph by first turning 

on the legend. Next, click inside the legend on the name of the curve to be adjusted. 

This calls up a menu which allows the user to select line color, style (dashed or solid), 

and width. 
 

Recalculating Phase Deviation 

The linear and quadratic phase deviation calculations require a curve fit over some 

portion of the measurement spectrum. (See “Linear phase deviation” and “Quadratic 

phase deviation” beginning on page 223.) When either of these quantities are 

selected in the Title Bar of either graph, the vertical cursor positions are used to 

define this curve fit region. To recalculate the phase deviation using a curve fit over 

just the device passband, position the vertical cursors at each end of the passband 

and click the recalculate button, . Because cursors are attached to the first matrix 

plotted, only the plot of the first matrix displayed is valid. To calculate the phase 

deviation of Matrix  C, for example, deselect Matrices  A and B in the checkboxes 

in the Matrix  Memory  Functions  area. 
 

Full Screen View 

To view an enlarged graph of a given parameter, first select that parameter as 

described under “Plot Selection” on page 62. Then click on the full screen view 

button, , of the desired graph. A full screen view of the graph appears, as shown 

below. 
 

(Note that this button is available in the OVA software, but not the OFDR software.) 
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Figure 5-9. Full screen view of insertion loss of a Bragg grating. 

 
The same zoom tools and axis autoscale buttons described above are available in 

full screen view. However, the legend and cursor buttons are not available. The user 

may enter X and Y values in the lower right corner in order to view up to two 

horizontal and vertical cursors. To remove these cursors, enter a value outside the 

viewing range. 

 
X- and Y-axis formatting buttons: 

 

Full screen view also offers two buttons for controlling how the X-axis and Y-axis 

units appear. These buttons call up the pop-up menu shown below to adjust the 

appearance of the X-axis scale and grid. [Note that these buttons are also available 

in the Time Domain Window (see Figure 5-11 on page 72).] 
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Figure 5-10. X- or Y-axis format menu. 
 

Using this menu, the user may select the Format (decimal, scientific, binary, etc.), 

Precision (number of significant digits), and Mapping Mode (linear or logarithmic) 

of the axes. Clicking the Visible Scale and Visible Scale Label menu selections 

toggles the axis scale and label on and off. The final menu item allows the user to 

adjust the Grid  Color. 
 

The user may print this single graph by clicking the Print button in the lower center. 

To exit full screen view, click on the blue Close button. 

 

Filtering Data 
The OVA control software provides two methods for filtering data. The first is a 

time domain filter that is applied to the raw Jones matrix data. It is used to select 

a portion of the time domain information to be included in the frequency domain 

representation of the Jones matrix. The second filter is a smoothing filter that is 

applied to the parametric data calculated from the Jones matrix. It applies an acausal 

Gaussian filter to each parameter after it has been extracted from the Jones matrix. 
 

Both of these filters can be characterized in terms of a resolution bandwidth. The 

resolution bandwidth refers to the smallest frequency (or wavelength) interval over 

which spectral features are discernible in the filtered data. Note that this is not the 

same as the spacing between data points. The resolution bandwidth changes 

depending on filter settings, whereas the spacing between data points remains 

constant. 
 

The Time Domain Filter 

The time domain filter allows the user to select a portion of the time domain for 

inclusion in the measurement. This is an effective way to reduce the amount of noise 
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in the displayed data without losing any information about the device under test. 

The impulse response of the device under test is typically recognizable as a peak 

in the time domain; as long as the complete peak remains in the selection, all of the 

information about the device is preserved. This section will describe how the time 

domain filter is used in a practical sense. For detailed information on the filter 

function itself, see “The time domain filter function” on page 244. 
 

 
Important  

This filter operates directly on the Jones matrix data prior 

to any parameter calculations. 

 
 

The time domain  plot window 
 

To adjust and apply the time domain filter, click the button in the 

Data Processing  area. The window shown in Figure 5-11 appears. 
 

The white curve in the impulse response plot window is the sum of the discrete 

Fourier transforms of the four raw, measured Jones matrix elements. The purple 

curve is the filter function, which has a flat-top Gaussian shape. The yellow cursors 

act as handles to define the filter passband. By default, the X-axis range is fixed at 

approximately 6 ns and is labeled in nanoseconds. The Y-axis is scaled in arbitrary 

units. The X-axis may also be scaled in meters by clicking on the axis label and 

selecting Length  from the drop-down menu. 
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Figure 5-11. The Time Domain Window, showing the impulse response (in white) 

of a fiber Bragg grating in reflection (sample data file “Bragg Reflection.dat”). 

The time domain filter function is shown in purple, and the cursors are yellow. 

 
To adjust  data that extends  out of the Time Domain  Window 

 

The OVA is capable of making accurate measurements only if the complete impulse 

response of the device fits within the range of the impulse response plot window. 

If the impulse response extends outside of the plot range, there are two possible 

remedies: 
 

1 If the impulse response extends out of the Time Domain Window in 

only one direction, it may be because the Length of DUT setting in the 

System Control  area of the main window is off slightly. This setting 

is used to locate the impulse response in the time domain and determines 

the positioning of the selected time segment relative to the time domain. 
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Therefore, changing the DUT length setting slightly has the effect of 

shifting the data in the Time Domain Window. Note that light travels 

approximately 1.2 m through standard single mode fiber in 6 ns. 
 

Changing the DUT length to a smaller value will shift the impulse response peak 

to the right in the Time Domain Window. A larger value will shift the peak to 

the left. 
 

 
Important         When the DUT length is changed, the measurement must 

be performed again by pressing the Scan button in order 

for the change to register in the Time Domain Window. 
 

 

2 If the impulse response extends out of the Time Domain Window on 

both ends, the device may require pulse compression. For details on see 

“Pulse Compression” on page 53. If the impulse response extends 

outside the Time Domain Window after pulse compression please 

contact Luna Technologies customer service at 1-866-LUNAOVA (1- 

866-586-2682) or by e-mail at support@lunatechnologies.com for other 

measurement options. 

 
The time domain  resolution bandwidth 

 

The resolution bandwidth, as determined by the time domain filter setting, is 

displayed in the field labeled Window Res BW (pm) or Window Res BW (GHz) 

in the Window Parameters area of the Time Domain Window. This value is 

updated whenever the user changes the filter setting by dragging the cursors or 

changes the value of Sigma. 

 
 
 

Note 

By default, the Filter Resolution BW, the TD Window Res 

BW, and the Convolved Res BW (in the main screen) and 

the Window Res BW (in the Time Domain Window) are 

all displayed in units of picometers. To change the units 

to gigahertz, select Options  > Resolution BW Units > 

Gigahertz  (GHz). 
 

 

This resolution bandwidth value is also displayed in the field labeled TD Window 

Res BW (pm or GHz) in the Data Processing area of the main window. When the 

Matrix  for Res BWs Below field reads A, the next two fields display the time 

domain and convolved resolution bandwidths for Matrix  A. 

mailto:support@lunatechnologies.com
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The time domain  Hanning  window 

 

To apply the Hanning window to impulse response data, make sure that Options > 

Apply Time Domain Hanning Window is checked. To turn it off, select that menu 

option again to “uncheck” or turn off the Hanning window. (See “Time Domain 

Hanning Window” on page 246 for more information.) 

 
Applying the time domain  filter 

 

To apply  the time domain  filter 
 

1 Click the button in the Data Processing  area of the 

main window. 
 

The Time Domain Window appears. (See Figure 5-12 below.) By default it will 

display the impulse response of the first matrix containing data. 
 

2 Select which of the three matrices to display using the Matrix to View/ 

Window pull-down menu. Any matrix loaded with data may be selected. 
 

3 Click and drag the yellow vertical lines to position the filter passband 

around the desired portion of the time domain data. 
 

If the mouse cursor will not “pick up” the yellow lines, click on the button 

in the graph window. 
 

4 If desired, change the shape of the Gaussian edges of the filter function 

by entering a new value in the Sigma (ns) data field. The purple 

Gaussian filter curve in the display will update to reflect any change to 

this value. 
 

If the user enters a sigma value lower than the minimal setting of 0.001 ns, the 

software automatically resets sigma to 0.001 ns. 
 

5 If desired, change the X-axis option from the default setting of Time 

(ns) to Length (m). The units will be retained on subsequent visits to 

this window. 
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6 In order to apply this adjusted Time Domain Window to new data 

acquired or moved to this matrix, make sure the Retain  Settings box 

is checked. 

 
 

Important 

To apply a Time Domain Window to newly acquired data, 

perform steps (1) through (6) above on Matrix A. Click to 

Accept  the changes. Then make sure that Options  > 

Apply  Time Domain  Window  is checked before 

scanning. 
 

 

7 To adjust the time domain filter of another matrix, select another matrix 

from the Matrix  to View/Window menu. 
 

A prompt asks the user whether to save the changes to the previous matrix. If 

“Yes” is selected, those time domain filter changes will be used when that matrix 

is displayed, upon exiting the Time Domain window by clicking Accept. 
 

8 To apply the most recent filter settings to other matrices loaded with 

data, click the Sync Matrix  Windows check box. This checkbox only 

appears if more than one matrix contains data. (See Figure 5-15 on 

page 79 for an illustration.) 
 

9 At any time, changes to the most recent matrix selected in the Matrix 

to View/Window menu may be undone by clicking Cancel. 
 

10 When finished, click Accept. 
 

The software returns to the main window and the data in the graph windows 

now reflects the new filter settings. 

 
Example:  Setting  the time domain  filter  window 

 

Below the filter window has been set to include only the impulse response of the 

fiber Bragg grating, and to exclude other portions of the time domain. All of the 

information about the device is contained in the peak. The other sections of the time 

domain only contribute noise to the measurement, so accuracy improves when the 

impulse response cursors are narrowed close to the peak, as shown below. 
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Figure 5-12. The Time Domain Window of the same Bragg grating reflection 

shown in Figure 5-11, with the impulse response cursors (yellow) set appropriately. 

 
Examples:  Setting  the value of Sigma 

 

To broaden the edges of the flat-top Gaussian function, set Sigma to a value larger 

than the default value of 0.02 ns. Below Sigma has been set to 0.20 ns. 



Optical  Vector Analyzer    77 

User Guide 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5 
Figure 5-13. The Time Domain Window of the same Bragg grating shown in 

Figures 5-11 and 5-12 (sample data file “Bragg Reflection.dat”), 

with sigma set to 0.20 ns. 

 
To tighten the filter function, set Sigma to a smaller value. Below Sigma has be set 

to 0.01 ns. 



78   Chapter 5 

Data Processing and Display 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5 
Figure 5-14. The Time Domain Window of the same Bragg grating shown 

in the three figures above, with sigma set to 0.01 ns. 

 
A larger value of Sigma will help reduce the “edge-effects” that appear as ripple 

near the edges of the scan range. A small value of sigma is useful for separating 

multiple device features for individual inspection. 

 
Retaining  time domain  filter  settings 

 

By default, the control software will reset the time domain filter to 10% and 90% 

of the time domain range each time new data occupies a matrix memory location, 

either by performing a new measurement or loading data from a file. When 

conducting repeated measurements of the same device, however, it is often 

convenient to retain the filter setting from scan to scan. Retained TD settings also 

apply to data loaded into that matrix from memory. 

 
To retain  time domain  filter  settings 

 

In the Time Domain Window, select the Retain  Settings checkbox. This only 

retains the time domain filter settings for the matrix indicated just above this 

checkbox. To apply these settings to other matrices, see “Synchronizing time domain 

filter settings” below. To turn off retention of the filter settings, click the checkbox 

again to clear the check mark. 
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Synchronizing time domain  filter  settings 

 

In addition to retaining the time domain filter settings, the user may apply TD filter 

settings to all the matrices with data loaded in them. This option is only available 

when more than one matrix contains data. 
 

To synchronize time domain  filter  settings 
 

1 Scan or load data into the matrices to be filtered. 
 

2 Adjust the time domain filter settings as described under “Applying the 

time domain filter” on page 74. 
 

3 In the Time Domain Window, click on the Sync Matrix  Windows 

check box, as shown below. 
 

 

                                                          5 
 

Figure 5-15. The Window Parameters area of the Time Domain Window, as it 

appears when more than one matrix contains data. 
 

4 Click Accept. 
 

The software returns to the main window. The data in all matrices containing 

data now reflect the new TD filter settings. 
 

The Smoothing Filter 

The smoothing filter imposes simple curve smoothing of the parametric data using 

an acausal Gaussian filter. This is equivalent to the use of a sliding Gaussian 

averaging window. This smoothing method was chosen because it introduces no 

minima, maxima, or wavelength shift to the data. It operates on insertion loss, group 

delay, chromatic dispersion, polarization dependent loss, and polarization mode 

dispersion (PMD) and second order PMD data. It is not applied to the linear phase 
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deviation, quadratic phase deviation, Jones matrix element amplitudes or phases, 

either of the time domain plots, or to phase ripple data. For more detailed information 

about the smoothing filter, see “Smoothing filter operation” on page 247. 
 

The smoothing filter is applied by selecting a resolution bandwidth. This resolution 

bandwidth becomes the effective wavelength resolution of the frequency domain 

data. The smoothing filter does not reduce the number of data points, but noise and 

other features that occur on a wavelength scale smaller than the resolution bandwidth 

setting will be removed from the displayed data. 
 

Applying the smoothing filter 
 

The smoothing filter can be applied automatically whenever the Filter Resolution 

BW (pm or Ghz) setting is changed, or it can be applied manually. To toggle between 

these two modes, select Options > Always Apply Filter. A check mark next to this 

menu selection indicates that the filter will be applied automatically. By default this 

option is selected, and the Filter Resolution BW (pm) is set to 10 pm. To display 

data without a smoothing filter, set the Filter  Resolution BW to 0 pm. 

 
To apply  the smoothing filter 

 

1   Enter a value in the Filter  Resolution  BW (pm or Ghz) field of the 

Data Processing  area of the main screen. 
 

If the Filter Resolution BW is set too small, the software automatically resets 

it to zero and displays unfiltered data. 
 

2 If the Always Apply Filter option is selected, press Enter or click 

anywhere on the screen to accept the value and apply the filter. 
 

-OR- 
 

If the Always Apply Filter option is not selected, click the 

Apply Filter  button in the Data Processing area of the main screen. 

 
Example 

 

Figures 5-16 and 5-17 illustrate the application of the smoothing filter to group delay 

data from the sample data file “Bragg Reflection.dat”. Note the reduction in noise 

between the two plots. 
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Figure 5-16. Group delay data for a Bragg grating reflection 

(sample data file “Bragg Reflection.dat”) before filtering. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-17. Group delay data for the same grating after applying 

the smoothing filter with a 50 pm resolution bandwidth. 
 

The Convolved Resolution Bandwidth 

Because two independent filters can be applied to the data, the overall frequency 

(or wavelength) resolution depends on both of the filter settings. This value is 

displayed in the Convolved Res BW (pm or GHz) field in the Data Processing 

area of the main window. The setting of Matrix  for Res BWs Below determines 

which of the active memory matrix locations is used for this display. 
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The convolved resolution bandwidth is equal to the square root of the sum of the 

squares of time domain resolution bandwidth and the smoothing filter resolution 

bandwidth. 

 

Printing 
 

Printing Two Graphs 

The user may print both graphs currently displayed by selecting File > Print  Data 

Sheet. The control software prints to any printer defined as the default Microsoft® 

Windows® printer. The graphs will print with the current filter and axis settings. The 
legends and cursors will not appear in the printout. Information entered under File 

> Specify Device Descriptor will print in the upper right section of the printout, 

as shown in Figure 5-18. 
 

5 
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Bragg Grating Reflection 04/22/03 
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- 2 0 . 0 0 0 0  

 
- 2 5 . 0 0 0 0  
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Wavelength (nm) 

1 5 3 5 . 1 3 3 3  

 
1 7 3 6 . 8 4 2 1  

1 7 2 0 . 0 0 0 0  

1 7 0 0 . 0 0 0 0  

1 6 8 0 . 0 0 0 0  

1 6 6 0 . 0 0 0 0  

1 6 4 0 . 0 0 0 0  

1 6 2 0 . 0 0 0 0  

1 6 0 0 . 0 0 0 0  

1 5 8 0 . 0 0 0 0  

1 5 6 0 . 0 0 0 0  

1 5 4 0 . 0 0 0 0  

1 5 2 0 . 0 0 0 0  

1 5 0 0 . 0 0 0 0  

1 4 8 0 . 0 0 0 0  

1 4 6 0 . 0 0 0 0  

1 4 4 0 . 0 0 0 0  

1 4 1 5 . 7 8 9 5  

1 5 3 3 . 6 6 6 7       1 5 3 3 . 8 0 0 0 1 5 3 4 . 0 0 0 0 1 5 3 4 . 2 0 0 0 1 5 3 4 . 4 0 0 0 1 5 3 4 . 6 0 0 0 1 5 3 4 . 8 0 0 0 1 5 3 5 . 0 0 0 0  

Wavelength (nm) 

 
1 5 3 5 . 1 3 3 3  

 
This data sheet was produced using an OVA system developed by 

 
Figure 5-18. The data sheet of a Bragg grating in reflection, 

as printed by selecting File > Print Data Sheet. 

 
Printing One Graph 

The user may also print one graph at a time. First enter the full screen view, as 

described under “Full Screen View” on page 68. Click the Print  button in the lower 

center. As with printing two graphs, the legends and cursors will not appear. When 

printing from full screen view, no device descriptor will appear in the printout. The 

printed graph will fill the page, as shown below, according to the margins set under 

the Microsoft® Windows® printer controls. 
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1 5 3 3 . 6 8 6 4               1 5 3 3 . 8 0 0 0            1 5 3 3 . 9 0 0 0            1 5 3 4 . 0 0 0 0           1 5 3 4 . 1 0 0 0            1 5 3 4 . 2 0 0 0            1 5 3 4 . 3 0 0 0           1 5 3 4 . 4 0 0 0            1 5 3 4 . 5 0 0 0            1 5 3 4 . 6 0 0 0           1 5 3 4 . 7 0 0 0            1 5 3 4 . 8 0 0 0           1 5 3 4 . 9 0 0 0            1 5 3 5 . 0 0 0 0           1 5 3 5 . 1 0 0 0        1 5 3 5 . 1 8 4 3  

5 T h i s d a t a s h e e t w a s p r o d u c e d u s i n g a n O V A s y s t e m d e v e l o p e d b y  

Figure 5-19. The printout of the insertion loss of Bragg grating reflection 

data, as printed from the full screen view. 
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Chapter 6 
 
 

 

Polarization Analysis Software 
 
 

Overview 
Luna Technology’s Polarization Analysis Software (PAS) displays the response of 

an optical component to a simulated input polarization. Purchased as an option with 

Luna’s Optical Vector Analyzer, this software eliminates the tedious and difficult 

task of polarization alignment often required to test modern fiber-optic and guided- 

wave components. 
 

In the lower graph, the software plots the insertion loss (IL), group delay (GD) and 

impulse response of an optical component at a user-defined input polarization state. 

Easy-to-use sliders allow the user to adjust the simulated input polarization to any 

desired state. Also plotted are the minimum and maximum insertion loss, group 

delay, chromatic dispersion, and the angle of the principle states of polarization 

(PSP). 
 

In the upper graph, the software displays all the parameters available in the OVA 

software: the polarization averaged quantities (IL, GD, chromatic dispersion, etc.) 

as well as polarization mode dispersion (PMD), polarization dependent loss (PDL), 

Jones matrix elements, time domain information, second order PMD, and phase 

ripple. All of the generated data can be saved for export to other plotting and analysis 

software. 

 

Measurement Theory 
Luna Technologies’ OVA instrument measures the Jones matrix  J of an optical 

component which may be expressed as 
 
 
 

J   = a   b    
. 

c   d  
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The quantities a, b, c, and d are the four scalar transform functions, and  represents 

optical frequency. 
 

The electric field input to the component can be described by the complex Jones 

vector, 
 
 
 
 

Ein    = 

 

E
x 
e 

ix 
 
 

    = 

 

cos e
i


 
 

   . 
y 

E
y 
e 

sin  e 
–i

 
The optical frequency,  , factor reminds us that all of these quantities are frequency 

dependant. Ex and Ey are the amplitudes of the field, and ix  and iy are the phase 

components of the field. 
 

PAS allows the user to change the rotation angles, phi    and theta    . This 
effectively gives the user control over the input polarization state and allows for 
graphical visualization of how the changes effect the output field. This simulated 

output field Eout  is calculated by multiplying the Jones matrix of the component 

by the simulated input electric field: 
 
 

Eout    = J  Ein    . 
 

Thus the position of the blue line of the lower graph in the PAS software is 

determined by user-selected values of  and  . 
 

Descriptions of each parameter available follow under “Parameter Selection” on 

page 90. 

 

Startup 
From the Windows® Start menu, select Programs > Luna  Technologies > 

Polarization Analysis, or double-click the Polarization Analysis desktop icon. The 

main window appears, as shown below, although no data will be loaded. 
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Figure 6-1. Polarization Analysis software main window, with data loaded. 

 

The Menu Bar 
The PAS menus are exactly the same as the OVA menus, with one addition to the 

File menu for saving PAS data (described below). All other menu items have already 

been discussed under “The Menu Bar” on page 29. 

 
Saving PAS Data 

To save PAS data, the user must select File > Save Polarization Analysis Files. 

This calls up the dialog box shown below, where the user selects which parameters 

to save. 
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Figure 6-2. File > Save Polarization Analysis Files calls up this dialog box. 

Clicking OK saves the selected parameters in a text file. 

 
Clicking OK prompts the user to name and select a location for the text file. 

 

The text file header contains information on the measurement and settings; a sample 

is given below. 
 

Acquired on 10/6/2008 at 16:28:52 

Device Descriptor: NONE 

Number of Scan Averages: 1 

Time Domain Window Resolution Bandwidth (pm): 1.543541 

Filter Resolution Bandwidth (pm): 9.859719 

Convolved Resolution Bandwidth (pm): 9.979809 

Calculation Method: PSP 

Phi (radians): 0.000000 

Theta (radians): 0.000000 
 

The remaining data in a PAS text file contains three columns for each parameter 

selected, in the order shown in Table 6-1. If some parameters are not selected, all 

data columns will shift left accordingly. The first column given for each parameter 
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 Value 

(units) 

 

Column 
Value 

(units) 

 
1 or A 

X-axis Wavelength 

(nm) 

 
10 or J 

CD State 1 (Min or Max) 

(ps/nm) 

 
2 or B 

X-axis Frequency 

(GHz) 

 
11 or K 

CD State 2 (Min or Max) 

(ps/nm) 

 
3 or C 

Insertion loss 

(dB) 

 
12 or L 

Time Domain (Amplitude) 

(electric field, a.u.) 

 
4 or D 

IL State 1 (Min or Max) 

(dB) 

 
13 or M 

TD State 1 (Min or Max) 

(electric field, a.u.) 

 
5 or E 

IL State 2 (Min or Max) 

(dB) 

 
14 or N 

TD State 2 (Min or Max) 

(electric field, a.u.) 

 
6 or F 

Group delay 

(ps) 

 
15 or O 

State 1 Phi (Min or Max) 

(rad) 

 
7 or G 

GD State 1 (Min or Max) 

(ps) 

 
16 or P 

State 1 Theta (Min or Max) 

(rad) 

 
8 or H 

GD State 2 (Min or Max) 

(ps) 

 
17 or Q 

State 2 Phi (Min or Max) 

(rad) 

 
9 or I 

Chromatic Dispersion 

(ps/nm) 

 
18 or R 

State 2 Theta (Min or Max) 

(rad) 

 

 
gives the “user-set values,” meaning the Y-axis values of the blue curve, as 

determined by the user-set values of  and  . 
 

Table 6-1: PAS Text File Output 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

6 
 
 
 
 
 
 
 
 
 
 
 
 
 

Manipulating Plots 
Most of the buttons and commands used to control the OVA are also available in 

PAS. Consult earlier chapters for these controls. The upper graph of the PAS software 

displays all of the parameters available with the OVA. The lower graph displays PAS 

parameters. Only those controls and parameters unique to PAS are described below. 
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Parameter Selection 

The lower graph displays polarization analysis parameters. Click and drag on the 

title bar to display the parameters listed below. 
 
 
 
 
 
 
 
 
 
 
 

Figure 6-3. The PAS lower parameter menu. 

 
Lower graph parameters 

 
Insertion Loss  PAS 

 

The insertion loss PAS graph displays the polarization dependent State 1 (purple) 

and State 2 (aqua) and user-defined (blue) transmission as a function of 

wavelength. States 1 and 2 represent either the minimum or the maximum— 

depending on the component tested. The difference between the minimum and 

maximum transmission states constitutes the polarization dependent loss (PDL) 

of the device under test (DUT). 
 

The minimum and maximum states are derived from the eigenvalues of the 

matrix Ji
† Ji , where  † denotes the conjugate transpose. At a given wavelength, 

the greater eigenvalue represents the maximum transmission and the smaller 

eigenvalue represents the minimum transmission.1 

 
Group  Delay PAS 

 

The minimum and maximum group delay are calculated by finding the 
–1 

eigenvalues of the product Ji + 1 Ji , where the indices denote frequency. The 

phases of the two eigenvalues represent the minimum and maximum 

transmission time through the DUT.2 

 
 

1   For more information on this calculation, see B.L. Heffner, “Deterministic, Analytically 

Complete Measurement of Polarization-Dependent Transmission Through Optical Devices,” 

IEEE Photonics Tech. Lett., vol. 4, pp. 451-454, 1992. 
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Chromatic Dispersion PAS 

 

The values displayed for minimum and maximum chromatic dispersion are 

calculated using the numerical derivative of the group delay values. 

 
Time Domain  (Amplitude) PAS 

 

The time domain values are calculated by finding the amplitude of the Fourier 

transform of the product Ji 
† Ji . 

 
Min/Max State 1 Transmission PAS 

 

State 1 of theta and phi will represent either the minimum or the maximum— 

depending on the component tested. 
 

Min/Max State 2 Transmission PAS 
 

State 2 of theta and phi will represent either the minimum or the maximum— 

the opposite of State 1. 

Upper graph parameters  6 
The parameters displayed in the upper graph area of the PAS are those measured 
by the OVA. Below is a list of the parameters, with references to descriptions of 

those parameters. 
 

• Insertion Loss (For a complete definition, see “Insertion loss” on 

page 217). 

• Group Delay (See page 218). 

• Chromatic Dispersion (See page 219). 

• Polarization Dependent Loss (See page 220). 

• Polarization Mode Dispersion (See page 220). 

• Linear Phase Deviation (See page 223). 

• Quadratic Phase Deviation (See page 224). 

• Jones Matrix Element Amplitudes (See page 225). 

• Jones Matrix Element Phases (See page 225). 
 

 
 

2  For more information on this calculation see B. L. Heffner, “Automated Measurement of 

Polarization Mode Dispersion Using Jones Matrix Eigenanalysis,” IEEE Photonics Tech. 

Lett., vol. 4, pp 1066-1069, 1992. 
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• Time Domain (Amplitude), (See page 225). 

• Time Domain (Wavelength), (See page 226). 

• Min/Max Loss (See page 227). 

• Second Order PMD, (See page 221). 

• Phase Ripple Linear (See page 228). 

• Phase Ripple Quadratic (See page 229). 
 

Adjusting Phi and Theta 

To simulate a change in the input polarization state, the user may adjust phi and 

theta. Click and drag one of the red bars in the Polarization Control  area, shown 

below in Figure 6-4. The lower blue graph adjusts automatically to changes in phi 

and theta. The exact values of phi and theta are displayed in the white box to the 

left of the phi and theta control bars. The user may also click in these white boxes 

and use the keyboard to enter the values of phi and theta. 
 

 
 

6 
 
 
 
 
 
 
 

Figure 6-4. The Polarization Control area of the main screen. 
 

Above these bars is a pull-down menu for selecting the units of phi and theta: either 

radians or degrees. The lower control allows the user to select the method of 

calculating minimums and maximums (See “Calculation Method” below). 
 

Calculation Method 

The software offers two methods of calculating minimums and maximums: Min/ 

Max Loss or PSPs. The user may select either method from the pull-down menu 

in the Calculation  Method  area of the main window. 
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Min/Max Loss 

 

The minimum and maximum states are derived from the eigenvalues of the matrix 

Ji 
† Ji where  †  denotes the conjugate transpose. At a given wavelength, the greater 

eigenvalue represents the maximum transmission and the smaller eigenvalue 

represents the minimum transmission.3 

 
PSPs 

 

The minimums and maximums may also be calculated using the principal states of 

polarization (PSPs). The PSPs are defined as the eigenvectors of the product 
–1 

. The two resulting eigenvectors, or PSPs, are then propagated through the
 

Ji + 1 Ji 

Jones matrix. The two PSPs represent the fast and slow propagation axes through 

a birefringent device or system.4 
 

 
 
 
 

6 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
3   For more information on this calculation, see B.L. Heffner, “Deterministic, Analytically 

Complete Measurement of Polarization-Dependent Transmission Through Optical Devices,” 

IEEE Photonics Tech. Lett., vol. 4, pp. 451-454, 1992. 

4  For more information on this calculation see B. L. Heffner, “Automated Measurement of 

Polarization Mode Dispersion Using Jones Matrix Eigenanalysis,” IEEE Photonics Tech. 

Lett., vol. 4, pp 1066-1069, 1992. 
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Chapter 7 
 
 

 

Optical Frequency Domain 

Reflectometer 
 
 

As mentioned in the Overview chapter, Luna Technologies' OVA may also be 

operated as an Optical Frequency Domain Reflectometer (OFDR), if the user 

purchases this option. By reconfiguring the hardware and data processing algorithms, 

the OVA can be utilized to measure the full scalar response of an optical system, 

including both phase and amplitude information in terms of the system transfer 

function. This allows the data to be presented in two ways: 
 

•  The time domain: The amplitude of the time domain data is equivalent to a tradi- 

tional optical time domain reflectometry (OTDR) measurement. 

•  The frequency domain: The amplitude of the frequency domain data provides a 

measure of the insertion loss or return loss of the device. The phase information 

in the frequency domain can be used to calculate group delay and chromatic dis- 

persion. 

 
OFDR Software Overview 

To run the OVA as an OFDR, the user launches separately-purchased OFDR 

software. This section will focus on where the OFDR differs from the OVA software. 
 

The main screen displays time domain data in the upper graph, and frequency domain 

data in the lower graph. Both amplitude and phase information can be displayed in 

either domain. 
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Figure 7-1. OFDR control software main window. 

 
The following parameters are calculated and displayed by the OFDR control 

software: 

 
Time Domain  Data 

• (For a complete definition, see “Time Domain Amplitude” on 

page 131). 

• Phase Derivative (See page 132). 

• Linear Amplitude (See page 132). 

 
Frequency  Domain  Data 

• Insertion Loss (See page 129). 

• Group Delay (See page 129). 
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• Phase (See page 130). 

 
Time Domain 

By default, the upper graph displays the amplitude of the time domain data, which 

is equivalent to a traditional optical time domain reflectometry (OTDR) 

measurement. In the time domain, each optical path (each optical interface in 

reflection mode) within the device under test produces a peak. The time domain data 

can also be displayed in terms of length. This allows the user to quickly and reliably 

identify and locate reflections along the length of an optical system. (For a graphical 

display of this concept, see “Measurement Example” on page 133.) The phase 

derivative of the time domain data can also be displayed in the upper plot window. 

The phase derivative corresponds to the instantaneous wavelength response of a 

device. This is particularly useful for devices designed to operate over narrow 

wavelength bands like DWDM (dense wavelength division multiplexed) filters. 
 

Frequency Domain 

The lower plot can display the amplitude and phase derivative of the frequency 

domain data. The amplitude of the frequency domain data corresponds to the 

insertion loss or return loss of the device under test. The phase derivative plot in 

the frequency domain can be used to calculate group delay and chromatic dispersion. 
 

The frequency domain plot is calculated based on only the time domain data 

contained in the plot window above. Therefore it is possible to analyze individual 

sections of a device or system and determine the insertion loss, group delay, and 

phase response of each interface separately, by zooming in on their corresponding 

peaks in the time domain plot. This provides a powerful means for quickly and easily 

identifying faults and pinpointing their cause within a component, module, or 

subsystem. 
 

The Average Loss field in the main window shows the single average loss value for 

quick pass/fail evaluation for each optical path or interface. 
 

Frequency Domain Resolution 

The duration of the impulse in the time domain determines the necessary step size 

for the group delay measurement. If the step is too large, information about the device 

is lost. If the step is too small, extraneous noise enters the measurement. The Luna 

OFDR software allows the user to select precisely the correct step size by setting 

the time domain window so that it includes only the device response. It is also 

possible to obtain group delay data for a variety of step sizes by changing the setting 
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of the time domain window and recalculating the frequency domain data. There is 

no need to perform a new measurement. This contrasts traditional methods of group 

delay measurement, such as the modulation phase shift technique, where the user 

must guess at the appropriate step size and perform a new measurement to change 

that step size. 

 

OFDR Main Window 

The main control window of the OFDR is very similar to the OVA software. 

(Compare the OFDR, Figure 7-1 on page 96, with the OVA, Figure 1-1 on page 3.) 
 

1 The Display Options area allows the user to control which traces are 

being displayed, to move data within local memory, and to view the 

Details of each measurement loaded into memory. 
 

2 The System Status  Bar at the bottom of the screen displays system 

messages such as error, laser status, and calibration status information. 
 

3 The two Graph areas contain plots of test data. The upper graph displays 

time domain data, and the lower displays either time domain or 

frequency domain data. The pull-down menu at the top of each graph 

allows the user to select which parameter is displayed. Buttons to the 

lower left on each graph adjust plot axes, cursors, legend, and zoom. 

The lower center pull-down menu controls X-axis units. By selecting 

Options > Lower Graph > Two Plots, the lower graph can display two 

parameters simultaneously. 
 

4 The Menu Bar contains additional commands for loading and saving 

data files, printing, controlling calibration and alignment, and for setting 

various measurement and display options. 
 

System Control 

The System Control  area of the OFDR main window contains fields and menus 

that control the instrument and set test parameters. 
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Figure 7-2. The System Control area in the main OFDR software window. 

 

• The Type of Measurement pull down menu allows the user to 

choose the type of measurement: reflection or transmission. 

• The Center Wavelength (nm) field allows the user to set the center 

wavelength of a scan. To set this parameter, type in a number within 

the wavelength range of the instrument. 

• The Wavelength Range (nm) field allows the user to set the range 

of the scan. The wavelength range determines the number of 

nanometers that will be analyzed during the next measurement. A 

drop-down list contains the range options available for the OFDR 

model in use. 

• The Scan Range (nm) field shows the starting and ending wave- 

lengths that will be scanned, as determined by the center wave- 

length and range wavelength entered by the user in the two fields 

above. 

• Continuous Scan, when checked, causes the OFDR to take 

repeated measurements. The graph displays are continuously 

updated after each measurement. This mode is started and stopped 

by clicking the Scan button. 

• Clicking the Scan button starts the measurement of the device 

under test. This same button is used to stop scanning when operat- 

ing in Continuous Mode. 

• Note that the OFDR does not require a DUT Length to be entered 

(as in the System Control area of the OVA software.) 
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Data Processing 

The Data Processing area allows the user to enter Spatial  Resolution and 

Integration Width  settings. For more information, see “Spatial Resolution 

Calculations” on page 128 and “Integration Width” on page 128. 
 
 
 
 
 
 
 
 
 

 
Figure 7-3. The Data Processing area in the main OFDR software window. 

 

Display Options 

The Display Options area allows the user to store data from the most recent scan 

to one of five Traces.  (Note that data locations are called Matrices  in the OVA, 

referring to the Jones matrix analysis performed on OVA data.) 
 

The data loaded in a given trace may be graphed by clicking in the adjacent 

checkbox. It may be moved from Trace A to another trace by clicking a button in 

the Operations column. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7-4. The Display Options area in the main OFDR software window. 
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Graphs 

Each Graph area contains controls for selecting the content of the graph and for 

manipulating how the graph is displayed. The upper graph area displays time domain 

data, and the lower graph displays either time domain or frequency domain data. 

After Options > Lower Graph > Two Plots is selected, the lower graph can display 

two parameters simultaneously. The left axis displays units for the parameter selected 

in the left-hand pull-down menu, and the right axis the right parameter. 
 

 
 

             7 
 

Figure 7-5. The lower graph area in the main OFDR software window, when Options  > 

Lower Graph > Two Plots is checked. Note the pull-down menu on the far upper 

right, allowing the user to select Time Domain or Frequency  Domain data. 

 
• The Title Bar at the top of each graph contains a pull-down menu 

allowing the user to select which parameter is graphed. These 

parameters are defined under “Parameter Calculations” on 

page 111. 
 
 
 
 
 
 

Figure 7-6. The Title Bars, or parameter selection pull-down menus, before and during 

selection. The left, Time Domain menu is available in the upper and lower graphs. 

The right, Frequency  Domain menu is only available in the lower graph. 
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• The pull-down menu at the bottom of a time 

domain graph allows the user to select the value and units of the X- 

axis: Time (ns), Length (m) or Length (ft). In the lower frequency 

domain graphs, the available X-axis units are Wavelength (nm), 

Frequency  (GHz), and Frequency  (THz). Note that the Y-axis 

units are determined by the parameter displayed. 

• Buttons to the lower left of each graph let the user adjust plot axes, 

cursors, and zoom, and show or hide a legend. Table 3-1 beginning 

on page 25 describes the function of each button and gives a page 

number for further explanation. 
 

The Menu Bar 

The menu bar contains additional commands for controlling calibration, alignment, 

and for setting various measurement and display options. Menu bar commands are 

organized into five menus. 
 

The File menu 

• Load Data File loads a binary data file (of the type “.ofdr”) previ- 

ously saved by the OFDR. A dialog box appears allowing the user 

to select the file. 

• Save Data Files saves measurement data according to the selec- 

tions in the File > Select Save Options dialog box. (See “To save 

data” on page 59 for more information.) 

• Select File Options calls up a dialog box allowing the user to select 

the file type(s) for data saved. The user may select the file exten- 

sions for spreadsheets (.txt) and binary files (.ofdr). Only binary 

files may be reloaded into the OFDR software. (See “File Names 

and Types” on page 117 for more information.) 

• Save Software Options saves user-selected settings from the 

Options menu; these settings are retained the next time the soft- 

ware is run. 

• Print  Datasheet prints the two graphs as they are displayed to the 

default printer. (For more information, see “Printing” on page 82.) 

• Exit exits the OFDR control software. 
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The Edit menu 

 

The edit menus in the OFDR and OVA software are identical. See “The Edit menu” 

on page 29. 
 

The Options  menu 

• Resolution BW Units allows the user to select either picometers 

(pm) or gigahertz (GHz) as the resolution bandwidth units. The 

default setting is picometers. The resolution bandwidth is displayed 

in the lower right of the lower graph area, but only when the upper 

vertical cursors are on and when the lower graph displays fre- 

quency domain data. Data resolution is further discussed under 

“Calculating the time domain resolution bandwidth” on page 245. 

• Data Decimation (Upper Graph) allows the user to turn data dec- 

imation on (checked) or off (unchecked). It also allows the user to 

select the level of decimation, as explained under “Data Decima- 

tion” on page 124. 

• Display Options controls several display features: 
 

> Auto-Update Lower Graph, when checked, automatically recalculates 

the lower graph whenever new data is loaded or scanned, provided the upper 

vertical cursors are on. 7 
> Apply Spatial Resolution Filter turns on (checked) and off (unchecked) 
the time domain filter. (See “Spatial Resolution Calculations” on page 128.) 

 

> Autoscale Y Axes (Both Graphs) allows the user to turn on (default 

setting) and off autoscaling for the Y-axes in both graphs. When this option 

is selected, the plot axes automatically scale to include the entire data set 

on the Y-axes when a new measurement is performed. 
 

> Autoscale X Axis (Upper Graph) or (Lower Graph) allows the user to 

turn on and off autoscaling for the X-axis in the upper or lower graph. 
 

• Cursors > Show Integration Area, when checked (default set- 

ting), highlights the data points used to calculate the data for the 

lower graph. When the integration area is shown, return loss (see p. 

110) is displayed in the upper right corner of the upper graph. 

• Lower Graph allows the user to see one or two plots in the lower 

graph area. (See Figure 7-5 on page 101.) 
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• Color Palette calls up a dialog box allowing the user to specify the 

colors for each graph. These changes may be saved for future times 

the software is used (by clicking Save), or only be applied to the 

current use of the software (by clicking Apply). Clicking Reload 

Defaults allows the user to go back to the original software set- 

tings. 

• Remote Interface Setup calls up a dialog box to set up remote con- 

figuration. For more information, see Chapter 6‚ “Controlling the 

OFDR Remotely,” on page 53. 
 

The Tools menu 

• Turn  Laser OFF or ON allows the user to turn the laser on or off 

from the OFDR control software. 

• Calibrate calls up a dialog box which allows the user to specify the 

calibration settings and begin a calibration. (See “Calibrating the 

System” on page 106 for complete calibration instructions.) 

• Align Optics performs an alignment of the internal optics of the 

OFDR, just as described for the OVA under “Aligning the OVA 

Optics” on page 33. 

• Calibration Information calls up a screen with information on the 

laser calibration currently in use. 

• Specify Calibration Filenames allows the user to use the default 

calibration filenames (OFDRCal_refl, OFDRCal_trans), or to 

uncheck this box and type in or select a new calibration filename. 

For further details, see “Calibration Files” on page 106. 

• Reload Calibration Data reloads the most recent valid calibration 

data. This may be used when a calibration fails or is cancelled by 

the user. 

 
The Help menu 

• About OFDR displays information about the current software ver- 

sion and contact information for Luna Technologies. 
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Startup 

1 Begin with the full assembled OVA instrument (see “Assembling the 

OVA” on page 11), stabilized at room temperature, between 10–35 ºC. 
 

2 If your system did not come with the OFDR software preinstalled, 

contact Luna Innovations Incorporated for installation files and 

instructions. Make sure there is no other software running, including the 

OVA software. 

3 Start the software from the desktop icon    or select OFDR Software 

from the Luna  Technologies program group in the Windows®  Start 
menu. An initial window will appear for a few moments while the user 

interface is initialized. 

 
 
 
 

Important 

If the control software is started when the instrument is not 

powered on, a communication failure error message 

opens. However, the software can be used in desktop 

analysis mode when the instrument is not powered by 

clicking OK in the message box. 

To operate in normal mode, turn on the instrument. The 

software automatically detects the instrument and displays 

a message. The system can then be used normally. 

7 
• Ensure that the instrument is aligned and calibrated. (See “Aligning 

the OFDR Optics” below, and “Calibrating the System” on 

page 106.) 
 

Aligning the OFDR Optics 

In order to perform accurate measurements, the internal optics of the OFDR must 

be properly aligned. The three conditions that require an alignment to be performed 

are listed below. 

 
Alignment must  be performed. . . 

 

1   When the instrument is initially set up for the first time. 
 

2   Whenever the OFDR is physically moved from one location to another. 
 

3   Whenever the                                  indicator in the System Status Bar 

is visible. 
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To align the OFDR optics 

 

1 Ensure that the OFDR unit is powered on and that the laser is on and 

ready. 
 

2 Select Tools > Align Optics. 
 

Alignment begins. A status bar shows the progress of the alignment. When the 

alignment is complete, the software returns to the main window. 
 

3 The user must next perform a calibration, as described below. 
 

Calibrating the System 

The OFDR system must be calibrated prior to performing measurements. The OFDR 

calibration removes the effects of the measurement network to ensure that the 

measured data represent only the device under test. 
 

Calibration Files 
 

Transmission and reflection measurements each require an independent calibration. 

The most recent calibrations for each measurement type are stored in files, which 

are loaded by the control software upon start-up. If the software is unable to locate 

at least one calibration file, a dialog box will appear to alert the user that a calibration 

must be performed before a measurement can take place. In this event, the Scan 

button will be unavailable until a calibration has been performed. 
 

Calibration files are saved to the same directory as the OFDR.exe file. The default 

directory for OFDR.exe is “C:\Program Files\Luna Technologies\OFDR” 

 
Conditions that Require  Calibration 

 

In a typical laboratory or manufacturing environment, calibration should be 

performed at least once every 24 hours. The need to recalibrate is largely determined 

by the surrounding environmental conditions. If the temperature is fluctuating 

rapidly, it may be necessary to calibrate more than every 24 hours. If the surrounding 

temperature is very stable, a longer interval may suffice. 
 

Calibration must be performed whenever the surrounding temperature has changed 

by more than 5 degrees C. A calibration may also be desirable when the front panel 

connectors have been reconnected since the last calibration, in order to calibrate out 

connector effects when splicing devices into the measurement path. 
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In certain cases the control software will detect that the internal optics of the 

instrument have drifted, and it will alert the user via the System Status Bar indicator 

. When this occurs performing a calibration will typically suffice. 
 

Consideration Prior  to Calibrating 
 

The maximum spatial resolution that can be achieved with the OFDR is related to 

the wavelength range of the measurement according to 

 
 

�z = 
 

--------------- , 
neff �

 

where �z is the spatial resolution, nef f  is the effective index of refraction of the 

device under test, 1  and 2  are the start and end wavelengths of the scan, and 

  =  1(  ) – 2. Thus, calibration over larger wavelength  ranges will allow for the 
highest spatial resolution measurements. 

 
The Calibration Procedure 

 
To calibrate  the system 

 

1 Ensure that the OFDR unit is powered on and that the laser is on and 

ready. The Laser Ready light on the front of the instrument comes on 

when the laser reaches operating temperature. 
 

2 Select Tools > Calibrate. 
 

The following dialog box appears: 
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Figure 7-7. Calibration parameters dialog box. 

 

3 Select Transmission or Reflection from the Type of Measurement 

pull-down menu. 
 

4 Type in the Center  Wavelength  appropriate for the device(s) to be 

tested following calibration. 
 

5 Select the desired Wavelength  Range from the pull-down menu. 
 

Note that in order to perform measurements over a broader wavelength range 

than the one selected during calibration, it is necessary to recalibrate. 
 

6 Click Continue. 
 

The instrument performs several internal scans. Next a prompt appears 

instructing the user to connect the supplied reference fiber to the instrument. 

First follow step seven. 
 

7 Before making connections, be sure to clean all fiber optic connectors. 

(See “Cleaning Connectors” on page 255.) 
 

8 For a Transmission calibration, connect the supplied patch cord to the 

Source and Detector  connectors on the front panel of the OFDR. 
 

For a Reflection calibration, connect the supplied gold reflector to the Source 

connector on the front panel of the OFDR. 
 

9 Align the connector key to fit in the groove in the bulkhead adaptor. 

Turn the screw ring around the connector clockwise until it is just 

tightened. 
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10 Click OK. 

 

A dialog box appears as calibration proceeds. 
 

11 Click OK in the dialog box indicating that the instrument has been 

successfully calibrated. 
 

After calibrating, it is advisable to check if the calibration was successful, to ensure 

that the system will provide accurate data. 
 

Checking  the Calibration 
 

1 Follow all the instructions above, under “To calibrate the system” on 

page 107. 
 

2 Leave the gold reflector (if checking a reflection calibration) or patch 

cord (if checking a transmission calibration) attached. 
 

3 Perform a scan, following the instructions under “To perform a single- 

scan measurement” on page 111. 
 

4 Display the insertion loss graph. Check that the insertion loss measures 

a nominal value of zero to within the measurement accuracy of the 

instrument. 

Storing  Multiple  Calibrations  7 
Users may store more than one calibration file, covering different wavelength ranges. 

Note that users should only use calibration files created in the last 24 hours or so, 

as explained under “Conditions that Require Calibration” on page 106. 



110   Chapter 7 

Optical  Frequency  Domain  Reflectometer 

 

7 

 
To store or use multiple calibrations 

 

1  Select Tools > Specify Calibration Filenames. The dialog box below 

appears. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 7-8. Select calibration file dialog box. 

 

2 Click on the Use Default Calibration Filename(s) checkbox, leaving 

it unchecked. The Calibration Filename  fields become accessible. 
 

3 Type in a new filename. Alternately, if other calibration files have been 

saved, the user may select a previously-saved calibration file from the 

pull-down list. The default calibration filenames are ofdrCal_refl and 

ofdrCal_trans. 
 

4 Click OK. 
 

5 If you typed in a new calibration filename, next select Tools > Calibrate. 

Follow the instructions under “The Calibration Procedure” on page 107. 

The new calibration will then take effect. It will be stored under the 

filename entered in the Select Calibration File window shown above. 
 

—OR— 
 

If you selected an existing calibration file, you must select Tools > Reload 

Calibration Data. Or, if you wish to overwrite this existing filename with a 

new calibration, simply perform a new calibration. 
 

In either case, the OFDR will not warn you if you are overwriting an existing 

calibration file. 
 

6 In order for the current calibration file to take effect when the OFDR 

software is restarted, select File > Save Software Options. Otherwise, 
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the default calibration files (ofdrCal_refl and ofdrCal_trans) will be 

loaded upon the next startup. 

 
 

Important 

Again: Renaming the calibration filename under Tools > 

Select Calibration File does not change the calibration 

file used by the OFDR software. To do so, the user must 

next perform a new calibration, or select Tools > Reload 

Calibration Data. 
 
 

Acquiring Data 
The OFDR has two different options for data acquisition: single scan and continuous 

mode. Each mode performs a complete scalar measurement of the device under test, 

and all parameters are available from measurements done in any mode. 
 

 
Important  Before testing, clean the fiber optic connectors with the 

appropriate cleaner to guard against errors. For 

instructions, see “Cleaning Connectors” on page 117. 
 

 

Single-Scan Mode 

The single-scan measurement represents the basic functionality of the OFDR. In this 

mode the instrument performs a single sweep of the laser over the selected 

wavelength range, and acquires data for the device under test over that range. 

 
To perform  a single-scan measurement 

 

1 Ensure that the OFDR unit is powered on and that the laser is on and 

ready. The Laser Ready light comes on when the laser reaches operating 

temperature. 
 

2 Be sure that the instrument has been aligned (See “To align the OFDR 

optics” on page 106) and calibrated (See “To calibrate the system” on 

page 107) within the recommended time period. 
 

3 Before connecting the device to the OFDR, be sure to clean all fiber 

optic connectors. (See “Cleaning Connectors” on page 255.) 
 

4 Connect the device to the OFDR. A transmission device must be 

connected to both the Source and Detector  connectors. A reflection 

device need only be connected to the Source detector. 
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5   Select Transmission or Reflection from the Type of Measurement 

pull-down menu in the System Control  area. 
 

6   Enter an appropriate Center Wavelength  and select a Wavelength 

Range from the pull-down menu. 
 

If the desired scan range falls outside the range of the most recent calibration, 

either select a smaller scan range or recalibrate the OFDR. 
 

If the center wavelength entered falls outside the range of the instrument, the 

software replaces it with a value within the instrument’s range. (See the 

Specifications Sheet shipped with your instrument for standard instrument 

wavelength ranges.) 
 

7 Check the Options menu for functions to be applied to the scan, such 

as Data Decimation  and Auto-Update Lower Graph. 
 

8 Click Scan. 
 

The instrument performs the measurement and the software displays the test 

data. 
 

Note that even if Options > Display Options > Auto-Update Lower Graph 

is off (unchecked), data may appear in the lower graph window from a previous 

scan. To update the lower graph based on the current time domain data, see 

“Updating Lower Graph” on page 120. 
 

Continuous Scan Mode 

Continuous scan mode takes advantage of the fast measurement speed of the OFDR 

to monitor devices whose properties may change slowly with time. It is particularly 

useful for short (<5 nm) scan ranges, where the update rate is fast enough to allow 

for near real-time device monitoring. 
 
 

Important  
For accurate measurements, the device must change 

slowly enough that its properties remain constant while 

                data is acquired. The blue “Scanning” LED on the OFDR 
turns on during data acquisition, indicating this time scale. 

 
 

Note that continuous scan mode will operate more quickly if the lower graph area 

is “turned off” by unchecking Options > Display Options > Auto-Update Lower 

Graph. To view this data after scanning, see “Updating Lower Graph” on page 120. 
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To scan continuously 

 

1   In the System Control  area of the main window, select Continuous 

Scan. 
 

2   Optional: To gain more speed, uncheck Options > Display Options > 

Auto-Update Lower Graph. 
 

3   Follow the same measurement procedure as was outlined above under 

“To perform a single-scan measurement” on page 111. 
 

4   The Scan button will turn gray during continuous scanning. 
 

The active graph window(s) will update after each scan. 
 

5   To stop scanning, press the grayed Scan button again, or uncheck the 

Continuous Scan box. 
 

The data displayed in the upper graph will be from the last measurement. If 

Options > Display Options > Auto-Update Lower Graph was checked, data 

displayed in the lower graph will also be from the last measurement. However, 

if Options  > Display Options  > Auto-Update Lower Graph was off 

(unchecked), any data appearing in the lower graph window is from a previous 

scan. To update the lower graph, follow the instructions under “Updating Lower 

Graph” on page 120. 7 
Data Processing and Display 

 

Displaying Multiple Traces 

The OFDR control software allows the user to store up to five data sets in active 

memory. These three memory locations are denoted Traces A through E. The most 

recent measurement is always stored in Trace  A. 
 
 

Important  
New scans are automatically loaded into Trace A, 

overwriting any data there. To avoid losing data, see 

                “Moving Data in Local Memory” below, or “Saving and 
Loading Data Files” on page 116. 

 

 

Moving Data in Local Memory 

Data Trace A may be moved to Trace B by clicking the button labeled A->B under 

the Operations column of the Display Options area shown in Figure 7-9. Similarly, 
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data may be moved to Traces C, D or E. However, only three of the five traces are 

available when operating in view-only mode (i.e. when the laser is off).The original 

data in Trace A remains in A until new data is scanned by the instrument or loaded 

from the hard drive. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7-9. The Display Options area in the main OFDR software window. In this 

example, the laser is off, so only three traces are available. Data has been loaded 

into Traces A and B, but only Trace A is being displayed, as indicated by the check 

boxes. 

7 Displaying Stored Data 

The control software can display any combination of Traces A through E 

simultaneously in the graph windows. By default the data in Trace  A is plotted as 

a blue curve, Trace  B is red, Trace  C green, Trace  D yellow, and Trace  E pink. 

In the example in Figure 7-9 above: 
 

1 Trace  A contains data, as indicated by the white name and checkbox 

and the blue Details buttons. Trace A is being graphed, as indicated by 

the filled-in checkbox. To clear this graph, click to clear the checkbox 

by Trace A. 
 

2 Trace  B also contains data but is not being graphed. Clicking in the 

second checkbox adds Trace  B to the graph window. 
 

3 Traces C has no data in it, as indicated by the grayed name and lack 

of a Details button. To overlay another plot, the user could move data 

into this trace using the A->C Operations button or by loading data 

from the hard drive. (See “Saving and Loading Data Files” on page 116.) 
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4 Traces D and E are unavailable, as indicated by the gray Operations 

buttons. This indicates that the software is operating in “Desktop 

Analysis” mode. To make these traces available, the user would have 

to select Tools > Turn  Laser ON. 
 

When data is loaded into local memory (by selecting File > Load Data File or by 

scanning) or moved within local memory (by clicking an Operations button), it is 

automatically displayed in the upper graph window. 
 

Trace Details 

Clicking a Details button in the Display Options  area calls up the Measurement 

Details window shown in Figure 7-10 below. This window lists the type of 

measurement, the scan range & date, the calibration date, and the gain setting. If 

the file has been loaded from the hard drive rather than scanned into Trace  A, the 

file path will be listed. The user may type in a one-line Device Descriptor. The user 

may also use this dialog box to change the group index of one trace at a time. The 

Save and Close button is only available when new data has been entered into the 

Device Descriptor  field or the Group  Index field. 
 

 

7 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 7-10. Measurement Details window. 
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The user can also use the                                     box in the lower right of the upper 

graph to change the group index, but this effects all of the data loaded into Traces 

A through E. (See “Adjusting Group Index” on page 124.) 
 

Saving and Loading Data Files 

The OFDR control software provides two different options for saving data files. The 

first file type (.ofdr) is a binary data format that completely captures the measured 

data and stores it in a format that can be loaded back into the control software at a 

later time for further manipulation. 
 

The second file type (.txt) is a text file in a tab-delimited spreadsheet format. Text 

files contain the data displayed in the upper and lower graphs at the time of saving. 

Data saved in the spreadsheet format cannot be loaded back into the control software. 
 

It is highly recommended that the binary data format be chosen over the spreadsheet 

format for data archives. The binary format stores all measurement information, 

whereas the spreadsheet format stores only a subset of the measured information. 

Furthermore, a spreadsheet file can always be generated from a binary file at a later 

date, but a binary file cannot be generated from a spreadsheet file. Finally, other 

data analysis software packages available from Luna Technologies accept only the 

binary data format produced by the OFDR control software. 

7 File Names and Types 

Depending on which options are set in the File > Select File Options  dialog box 

(Figure 7-11), up to four files may also be saved each time File > Save Data Files 

is selected. As an example, if the user saves the data as Your_Filename, the four 

files would be: 
 

1 Your_Filename.ofdr is the complete binary file, which can be reloaded 

into the OFDR software. 
 

2 Your_Filename_Segment.ofdr is a subset of the data displayed in the 

upper graph. This subset is the region integrated by the vertical cursor 

in the upper graph and displayed in the lower graph. These files may 

also be reloaded into the OFDR software. 
 

3 Your_Filename_Upper.txt is a spreadsheet file of all of the upper graph 

parameters selected in the File > Select File Options dialog box. 
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4 Your_Filename_Lower.txt is a spreadsheet file of all of the lower graph 

parameters selected in the File > Select File Options dialog box. 
 

 
Important  When File > Save Data Files is selected, the OFDR 

software will overwrite any files with the filename specified, 

               without warning the user. 
 

 
The first column of each spreadsheet is determined by whatever units are selected 

and displayed on the respective X-axes when the user selects File > Save Data Files. 

Make sure first to follow instructions under “Updating Lower Graph” on page 120, 

as the segment displayed will be the one saved. 
 

Spreadsheet files cannot be reloaded into the OFDR software. Therefore, a warning 

message will be displayed the first time the user saves data with both Binary File 

Options unchecked. This warning will not be displayed again until the user restarts 

the software. 
 

Saving Data 
 

Prior to saving data, the user may customize the format, content, and file extensions 

of saved data files. The following procedure sets options that will affect how the 

command File > Save Data Files saves measurement data. 
 

1 Select File > Select File Options 
 

The Select Data File Options dialog box opens: 
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Figure 7-11. Select File Options dialog box. With this setting, 

the complete (upper) binary file and two text files will be saved. 
 

2 A binary file of the complete data will only be saved if the Save Full 

Measurement File box is checked. If Save Lower Graph Segment is 

checked, the software will also save a binary file of the data displayed 

in the lower graph. All of the data in that segment will be saved, not 

just the parameter displayed. This allows the user to save and manipulate 

smaller binary files. These lower segment binary files may also be 

reloaded into the software. 
 

3 To set the software to save spreadsheet text files whenever File > Save 

Data Files is selected, check the appropriate box(es) under Spreadsheet 
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File Options.  Use the pull-down menus to determine the x-axis units 

and domain of the text files saved. 
 

 
Important  

Only binary data files, of type “.ofdr,” may be reloaded into 

                 the OFDR software. 
 

 

4 Click OK. 
 

The control software saves the selected options. 
 

To save data 
 

1 Select File > Save Data Files. 
 

A dialog box appears. 
 

2 Select the file destination and enter a file name. The file extension(s) 

will be added automatically according to the configuration set using File 

> Select File Options,  as described above. 
 

3 Click Save. 

Loading  Saved Data  7 
Only data saved in the binary format (.ofdr) can be loaded into the control software. 

 
To load a saved data file 

 

1 Select File > Load Data File from the pull-down menu. 
 

2 In the dialog box that appears, choose the desired file and click Open. 
 

The loaded data will appear in the upper graph area. 
 

If Options  > Always Update  Frequency Domain is checked, new data will 

also appear in the lower graph area. If Options > Always Update Frequency 

Domain is unchecked, any data showing in the lower graph is from a previous 

calculation. To reset the lower graph area, click the recalculate button . 
 

Spreadsheet  File Data 
 

The header of a spreadsheet file gives the following information: 
 

• Date and time data was acquired 
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• Calibration date and time 

• Device descriptor (The user may enter a descriptor after clicking 

the Details button in the Display Options area.) 

• Scan range 

• Measurement type 

• Group index 

• Domain (time or frequency domain) 

• Resolution bandwidth 

• Number of data points 

• Decimation 
 

Only the parameters selected (checked) in the File > Select File Options dialog box 

will be contained in a spreadsheet file. The X-axis units of the data are also 

determined in that same dialog box. The parameter name and the units are given at 

the top of each spreadsheet column. 
 

Manipulating Plots 

Most of the tools for changing plots are the same in the OFDR and OVA. Features 

unique to the OFDR software are described below. See “Graphing Tools Common 

to the OVA and OFDR” on page 125 for references to earlier sections describing 

common features. 

 
Updating  Lower Graph 

 

In both the OVA and OFDR software, the data in the upper graph automatically 

updates when data is scanned (into Trace A), moved, or loaded from memory. 

However, in the OFDR software, the lower graph will not update automatically 

unless Options > Display Options > Auto-Update Lower Graph is checked. As 

mentioned earlier, this is often left off (unchecked) to speed up scanning time. 

 
To update the lower  graph in OFDR software 

 

1 Turn on the vertical cursors in the upper graph by clicking . 
 

2 By default, the vertical cursors are attached to Trace  A. To attach the 

upper graph cursors to another trace, select a different trace from the 

pull-down menu in the lower graph Title Bar . 

3 Adjust the cursor locations in the upper graph as desired by selecting 

the cross-hair          tool, then clicking and dragging a cursor. 
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4 If Options > Cursors > Show Integration Area is on (checked), the 

regions of the graph around the vertical cursors are highlighted. This 

highlighted segment is the only data that will appear in the lower graph. 

Lower graphs of all traces will be based on this same segment of the 

X-axis. 
 

The user may change the width of the highlighted area (and lower graph X-axis) 

by entering a new Integration Width  in the Data Processing  area. 
 

5 Click the blue recalculate button in the upper left of the lower 

graph. 
 

By default, the lower graph will be based on the data integrated by the left 

(yellow) cursor from the upper graph, as indicated by the yellow button to the 

left of the recalculate button. 

6 To see the data from the right (orange) cursor, click to the right of the 

recalculate button; the button will turn from gray to orange: 

. Then hit the recalculate button again. 
 

 
Note  The recalculate button only appears in the top left 

of the lower graph when the vertical cursors are on in the 

               upper graph. 
 

 

7 To change the parameter displayed in the lower graph, follow the next 

set of instructions. 

 
Parameter Selection 

 

As with the OVA, the user can control the content of the two graphs in the main 

window from a list of parameters in the Title Bars. By default, the upper, time 

domain graph displays amplitude, but it can also display phase derivative or linear 

amplitude. The lower graph can display the same time domain parameters, or the 

user can select frequency domain from the pull-down menu  to 

display insertion loss (default), group delay, or phase. 
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Graphing  Two Parameters  Simultaneously 

 

The OFDR (but not the OVA) offers the option of displaying two parameters in one 

graph area. If Options > Lower Graph > Two Plots is on (checked), two parameter 

menus will appear in the lower graph, as shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7-12. Lower graph window showing one Title Bar pulled down 

for parameter selection. 
 

Click on the desired parameter from the list in a graph’s Title Bar. The content of 

the graph changes, as do the title and the axis labels (if necessary). 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7-13. Graph window with vertical cursors appearing at the default location. The 

legend at the upper right gives the precise location of the cursors and the distance 

between them (dX in this case). Just beneath that, Return Loss is not displayed 

because the integrated area is not highlighted (Options  > Cursors  > Show 

Integration Area is unchecked.) For an illustration of the Return Loss display, see 

Figure 1-1 on page 2. 
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Vertical  cursors: 

 

This button provides additional functionality in the OFDR. Clicking this button 

toggles two vertical cursors on or off. Note that when these cursors are on, the data 

points integrated to calculate return loss (see page 128) are highlighted in contrasting 

colors, and return loss is displayed in the upper right legend. This highlighted region 

may be turned off by unchecking Options  > Cursors > Show Integration Area. 

This highlighted or integrated region determines the X-axis of the lower graph. 
 

The number of points integrated may be increased (or decreased) by entering a larger 

(or smaller) number in the Integration Width box in the Data Processing area to 

the left of the graphs. For an explanation of how return loss is calculated, see 

page 128. 
 

By default, all cursors are attached to Trace A. To attach cursors to another trace, 

use the pull-down menu at the upper right of the lower graph area. 
 

Select the cross-hair tool to move any cursors. 
 

Move cursors to peak: 
 

Clicking this button moves the two vertical cursors to the peaks of the regions 

highlighted by each cursor. Simply click on this button when the vertical cursors 

are on. Note that this button is only available in the OFDR software.                               7 
Adjusting Group Index 

 

In the OFDR only, when the upper graph X-axis displays meters or feet, the Group 

Index field shown below appears in the lower right corner. The user may enter the 

index appropriate for the device under test. 
 
 

 
Figure 7-14. The group Index field, which appears when the 

upper X-axis is set to length. 

 
 
 

Important 

Changing the group index in the box shown above 

changes the group index for all the data loaded into 

memory, Traces A through E. In order to change the group 

index of only one trace, click the Details  button of that 

trace and change the group index in the details dialog box. 

(See “Trace Details” on page 115.) 
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This setting scales the X-axis length values according to 

 

z 
c 

=  ----- t , 
ng 

 
where z is the spatial dimension (X-axis) of the device under test, c is the speed of 

light in a vacuum, and ng  is the group index of refraction of the device under test. 

 

Data Decimation 

Data decimation is only available in the OFDR software. By default, Options > Data 

Decimation (Upper Graph) > Decimate Data is turned on (checked). This means 

that only the average of roughly every 64 data points is displayed in the upper graph. 

The user may change the number of data points displayed from a pull-down menu 

displayed after selecting Options > Data Decimation (Upper  Graph) > Specify 

Level... 
 
 
 
 
 

7 
 
 
 
 
 
 
 
 

Figure 7-15. The Specify Decimation Level dialog box 

allows the user to set the number of data points displayed. 
 

Decimation makes the graphs much less “noisy” and quicker to display. Unchecking 

this option displays the full data set. Note that files saved in the binary (.ofdr) format 

contain the raw data, undecimated. Text files (.txt) may be reduced in size by making 

sure data decimation is on before saving. The upper section of a text file notes 

whether or not data decimation has been applied to the saved data. 
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Graphing  Tools Common  to the OVA and OFDR 

• “Scaling Plot Axes” on page 63 

• “Using zoom tools” on page 64 

• “Using Cursors and Legends” on page 66 

• “Printing” on page 82 

 
Measurement Theory 

This section describe areas where OFDR and OVA theory or parameters differ. For 

Measurement Theory on areas where the OFDR and OVA are essentially the same, 

see these relevant sections: 
 

• “Fiber Optic Interferometry” on page 231 

• “Triggering and Resolution” on page 235 

• “Wavelength Calibration” on page 241 

• “Calculating the time domain resolution bandwidth” on page 245 
 

Optical Network of the OVA in OFDR Mode 

A detailed schematic of Luna’s OFDR optical network is shown in Figure 7-16. The 

optical system is comprised of a tunable laser source (TLS), two interferometers 

(DUT and trigger), a polarization beam splitter (PBS), three data acquisition 

channels, and a high speed analog to digital converter (ADC). Note that the system 

can interrogate a DUT in both reflection and transmission via the use of the 1x2 

optical switch in one arm of the DUT interferometer. The interference fringes Us(t), 

Up(t), and Ut(t) are labeled at their corresponding detector, where “s” and “p” 
correspond to the two polarization states of the PBS and “t” denotes the trigger. 
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Figure 7-16. OFDR optical network, in reflection mode. 

 
This basic idea from the previous section can be applied to device characterization 
by including a device under test (DUT) in one arm of a Mach-Zender interferometer, 
as shown in Figure 7-16. We can describe the DUT by its frequency domain linear 

transfer function, H   ; the linear transfer function contains information about the 

amplitude,    , and phase,    , response of the DUT and is given by 

H   =   ei   . Given the amplitude and phase response, the detected power 

is proportional to the intensity, I, given by 

7 I  = 

 
E0  t  

2 + 

 
E0  t –   2   2 

+ 2  E0  t E0  t –   cos   t  –      . 
 

Next a Fourier transform is performed allowing the three terms in the above 

expression to be separated spectrally. Note that the first two terms will have only 

low frequency characteristics, and thus will appear at or near t = 0 in the time- 

domain. The device information resides in the third term of this expression, called 

the interference term. The interference term oscillates at the frequency  t  , while 
the other terms do not oscillate. Its location in the time-domain will be determined 

by the delay difference    between the two arms of the interferometer. Provided 

that   is large enough, the device response will be separable from the low frequency 
terms, and thus measurable. The Luna OFDR is designed such that the internal delay 
path through the device under test is long enough such that the low frequency terms 
will not influence the measurement, even for very short devices. Thus the OFDR 
operates with no dead zone. 

 

The Fourier transform of reflected optical intensity (I) for a short length of single- 

mode fiber as the DUT is plotted in Figure 7-17 (a). Figure 7-17 (b) shows the 
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selected segment that contains the device information. Because the initial data was 

acquired as a function of optical frequency,  , the transformed data is a function 
of time. For this reason, the transformed data is referred to as time domain data. 

 

                              7 
Figure 7-17. (a) The Fourier transform of interference fringes. 

(b) The segment of the time domain data that contains device information. 

 
Spatial Resolution Calculations 

The Spatial Resolution field in the Data Processing area sets the length of the box- 

car filter applied to the amplitude data in the time domain. This filter assigns each 

location in the measurement with the simple sum of all the adjacent points within 

the range of the filter resolution setting. Because this is not a weighted average, 

localized reflections—like those at the end of a fiber—will have a rectangular shape 

equal to the width of the control setting. 
 

Integration Width 

The Integration Width field in the Data Processing area controls the length of the 

segments centered on the vertical cursors in the top graph, which are used to calculate 
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the average loss within a two highlighted segment. The width of this segment 

determines the width of the lower graph X-axis. 

 
Return Loss 

When the vertical cursors are on in the upper graph, the average return loss is 

calculated over the two integration widths and displayed in the upper right as Ret 

Loss (dB). For example, if the entire time domain axis is given by t �  0 T  and 

the data is highlighted at a cursor such that t �  t1 t2  , then the average return loss 

at that cursor is given by 
 
 
 

 
 
 

RetLoss = 

t2 

� h̃ 
j 

t 
------------ 
T 

� h̃ 
j 

0 

 

where h̃ 
j 

 

is the impulse response, further defined below under “Time Domain 

Amplitude” on page 131. 
 

Parameter Calculations 

As mentioned above, the OFDR uses coherent interferometry to measure the linear 

transfer function, H  =   ei   , of the DUT. From this, the loss, dispersion 

and time domain parameters are extracted. 

 
Insertion Loss 

 

Insertion loss (IL) is the ratio of optical power output by the device to the optical 

power input to the device, and is expressed in dB. In terms of the transfer function, 

it is defined as 
 
 
 

ILi = 20log   i  . 
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where the subscript “i” corresponds to the “ith” data point and i  is the amplitude 

response normalized to the response of the reference patch cord for transmission 
measurements and the reference gold reflector for reflection measurements. 

 

 
 

 
 

Figure 7-18. Insertion loss data for a patch cord. 

 

Group Delay 
 

Group delay (GD) is defined to be the rate of change of phase as a function of 

frequency. Physically, this property corresponds to the delay experienced by the 

sinusoidal envelope of a modulated optical signal as it propagates through the device. 

In terms of the transfer function, the group delay is given by 

 

arg Hi + 1 H � 
GDi  = -----------------------------------   , 

�
 

where arg  z  denotes the argument (phase) of the complex number z , and �  is 

the change in optical frequency from index i to index i + 1 . 
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Figure 7-19. Group delay data for a patch cord. 

 

Phase 
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The frequency domain (lower) graph can also display phase. This represents the 

optical phase response as a function of wavelength of the portion of the DUT 

response that is visible in the upper graph. As stated above, group delay is calculated 

as the numerical derivative of the spectral phase. 
 

Note that the phase is a function of the placement of the data in the upper graph. 

For example, an impulse occurring in the left of the upper graph will display a phase 

with negative slope. Conversely, the same impulse repositioned to the right in the 

upper graph will display a phase with a strong negative slope. An impulse that is 

centered in the upper graph will have nominally flat phase in the lower graph. This 

ambiguity in the slope of the phase is due to the fact that the linear term in the phase 

response for a given component determines, to the first order, the length of the 

component. One is often more interested in higher order phase terms and thus the 

strong linear term is undesired in the phase plot. By centering the data in the upper 

graph, the user has a control over the amount of slope that is “allowed” into the 

phase plots. 
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Figure 7-20. Lower graph area showing phase data. 

 
Time Domain  Amplitude 

 

The time domain amplitude plot selection displays the amplitude of the impulse 

response of the device in the time domain. The impulse response is given by the 

Fourier transform of the transfer function, 
 

h̃ 
j  = 

 

FFT H   j  , 7 
where FFT H    denotes the Fast Fourier Transform of H   . The index j 
indicates the location in the data array, and corresponds to time. 

 

The impulse response amplitude is plotted on log scale and is given by 

 

log  h̃ 
j  . 

 
This definition yields an average impulse response over all input polarization states. 

The result is scaled such that 

 

� h̃
 
j   = 1 

j 

 
for a lossless device. 



132   Chapter 7 

Optical  Frequency  Domain  Reflectometer 

 

 

 
 
 

 
 

Figure 7-21. Time domain amplitude data for a patch cord. 

 
Time Domain Linear Amplitude 

The linear amplitude is the  h̃ 
j   plotted on a linear scale. 

 

 

7  
 

Figure 7-22. Time domain linear amplitude data for a patch cord. 

 
Time Domain Phase Derivative 

 

The time domain phase derivative plot is the derivative of the phase of the impulse 

response with respect to time. Note that the time derivative of phase is the definition 

of optical frequency, so this derivative can be scaled as a wavelength. For a device 

with a distributed impulse response, the time domain phase derivative shows the 

wavelength distribution as a function of time for an infinitely short pulse as it is 

dispersed by the device. Another way to think of the time domain phase derivative 
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is it represents the “wavelength” of the device under test. It is therefore especially 

meaningful for wavelength conditioning devices and filters. 

In terms of the impulse response h̃ 
j defined above, the time domain phase derivative, 

PDj , is defined as 
 
 

PDj  = 
2�c� t 

--------------------------------   , 

arg  h̃ 
j + 1 h̃

 
j
� 

 

where c is the speed of light in a vacuum and �t is the difference in time between 

index j and index j + 1 . 
 

 
 

                                    7 
 

Figure 7-23. Phase derivative of the time domain response of a fiber Bragg grating. 

 

Measurement Example 
 

If the OFDR is operating in reflection mode and there are multiple reflecting 

interfaces within the device under test, each interface will contribute a term to the 

interference pattern and a peak in the time domain located at the corresponding delay. 

See Figure 7-24 for an example measurement of a photodetector packaged with a 

ball lens. Similarly, a transmission measurement of a device with multiple optical 

paths will also produce multiple peaks in the time domain plot. 
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7 
 

Figure 7-24. An OFDR measurement of a packaged optical detector. 

Reflections from the connector endface, both sides of a ball lens, and 

the photodiode are apparent. 
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Chapter 8 
 
 

 

Controlling the OVA Remotely 
 
 

This chapter provides information about controlling the Optical Vector Analyzer 

remotely using GPIB or TCP/IP commands. This section assumes that the user 

already has some familiarity with either GPIB or TCP/IP. For detailed information 

about GPIB, see IEEE 488.2 standards documents; for information about TCP/IP, 

see the IEEE 802 standards documents. 
 

Nearly all functions that can be performed using the graphical interface of the control 

software can also be performed remotely. This includes setting scan parameters, 

performing measurements, filtering data, loading and saving data files, as well as 

receiving data over the remote interface. However, continuous and real-time modes 

are not available with remote operation. 
 

Remote operation offers the additional feature of using the OVA as a tunable light 

source. For details, see “Using the OVA as a Light Source” on page 195. 
 

Access to the Matrix B and C memory locations is not available through remote 

operation of the OVA. Remote control commands can store and retrieve data using 

only the Matrix A memory location. 
 

Full calibration including calibration for PDL is not available through remote 

operation, because it requires user interaction. To operate remotely using a complete 

calibration, the user must first calibrate locally (as described under “The Calibration 

Procedure” on page 37), and then switch to remote operation. The remote command 

SYST:QCAL (See page 156) allows calibration for insertion loss and dispersion 

parameters only. 
 

For higher speed remote operation, TCP/IP is recommended over GPIB. 
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Prerequisites for Remote Control Setup 

1   Be familiar with the use of GPIB or TCP/IP commands and the OVA 

control software before attempting to control the OVA remotely. 
 

2   Network cabling must comply with IEEE 488.2 requirements for GPIB 

operation, or with IEEE 802 requirements for TCP/IP operation. 
 

3   Some OVA functions require several minutes to complete. Adjust GPIB 

or TCP/IP time-outs for your application accordingly. 
 

4 Each device in the GPIB network must have a unique GPIB address, 

typically from 1 to 30. The network controller is typically assigned an 

address of 0. 
 

5 Be aware of the IP address of the OVA PC in order to use TCP/IP remote 

control. 
 

Remote Control Setup Configuration 

The remote interface type, board address and port number can be configured using 

the OVA menu selection Options > Remote Interface Setup. The following dialog 

box appears, whether using the OVA or the OFDR software: 
 

 
 
 

8 
 

 
 
 
 
 
 

Figure 8-1. The remote interface setup dialog box. 

 
The pull-down menu allows the user to select either GPIB or TCP/IP remote 

interface. TCP/IP is the default interface. The second field is used to set either the 

GPIB address or the ethernet port number. By default, both the GPIB address and 

the ethernet port number are set to “1”. 
 

The GPIB board name is set to “GPIB0” by default. 
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For suggestions on remote setup using TCP/IP, see “Setting Up a TCP/IP Console” 

on page 195. 

 

Commands for OVA and OFDR Software 
This section gives a description of every remote control command available with 

both the OVA and OFDR control software. The next section will give OVA-only 

commands; a third section will give OFDR-only commands. 
 

The commands are organized by function. For an alphabetical listing of each 

command, see Table 8-1, “Alphabetical Summary of GPIB and TCP/IP Commands,” 

on page 199. 
 

Each of the commands listed below may be used for either GPIB or TCP/IP interface. 

The OVA control software accepts all mandatory IEEE 488.2 commands for GPIB, 

but only responds to the commands described in this section. The OVA does not 

accept TCP/IP commands that are not listed in this document. 
 

 
Important  The OVA control software does not support multiple 

commands on a line, separated by semicolons. Enter each 

command on a separate line. 
 

 

IEEE 488.2 defines commands as being either sequential or overlapped. Sequential 

commands cause the instrument to ignore other remote control commands until each 

command has completed. Overlapped commands let the device respond to incoming 

commands before pending commands completely execute. The OVA processes only 

sequential commands. 
 

All commands are case-sensitive, and must be entered exactly as they appear in this 

chapter. 

Examples of how to use these commands with Visual Basic® code are given under 

“Example Visual Basic Code” on page 188. 

Remote control commands are classified by types: 

• Standard Commands 

• System Control Commands 

• Configuration Commands 

• Data Capture and Retrieval Commands 
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Standard Commands 

These are mandatory commands required by IEEE 488.2. For consistency, they are 

also accepted by the OVA when operating with TCP/IP. These commands are 

generally not necessary for performing measurements with the OVA. For more 

information about these commands, see the IEEE 488.2 standards documents. 
 

*CLS 
 

Usage: *CLS 
 

Description: Clears the status register. 

Response: None. 

*ESE 
 

Usage: *ESE {mask value} 
 

Description: Sets the value of the Status Enable register. 

Response: None. 

*ESE? 
 

Usage: *ESE? 
 

Description: Queries the current value of the Status Enable register. 

Response: Returns a number ranging from 0 to 255. 

*ESR? 
 

Usage: *ESR? 
 

Description: Queries the value of the Event Status register. 

Response:  Returns a number ranging from 0 to 255. 

*IDN? 
 

Usage: *IDN? 

Description: Queries the OVA or OFDR for its identification string. 

Response:  Returns device information in a string identifying the 

model, manufacturer, and firmware level for the device in 

the form: 
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*OPC 

Optical Vector Analyzer, Luna Technologies Firmware: 3.8.1 

Released On: 4/15/2008. 

 

Usage: *OPC {0|1} 
 

Description: Sets the event bit in the Standard Event Status register, 

enabling (1) or disabling (0) “operation complete” event 

notification. 
 

Response: None. 
 

*OPC? 
 

Usage: *OPC? 
 

Description: Queries the OVA or OFDR to determine if the operation is 

complete. 
 

Response:         When the previous operation is complete, the response is 

“1.” If the operation is incomplete, the response is “0.” This 

response is sent immediately. 
 

*RST 
 

Usage: *RST 
 

Description: Instructs the OVA or OFDR to reset all parameters to the 

power-on defaults. 
 

Response: None. 
 

*SRE 
 

Usage: *SRE {n} 
 

Description: Sets the Service Request Enable register to n, where n can 

be any number from 0 to 255. 
 

Response: None. 



140   Chapter 8 

Controlling the OVA Remotely 

 

 
*SRE? 

 

Usage: *SRE? 
 

Description: Queries the current value of the Service Request Enable 

register. 
 

Response: Returns the value (0–255) of the Service Request Enable 

register. 
 

*STB? 
 

Usage: *STB? 
 

Description: Queries the value of the Status Byte register. 

Response: Returns the value (0–255) of the Status Byte register. 

*WAI 
 

Usage: *WAI 
 

Description: Prevents the OVA or OFDR from executing any further 

commands or queries until all pending operations have been 

completed. 
 

Response: None. 
 

*TST? 

8 Usage: *TST?
 

Description: Performs a self-test query. 
 

Response: None. 
 

*QUIT 

Usage: *QUIT 

Description: Ends a remote session, allowing the OVA or OFDR to go 

back to local control mode. 

Response: None. 
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System Level Commands 

 

SYSTem:WARM? 
 

Usage: SYST:WARM? 
 

Description: Queries if the laser is at operating temperature. 
 

Response: Returns the digit “1” if the laser is at operating temperature, 

or “0” if it is not at operating temperature. 
 

SYSTem:WarmupTIMeremaining? 
 

Usage: SYST:WTIM? 
 

Description: Retrieves the time remaining on the system one hour warm- 

up timer. 
 

Response: Returns the current warm-up time left in minutes. 
 

If the OVA instrument and PC have warmed-up for the 

specified hour, this command will return zero, “0”, meaning 

no warm-up time is left. 
 

Note: It is always recommended to query the warm-up timer 

before calibrating and taking measurements. The OVA must 

be at a stable temperature in order to consistently perform 

accurate measurements according to published 

specifications. 8 
SCAN 

 

Usage: SCAN 
 

Description: Tells the OVA to execute an optical scan based on the 

configured system parameters. Depending on the 

wavelength range setting and the number of averages, this 

command may take up to several minutes to complete. 
 

Response: None. 
 

Note: It is advisable to use the SYST:ERR? query after each 

SCAN command and before attempting to retrieve the data 

with FETC queries. This will reveal any errors that occurred 

during the scan. 
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SYSTem:ALIGn 

 

Usage:  SYST:ALIG 

Description: Aligns the optics. 

Response:  None. 

Notes: This process may take several minutes. Adjust the time-outs 

for your application accordingly. 
 

After a successful alignment, the system will automatically 

perform an internal calibration. 
 

Poll for *OPC? to see whether the operation is completed 

or not. 
 

SYSTem:ALIGn? 
 

Usage: SYST:ALIG? 
 

Description: Queries the OVA if the optics are aligned. 
 

Response: Returns “1” if the optics are aligned, or “0” if they are not 

aligned. 
 

Note: The validity of alignment is checked with every scan. If it 

is determined that the alignment is no longer valid, then this 

status switches to “0.” Thus it is prudent to issue this query 

periodically after intervals of scanning to verify that the 

alignment was valid during the last scan. 
 

SYSTem:CALibration? 
 

Usage: SYST:CAL? 
 

Description: Queries the system calibration status. 

Response: Returns “1” if the system is in calibration or “0” if it is not. 

Note: The validity of calibration is checked with every scan. If it 

is determined that the calibration is no longer valid, then this 

status switches to “0.” In this case, the user may either 

recalibrate (by using the SYST:FCAL, SYST:ICAL, or 

SYST:QCAL commands described above), or reload a 

previous calibration file (by using the SYST:RLDC 

command described below). 
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SYSTem:ReLoaDCalibration 

 

Usage: SYST:RLDC 
 

Description: Reloads a calibration file into memory. The OVA software 

looks for an appropriate calibration file based on the Type 

of Measurement set using the CONF:TEST command. 

(See “CONFigure:TEST” on page 149.) 
 

Response: None. 
 

Note:                 The user may send this command if SYST:CAL? returns a 

“0,” indicating that the calibration failed. Alternately, the 

user may recalibrate using the SYST:FCAL, SYST:ICAL, 

or SYST:QCAL commands described above. 
 

SYSTem:ERRor? 
 

Usage: SYST:ERR? 
 

Description: Queries the OVA for the error status of the most recent 

command or query. 
 

Response: Returns an error code followed by a text description of the 

error. Zero (0) indicates no error; i.e. the last command or 

query completed successfully. Any non-zero number 

indicates that an error has occurred. A description of the 

error may be retrieved with the query SYST:ERRD? 
 

The numeric field ranges from -32767 to +32767, with “0” 

indicating that the last command or query completed 

successfully. The total length of the error message will be 

less than 512 bytes. Two examples of error messages are: 
 

10: The optics must first be aligned before a scan can be executed 

0: No error 

Response: Returns a numeric error code. A code of 0 indicates no error; 

i.e. the last command or query completed successfully. Any 

non-zero number indicates that an error has occurred. A 

description of the error may be retrieved with the query 

SYST:ERRD? 
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SYSTem:ERRorDescription? 

Usage: SYST:ERRD? 

Description: Retrieves the detailed error description for the most recent 

remote operation. 

Response:         Retrieves a string explaining the results of the most recent 

operation. The total length of the error message will be less 

than 512 bytes. Two examples of error messages are: 

Examples: Not a valid trace: W 

Missing parameter: <center wavelength> 
 

SYSTem:LASEr 
 

Usage: SYST:LASE {0|1} 
 

Description: Turns on the laser if the parameter is “1”, or turns it off if 

the parameter is “0”. 
 

Response: None. 
 

SYSTem:LASEr? 
 

Usage: SYST:LASE? 

Description: Queries if the laser is on. 

Response: Returns “1” if the laser is on, or “0” if the laser is not on. 

8 SYSTem:ReaDY?
 

Usage: SYST:RDY? 
 

Description: Queries if the OVA is ready to scan. 
 

Response: Returns “1” if the OVA is ready to scan, or “0” if it is not 

ready to scan. 
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SYSTem:LOAD 

 

Usage: SYST:LOAD “{filename.bin}” 
 

Description: Loads the external file specified in quotes as a source of data 

reference for the measurement. 
 

If the file format is not correct, an error flag will be set. The 

cause of the error can be determined by using the 

SYST:ERR? query. 
 

Response: None. 
 

Note: The entire file path must be in quotes. Only load “.bin” type 

files. This command always loads the data into Matrix A. 
 

Example: SYST:LOAD “C:\SavedFiles\test.bin” loads the data 

contained in the file “test.bin” into Matrix A. 
 

SYSTem:LAST? 
 

Usage: SYST:LAST? 

Description: Queries the last remote command or query processed by the 

device. This query can be used to determine whether a 

command was received and processed. 

Response: Returns the name of the last remote command or query 

processed by the device. 

Example: CONF:INTW 1.5 

SYST:LAST? 

This query returns “CONF:INTW”. Note that SYST:LAST? 

only returns the name of the last command and does not 

report any parameters included with the command. 
 

SYSTem:VERsion? 

Usage: SYST:VER? 

Description: Queries the software version. 

Response: Returns a string containing the OVA software version. 

Example: 3.8.1 
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Configuration Commands 

 

CONFigure:CenterWaveLength 
 

Usage OVA:  CONF:CWL {wavelength, operationType} 
 

Usage OFDR:  CONF:CWL {centerWavelength} 
 

Description: Sets the Center  Wavelength  (nm) and for the specified 

operationType. The wavelength parameter must be within 

the operating range of the instrument. 
 

For the OVA only, the operationType is 0 for measurement, 

1 for full calibration, or 2 for internal calibration. If no 

operationType is specified, the Center Wavelength will be 

set for measurement (0). 
 

Response: None. 
 

Notes: Every time the center wavelength is changed for full 

calibration or internal calibration, the system will go out of 

calibration, so the user must then recalibrate the system 

(using SYST:FCAL or SYST:ICAL, respectively). Failure 

to do so can result in system malfunction. 
 

If the center wavelength and wavelength range settings for 

an internal calibration fall outside the most recent full 

calibration, the internal calibration wavelength settings will 

be coerced to fit within the most recent full calibration. 

Likewise, if the range of wavelengths chosen for a 

measurement fall outside of the internal calibration range, 

they will be coerced to fit within the internal calibration 

range. 
 

Examples: “CONF:CWL 1550.0” or “CONF:CWL 1550.0,0” 
 

Either command sets the Center Wavelength to 1550.0 nm 

for the next measurement. 
 

“CONF:CWL 1550.0,2” sets the Center Wavelength  for 

internal calibration to 1550.0 nm. 
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CONFigure:CenterWaveLength? 

 

Usage OVA:  CONF:CWL? {operationType} 
 

Usage OFDR:  CONF:CWL? 
 

Description: Queries the current Center  Wavelength.  In the OVA, 

operationType must be specified. The operationType is 0 for 

measurement, 1 for full calibration, or 2 for internal 

calibration. If no operationType is specified, the query will 

return the Center  Wavelength  for measurement (0). 

Response:  Returns the current Center  Wavelength  in nanometers. 

Examples: “CONF:CWL?” or “CONF:CWL? 0” returns the Center 

Wavelength  for measurement in the form “1550.00” nm. 
 

“CONF:CWL? 1” returns the Center  Wavelength  for full 

calibration in the form “1550.00” nm. 
 

CONFigure:STARtwavelength  (This command is being phased out.) 
 

Usage: CONF:STAR {wavelength} 
 

Description: Sets the start wavelength for the scan in nanometers. The 

wavelength parameter must be within the operating range 

of the instrument. 
 

If the start wavelength falls outside the limits of the 

instrument and the most recent internal calibration, the 

command is accepted, but the start wavelength will be 

coerced to the nearest wavelength within the OVA’s limits 

using the current setting of Wavelength  Range. 
 

Response: None. 
 

Note: This command is included for backward compatibility only, 

and may not be supported by future versions of the OVA 

control software. This command has been replaced by 

CONF:CWL. 
 

Example: CONF:STAR 1525.0 
 

This command sets the starting wavelength to 1525.0 nm. 
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CONFigure:STARtwavelength?  (This command is being phased out.) 

 

Usage: CONF:STAR? 
 

Description: Queries the OVA for the current start wavelength. 

Response:  Returns the current start wavelength in nanometers. 

Note: This command is included for backward compatibility only, 

and may not be supported by future versions of the OVA 

control software. This command has been replaced by 

CONF:CWL?. 
 

Example: CONF:STAR? 
 

This query returns a message in the form “1525.00.” 
 

CONFigure:ENDwavelength? 
 

Usage: CONF:END? 
 

Description: Queries the OVA for the current ending wavelength. 

Response:  Returns the current ending wavelength in nanometers. 

Example:  CONF:END? 

This query returns a message in the form “1590.00” nm. 
 

CONFigure:RANGe 

8 Usage: CONF:RANG {scanRange, operationType} 

Description: Sets the Scan Range in nanometers for the specified 

operationType. The OVA only allows scan ranges that have 

a number of data points equal to a power of two, so the 

actual value of the Scan Range will be set to the valid value 

closest to x. 
 

The operationType is 0 for measurement, 1 for full 

calibration, or 2 for internal calibration. If no 

operationType is specified, the Scan Range will be set for 

measurement (0). 
 

Response: None. 
 

Notes: Every time the wavelength range is changed for full 

calibration or internal calibration, the system will go out of 
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calibration, so the user must then recalibrate the system 

(using SYST:FCAL or SYST:ICAL, respectively). Failure 

to do so can result in system malfunction. 
 

If the center wavelength and wavelength range settings for 

an internal calibration fall outside the most recent full 

calibration, the internal calibration wavelength settings will 

be coerced to fit within the most recent full calibration. 

Likewise, if the range of wavelengths chosen for a 

measurement fall outside of the internal calibration range, 
 

Examples: CONF:RANG 5.0 or CONF:RANG 5.0,0 sets the Scan 

Range for the next measurement to the valid range closest 

to 5.0 nm. 
 

CONF:RANG 5.0,2 sets the Scan Range for internal 

calibration to the valid range closest to 5.0 nm. 
 

CONFigure:RANGe? 
 

Usage: CONF:RANG? {operationType} 
 

Description: Queries the OVA for the current Scan Range for the 

specified operationType: 0 for measurement or 1 for 

internal calibration. If no operationType is specified, the 

query will return the Scan Range for measurement (0). 

Response: Returns the current Scan Range in nanometers. 8 
Examples: “CONF:RANG?” or “CONF:RANG? 0” returns the Scan 

Range for measurement in nanometers. 
 

“CONF:RANG? 1” returns the Scan Range for internal 

calibration in nanometers. 
 

Returns a message in the form “20.0” nm. 
 

CONFigure:TEST 

Usage: CONF:TEST {measurementType, operationType} 

Description: Sets the Type of Measurement to reflection (0) or 

transmission (1) for the specified operationType. The 

operationType is 0 for device measurement, 1 for full 

calibration, or 2 for internal calibration. If no 
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operationType is specified, the instrument will be set for 

scanning, or measurement (0). 
 

Response: None. 
 

Examples: “CONF:TEST 0” or “CONF:TEST 0,0” sets the Type of 

Measurement for device measurement (scanning) to 

reflection. 
 

“CONF:TEST 1,1” sets the Type of Measurement for full 

calibration to transmission. 
 

CONFigure:TEST? 
 

Usage: CONF:TEST? {operationType} 
 

Description: Queries the OVA for the current Type of Measurement for 

the specified operationType: 0 for device measurement, 1 

for full calibration, or 2 for internal calibration. If no 

operationType is specified, the query will return the Type 

of Measurement for device measurement. 
 

Response: Returns “0” if the Type of Measurement is set for 

reflection, or “1” for transmission. 
 

Examples: “CONF:TEST?” or “CONF:TEST? 0” returns the Type of 

Measurement for device measurement in the form “0” for 

reflection or “1” for transmission. 
 

“CONF:TEST? 1” returns the Type of Measurement for 

full calibration in the form “0” for reflection or “1” for 

transmission. 
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Data Capture and Retrieval Commands 

 

FETCh:FREQuency? 
 

Usage: FETC:FREQ? 
 

Description: Queries the OVA for the starting frequency and the 

increment size, both in units of GHz. 
 

Response:         Returns two numeric values delimited by a comma. The first 

value is the starting frequency (GHz), and the second value 

is the frequency increment size/sample spacing (GHz). 
 

If a successful scan has not been made before this query, 

the OVA will respond with a 0, indicating that there is no 

data available. The cause of error can be retrieved by using 

the SYST:ERR? query. 
 

Example: FETC:FREQ? 
 

This query returns a message in the form 

“195000,0.321073,” meaning the starting frequency is 

195000 GHz and the frequency increment size/Sample 

Spacing is 0.321073 GHz. 
 

FETCh:TimedomainINCrement? 
 

Usage: FETC:TINC? 
 

Description: Queries the OVA for the time increment of the Time 

Domain Window X-axis in nanoseconds (ns). 
 

Response: Returns the time increment of the Time Domain Window 

X-axis in nanoseconds (ns). 
 

If a successful scan has not been made before this query, 

the OVA will respond with a 0, indicating that there is no 

data available. 
 

Example: FETC:TINC? 
 

This query returns a message in the form “0.000567” ns. 
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FETCh:FSIZe? 

 

Usage: FETC:FSIZ? 
 

Description: Queries the OVA for the size of the data arrays. 
 

This query should be called before retrieving the X-axis or 

the optical test results (insertion loss, group delay, etc.) if 

the controller program needs to pre-allocate space for the 

data. 
 

Response: The response is an integer indicating the number of data 

samples to expect from the FETC:XAXI? and 

FETC:MEAS? queries. 
 

If a successful scan has not been made before this query, 

the OVA responds with 65536, the largest data array size 

available. The cause of error can be retrieved by using the 

SYST:ERR? query. 
 

Example: FETC:FSIZ? 
 

This query returns a message in the form “4096” data points. 
 
 
 

 

8 
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 Jones Matrix  Parameter units 

0 Insertion Loss dB 

1 Group Delay ps 

2 Chromatic Dispersion ps/nm 

3 Polarization Dependent Loss dB 

4 Polarization Mode Dispersion ps 

5 Linear Phase Deviation rad 

6 Quadratic Phase Deviation rad 

7 Jones Matrix Element Amplitudes  

8 Jones Matrix Element Phases rad 

9 Time Domain (Amplitude) GW/J 

10 Time Domain (Wavelength) nm 

11 Min/Max Loss dB 

12 Second Order PMD ps
2 

13 Phase Ripple Linear rad 

14 Phase Ripple Quadratic rad 

 

 
FETCh:MEASurement? 

 

Usage: FETC:MEAS? {x} 
 

Description: Queries the OVA for the measured data array for the Jones 

matrix parameter specified by x. 
 

The parameter x can take values from 0 to 14: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8 
 
 
 
 
 
 
 
 
 
 
 
 

This query is usually preceded by the FETC:FSIZ? query 

to determine the number of data points that will be returned. 
 

Response: Returns an array with each element in floating point format 

with ten significant digits and possible exponent field of the 
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form [?]d.ddddddddd[e[?]ddd]. 

 

If space needs to be allocated for the receiving buffer, the 

amount required for each element is 18, including a carriage 

return as the delimiter. 
 

If a successful scan has not been made before this query, 

the OVA will respond, “An attempt was made to retrieve 

data, when no data was acquired or loaded.” The cause of 

error can be retrieved by using the SYST:ERR? query. 
 

Example: FETC:MEAS? 8 
 

This query returns the Jones Matrix element phases (rad) 

in the form: 
 

-0.169698 

-0.182416 

-0.151350 
 

and so on. 
 

FETCh:MeasurementDETails? 
 

Usage: FETC:MDET? 
 

Description: Queries the OVA for current measurement details for Matrix 

A. 

8 Response: Returns a string of information (shown below) about the 
current Matrix A data. 

 

If a successful scan has not been made before this query, 

the OVA will respond, “An attempt was made to retrieve 

data, when no data was acquired or loaded.” The cause of 

error can be retrieved by using the SYST:ERR? query. 
 

Example: FETC:MDET? 
 

This query returns a message in the form: 
 

DUT Length (m): 3.000000 

End Wavelength (nm): 1605.000000 

Segment Size: 32768 

Measurement Type: 1 

Sample Spacing (GHz): 0.335265 
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Start Frequency (ns): 185634.000000 

Time Increment (ns): 0.000153 

TD Windowed RSBW (GHz): 3.521000 

Number of Averages: 5 

Measurement Time Stamp: 3/1/2008 09:20:45 

 

Commands for OVA only 
 

OVA-only System Command 
 

SYSTem:FullCALibration 
 

Usage: SYST:FCAL 
 

Description: Performs a full calibration of the OVA with the PDL 

calibration option on. 
 

The OVA control software will prompt the user to connect 

and move the supplied polarization controller paddles. 
 

Response: None. 
 

Notes: Do not use this command in automated test scripts because 

this command requires user interaction with the OVA 

software and hardware. 
 

This process may take several minutes to complete, so 

adjust application time-outs accordingly. 

A full calibration should be performed every 72 hours. 

Poll for *OPC? to see whether the operation is completed 

or not. 
 

SYSTem:InternalCALibration 
 

Usage: SYST:ICAL 
 

Description: Performs an internal calibration. 

Response: None. 

Notes:               This command does not perform a full calibration of the 

system. A full calibration should be performed every 72 

hours using the SYST:FCAL command, or as described 
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under “Calibrating the System” on page 34. Internal 

calibrations should be performed more frequently, as 

described under “Conditions that Require Calibration” on 

page 35. 
 

This process may take several minutes to complete, so 

adjust application time-outs accordingly. 
 

Poll for *OPC? to see whether the operation is completed 

or not. 
 

SYSTem:QCALibration 
 

Usage: SYST:QCAL 
 

Description: Performs a full calibration of the OVA with the PDL 

calibration option off. 
 

A reference patchcord or gold reflector [depending on the 

Type of Measurement set using the CONF:TEST 

command. (See “CONFigure:TEST” on page 149.)] must 

be connected to the OVA before issuing this command. 
 

Response: None. 
 

Notes: This process may take several minutes to complete, so 

adjust application time-outs accordingly. 
 

Poll for *OPC? to see whether the operation is completed 

or not. 
 

SYSTem:FILTer 
 

Usage: SYST:FILT 
 

Description: Applies the smoothing filter to all data currently in the 

memory of the OVA PC. 
 

Response: None. 
 

Note: This command applies the filter to data stored in Matrices 

A, B, and C, but only data in Matrix A is available for 

retrieval through a remote interface. 
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SYSTem:SWEEp 

 

Usage: SYST:SWEE 
 

Description: Opens the laser Source switch and sweeps the laser through 

the user-specified wavelengths without performing a scan. 

This command allows the OVA to function as a tunable light 

source. Depending on the wavelength range setting, this 

command can take up to 15 seconds to complete. 
 

Response: None. 
 

Notes: Use the CONF:WAVE command (page 172) to set the 

wavelength for this command. 
 

It is necessary to close the Source switch (using the 

CONF:SOUR 1” command, page 172) after a sweep before 

performing a measurement scan. 
 

It is not necessary to open the Source switch (using 

“CONF:SOUR 0” command) before performing a sweep, 

as the SYST:SWEE command begins by opening the 

Source switch. 
 

SYSTem:SAVeJonesmatrix 
 

Usage: SYST:SAVJ “{filename.bin}” 
 

Description: Saves the current Jones matrix data in Matrix A as binary 

data in the filename.bin specified. 
 

An error flag will be set if no data is available to save. The 

cause of error can be determined by using the SYST:ERR? 

query. 
 

Response: None. 
 

Note: The entire file path must be in quotes, and the file type 

“.bin” must be specified. This command always saves the 

data from Matrix A. 
 

Example: SYST:SAVJ “C:\SavedFiles\JM.bin” saves the data from 

Matrix A into the file “JM.bin.” 
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SYSTem:SAVeStextfile 

 

Usage: SYST:SAVS “{filename.txt}” 
 

Description: Saves the current data in Matrix A as text data in the 

filename.txt specified. The spreadsheet will contain all 

parameters. 
 

An error flag will be set if no data is available to save. The 

cause of error can be determined by using the SYST:ERR? 

query. 
 

Response: None. 
 

Note: The entire file path must be in quotes, and the file type “.txt” 

must be specified. This command always saves the data 

from Matrix A. 
 

Example: SYST:SAVS “C:\SavedFiles\measData.txt” saves the data 

from Matrix A into the file “measData.txt.” 
 

SYSTem:SAVText 
 

Usage: SYST:SAVT “{filename.txt}” 
 

Note: This same command works with different variables in the 

OFDR software (see page 176). 
 

Description: Writes the OVA spreadsheet file to the given name. The file 

name must be in quotes, and the file type “.txt” must be 

specified. 
 

SYST:SAVT writes only the curves selected in the “Select 

Save Options” dialog in the OVA software. This command 

is similar to SYST:SAVS, except that SYST:SAVS saves all 

available curve types, not just the selected curves. 
 

Response: None 
 

Example: SYST:SAVT “C:\data.txt” 
 

Saves the selected curves to the file “C:\data.txt” 
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OVA-only Configuration Commands 

 

CONFigure:AlwaysApplyFilter 
 

Usage: CONF:AAF {0|1} 
 

Description: Enables (1) or disables (0) the Always Apply Filter 

boolean. Once this flag is enabled, the resolution bandwidth 

smoothing filter will be applied automatically. If this flag 

is disabled, the resolution bandwidth smoothing filter can 

be applied using “SYST:FILT.” 
 

The Always Apply Filter boolean is disabled (0) if no value 

is specified. 
 

Response: None. 
 

Example: “CONF:AAF 0” disables the Always Apply Filter boolean. 
 

CONFigure:AlwaysApplyFilter? 
 

Usage: CONF:AAF? 

Description:  Retrieves the status of the Always Apply Filter  boolean. 

Response: Returns “0” if the Always Apply Filter is disabled, or “1” 

if enabled. 
 

CONFigure:AVeraGE 
 

Usage: CONF:AVGE {0|1} 
 

Description: Enables (1) or disables (0) matrix averaging. The averaging 

boolean is disabled (0) if no value is specified. 
 

Response: None. 
 

Example: “CONF:AVGE 1” enables matrix averaging. 
 

CONFigure:AVeraGE? 
 

Usage: CONF:AVGE? 
 

Description: Retrieves the status of matrix averaging. 
 

Response: Returns “0” if the matrix averaging is disabled, or “1” if 

enabled. 
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CONFigure:AVeraGeSet 

 

Usage: CONF:AVGS {number, operationType} 
 

Description: Sets the number of averages to the input number for the 

specified operationType. If the value is larger than the 

maximum number of averages allowed for the Scan Range 

specified by CONF:RANG, the number of averages will be 

set to the maximum value. If no value is specified, the 

number of averages is set to 1. 
 

The operationType is 0 for measurement, 1 for full 

calibration, or 2 for internal calibration. If no 

operationType is specified, the OVA will be set for 

measurement (0). 
 

Response: None. 
 

Examples: “CONF:AVGS 10,0” sets the number of averages to 10 for 

measurement. 
 

“CONF:AVGS 15,1” sets the number of averages to 15 for 

full calibration. 
 

“CONF:AVGS 20” sets the number of averages to 20 for 

measurement, which is the default operationType. 
 

CONFigure:AVeraGeS? 
 

Usage: CONF:AVGS? {operationType} 
 

Description: Retrieves the number of averages taken per measurement 

for the specified operationType: 0 for measurement or 1 for 

internal calibration. If no operationType is specified, the 

query will return the number of averages for measurement. 
 

Response: Returns the number of averages for the specified 

operationType: 0 for measurement, 1 for full calibration, or 
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2 for internal calibration. If no operationType is specified, 

the number of averages for measurement will be queried. 
 

Examples: “CONF:AVGS?” or “CONF:AVGS? 0” returns the number 

of averages for measurement. 
 

“CONF:AVGS? 2” returns the number of averages for 

internal calibration. 
 

CONFigure:TimeDomainWindow 
 

Usage: CONF:TDW {0|1} 
 

Description: Enables (1) or disables (0) the menu setting Options  > 

Apply Time Domain Window. The Option will be disabled 

(0) if no value is specified. 
 

Response: None. 
 

Example: “CONF:TDW 1” enables the menu setting Options  > 

Apply Time Domain Window. 
 

CONFigure:TimeDomainWindow? 
 

Usage: CONF:TDW? 
 

Description: Retrieves the status of the menu setting Options > Apply 

Time Domain Window. 
 

Response: Returns “0” if Options  > Apply Time Domain Window 

is disabled, or “1” if enabled. 
 

CONFigure:FindDUTlengthautomatically 
 

Usage: CONF:FDUT {0|1} 
 

Description: Enables (1) or disables (0) the menu setting Options  > 

Automatically  Find DUT Length.  The option will be 

disabled (0) if no value is specified. 
 

Response: None. 
 

Example: “CONF:FDUT 1” enables the menu setting Options  > 

Automatically  Find DUT Length. 
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CONFigure:FindDUTlengthautomatically? 

 

Usage: CONF:FDUT? 
 

Description: Retrieves the status of Options > Automatically Find DUT 

Length  menu option. 
 

Response: Returns “0” if the status of Options > Automatically  Find 

DUT Length  is disabled, or “1” if enabled. 
 

CONFigure:DUTLengthset 
 

Usage: CONF:DUTL {length} 
 

Description: Sets the DUT length to the value specified in meters. When 

this command is sent without a numeric parameter, the OVA 

determines the length of the DUT automatically using the 

method selected using “CONF:DUTM.” 
 

Response: None. 
 

Examples: “CONF:DUTL 4.3125” sets the length of the DUT to 

4.3125 m. 
 

“CONF:DUTL” causes the OVA to scan the DUT and 

determine its length. 
 

CONFigure:DUTLength? 

8 Usage: CONF:DUTL?
 

Description: Queries the OVA for the current DUT length. 
 

Response: Returns the current DUT length in meters. 
 

If the DUT length has not been set by a previous 

CONF:DUTL command or by using the graphical interface 

of the OVA software, the default value (3.000) is returned. 
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CONFigure:DUTlengthfindMethod 

 

Usage: CONF:DUTM {0|1} 
 

Description: Sets the DUT Length  Find Method. 
 

When the parameter is “0,” the method is set to 

Narrowband, and when it is set to “1,” the method is set 

to Broadband. 
 

Response: None. 
 

Examples: “CONF:DUTM 0” sets the DUT Length Find Method to 

Narrowband. 
 

“CONF:DUTM 1” sets the DUT Length Find Method to 

Broadband. 
 

CONFigure:DUTlengthfindMethod? 
 

Usage: CONF:DUTM? 
 

Description: Queries the OVA for the current method of determining 

DUT length. 
 

Response: Returns “0” if the DUT Length  Find Method is set to 

Narrowband, or “1” for Broadband. 
 

CONFigure:DUTName 
 

Usage: CONF:DUTN “{name}” 
 

Description: Sets the Device Descriptor  to name. The descriptor must 

be within quotes. If no name is specified, the Device 

Descriptor remains empty. 
 

Response: None. 
 

Example: CONF:DUTN “OVA-TEST” 
 

This command sets the Device Descriptor to OVA-TEST. 
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CONFigure:DUTName? 

 

Usage: CONF:DUTN? 
 

Description: Retrieves the Device Descriptor. 
 

Response: Returns the Device Descriptor. If no name was assigned for 

DUT, the default empty string is returned. 
 

CONFigure:PhaseDEviationCursor 
 

Usage: CONF:PDEC {x1, x2} 
 

Description: Defines the effective pass band for linear and quadratic 

phase deviation measurements, bounded by the cursors x1 

and x2. A subsequent FETC:MEAS 5? (linear phase 

deviation) or FETC:MEAS 6? (quadratic phase deviation) 

query will recalculate the phase deviation prior to returning 

the data. 
 

Response: None. 
 

 
 
 
 
 
 

8 
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CONFigure:PULSecompression 

 

Usage: CONF:PULS {enabled, averageDispersion, referenceWL, 

dispersionSlope} 
 

Description: Sets the OVA's Pulse Compression  settings, which 

correspond to settings made in the Options  > Pulse 

Compression  Settings window. 
 

Enabled, the first parameter, enables (1) or disables (0) 

pulse compression. 
 

The second parameter sets the averageDispersion in ps/mm. 

The third sets the referenceWavelength in nm. 

The last parameter sets the dispersionSlope in ps/nm2. 
 

Response: None. 
 

Examples: CONF:PULS 1, 2.5, 1555, 0 
 

Enables pulse compression, with an average dispersion of 

2.5 ps/nm, a reference wavelength of 1555 nm, and a 

dispersion slope of 0 ps/nm2. 
 

CONF:PULS 0 
 

Disables pulse compression. 

Note: Pulse compression is a purchased option for the OVA. If this 8 
feature has not been purchased, the CONF:PULS command 
will be ignored. 
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CONFigure:PULSecompression? 

 

Usage: CONF:PULS? 

Description: Queries the OVA for the pulse compression settings. 

Response:  Returns the following pulse compression parameters, 

separated by commas: 
 

1 if pulse compression is enabled, 0 if disabled. 

Average Dispersion in ps/mm. 

Reference Wavelength in nm. 

Dispersion Slope in ps/nm2. 

Example: CONF:PULS? 
 

This query returns a message in the form 

“1,0.00,1550.00,0.00”. This response would indicate that 

compression is enabled with an average dispersion of 0 ps/ 

nm, a reference wavelength of 1550 nm, and a dispersion 

slope of 0 ps/nm2. 
 

Note: Pulse compression is a purchased option for the OVA. If this 

feature has not been purchased, the CONF:PULS? 

command will be ignored. 

8 CONFigure:DISPersion
 

Usage: CONF:DISP {x} 
 

Description: Sets the average dispersion (ps/nm) used for pulse 

compression. This corresponds to setting average dispersion 

in the Options  > Pulse Compression  Settings window. 
 

Response: None. 
 

Example: “CONF:DISP 4.25” sets the average dispersion to 4.25 ps/ 

nm. 
 

Note: To set all of the pulse compression settings, use the 

CONF:PULS command above. 
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CONFigure:DISPersion? 

 

Usage: CONF:DISP? 
 

Description: Retrieves the average dispersion (ps/nm) used for pulse 

compression. 
 

Response: Returns the average dispersion in the form “4.25”. 
 

CONFigure:ReSolutionBandwidthUnits 
 

Usage: CONF:RSBU {0|1} 
 

Description: Configures the Resolution Bandwidth Units for both 

filters to either picometers (1) or gigahertz (0). If no 

parameter is selected, the OVA sets the resolution 

bandwidth units to GHz. 
 

Response: None. 
 

Examples: “CONF:RSBU 1” sets the Resolution Bandwidth  Units to 

picometers. 
 

“CONF:RSBU 0” sets the Resolution Bandwidth  Units to 

gigahertz. 
 

CONFigure:ReSolutionBandwidthUnits? 
 

Usage: CONF: RSBU? 

Description: Retrieves the Resolution Bandwidth Units. 

Response:  Returns “1” if the Resolution Bandwidth Units are 

picometers, and “0” if they are gigahertz. 
 

CONFigure:FilterResolutionBandWidth 
 

Usage: CONF:FRBW {value} 
 

Description: Sets the smoothing Filter  Resolution  Bandwidth to the 

requested value in the units specified using CONF:RSBU. 
 

Response: None. 
 

Note: If the specified value is not a valid setting, the smoothing 

filter resolution bandwidth is set to the value of the time 

domain filter resolution bandwidth. Query the system using 
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the SYST:ERR? command to ensure that the requested 

value was valid. 
 

Example: “CONF:RSBW 0.125” sets the Filter  Resolution 

Bandwidth  to 0.125 in the units specified using 

CONF:RSBU. 
 

CONFigure:FilterResolutionBandWidth? 
 

Usage: CONF:FRBW? 
 

Description: Queries the OVA for the current smoothing Filter 

Resolution Bandwidth. 
 

Response: Returns the current smoothing Filter  Resolution 

Bandwidth  in the units specified using CONF:RSBU. 

Example: CONF:FRBW? 

This query returns the current smoothing Filter Resolution 

Bandwidth  in the form “1.50” in the units specified using 

CONF:RSBU. 
 

CONFigure:TimedomainWindowResolutionBandwidth? 
 

Usage: CONF:TWRB? 
 

Description: Queries the OVA for the current Time Domain Window 

Resolution Bandwidth. 
 

Response: Returns the current TD Window Res BW in the units 

specified using CONF:RSBU. The default value is 0.00. 
 

Example: CONF:TWRB? 
 

This query returns a message in the form “10.00” in the units 

specified using CONF:RSBU. 



Optical  Vector Analyzer    169 

User Guide 

 

8 

 
CONFigure:ConvolvedResolutionBandWidth? 

 

Usage: CONF:CRBW? 
 

Description: Queries the OVA for the Convolved Resolution 

Bandwidth. 
 

Response: Returns the Convolved Res BW in the units specified using 

CONF:RSBU. The default value is 0.00. 

Example: CONF:CRBW? 

This query returns a message in the form “26.458” in the 

units specified using CONF:RSBU 
 

CONFigure:SampleRESolution? 
 

Usage: CONF:SRES? 
 

Description: Queries the OVA for the current Sample Resolution. 

Response:  Returns the current Sample Resolution. 

Example: CONF:SRES? 
 

This query returns a message in the form “6.13” ns. 
 

CONFigure:TimedomainSIGma 
 

Usage: CONF:TSIG {value} 
 

Description: Sets the Sigma value in nanoseconds to create the Time 

Domain Window. Once this value is set, the Time Domain 

Window will be calculated and applied to the data currently 

in Matrix A. The change in the data can be identified by 

fetching any measurement data. 
 

The default value of sigma is 0.02 ns. 

Response: None. 

Example: “CONF:TSIG 0.50” sets the Sigma value to 0.50 ns. 
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CONFigure:TimedomainSIGma? 

 

Usage: CONF:TSIG? 
 

Description: Queries the OVA for the current value of Sigma (ns) from 

the Time Domain Window. 
 

Response: Returns the value of Sigma (ns). The default value is 0.02 

ns. 
 

Example: CONF:TSIG? 
 

This query returns a message in the form “0.02” ns. 
 

CONFigure:TimeLIMits 
 

Usage: CONF:TLIM {lowerLimit, upperLimit} 
 

Description: Sets the limits in nanoseconds that determine the roll-off 

points for the flat-top Gaussian filter function in the time 

domain. Once these values are set, the time domain filter 

will be calculated and applied to the data currently in Matrix 

A. The change of data can be identified by fetching any 

measurement data. 
 

Response: None. 
 

Note: The default upper and lower limits are set at 10% and 90% 

of Time Domain Window X-axis width. 
 

Example: “CONF:TLIM 1.50,1.80” sets the Time Domain Window 

X-axis limits to 1.50 ns and 1.80 ns. 
 

CONFigure:TimeLIMits? 
 

Usage: CONF:TLIM? 
 

Description: Queries the OVA for the current Time Domain Window 

limits. 
 

Response:         Returns the current Impulse Response X-axis limits used 

to create the Time Domain Window. The response is in the 

units of nanoseconds. 
 

Example: CONF:TLIM? 
 

This query returns a message in the form “1.05,1.80” in ns. 
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CONFigure:TimedomainsettingsRETain 

 

Usage: CONF:TRET {0|1} 
 

Description: Enables (1) or disables (0) the Retain Settings function in 

the Time Domain Window. Enabling will retain the current 

Time Domain Window parameters and apply them to 

future measurements. 
 

Response: None. 
 

Examples: “CONF:TRET 0” disables the Retain  Settings function. 

“CONF:TRET 1” retains Time Domain Window settings. 

CONFigure:TimedomainsettingsRETain? 
 

Usage: CONF:TRET? 
 

Description: Queries the OVA for the Retain Settings status in the Time 

Domain Window. 
 

Response: Returns “1” if Retain  Settings is enabled in the Time 

Domain Window, or “0” if it is disabled. 

Example: CONF:TRET? 

This query returns a message in the form “1.” 
 

CONFigure:TimedomainHANning 
 

Usage: CONF:THAN {0|1} 
 

Description: Enables (1) or disables (0) the Time Domain Hanning 

Window. 

Response: None. 

Example: “CONF:THAN 0” disables the Time Domain Hanning 

Window. 
 

Note: By default, the Hanning window is applied to time domain 

data. 
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CONFigure:TimedomainHANning? 

 

Usage: CONF:THAN? 
 

Description: Queries the OVA to determine if the Hanning window is 

currently being applied to the time domain data. 
 

Response: Returns “1” if the Time Domain Hanning  Window is 

enabled, or “0” if it is disabled. 
 

CONFigure:SOURce 
 

Usage: CONF:SOUR {0|1} 
 

Description: Sets the Source switch position to either Open (0) or Closed 

(1). 

Response: None. 

Example: “CONF:SOUR 1” sets the Source switch to the Closed 

position. 
 

Note: Use this command to return to normal OVA operation after 

using the SYST:SWEE command (see page 157). 
 

CONFigure:SOURce? 
 

Usage: CONF:SOUR? 
 

Description: Queries the Source Switch position. 
 

Response: Returns “0” if the Source switch is Open, “1” if Closed. 
 

CONFigure:WAVElength 
 

Usage: CONF:WAVE 
 

Description: Sets the wavelength to be used by the command 

SYST:SWEE (page 157). 

Response: None. 

Example: “CONF:WAVE 1550.00” sets the light source mode 

wavelength to 1550.00 nm. 



Optical  Vector Analyzer    173 

User Guide 

 

 
CONFigure:WAVElength? 

 

Usage: CONF:WAVE? 
 

Description: Queries the wavelength to be used by the command 

SYST:SWEE (page 157). 
 

Response: Returns the light source mode wavelength in the form 

“1550.00” nm. 
 

OVA-only Data Capture and Retrieval Commands 
 

FETCh:PolarizationDependentFrequency? 
 

Usage: FETC:PDF? {centerFrequency, threshold} 
 

Description:      Queries the OVA for the polarization dependent frequency 

for the specified center frequency (GHz) and threshold (dB). 
 

Response: Returns the polarization dependent frequency in units of 

GHz. 
 

Example: FETC:PDF? 193000, 0.5 
 

Returns the polarization dependent frequency for 193000 

GHz and 0.5 dB, in the form “0.318247” GHz. 
 

FETCh:JONesElements? 

Usage: FETC:JONE? 8 
Description: Queries the OVA for the raw Jones matrix elements, with 

real and imaginary parts. 
 

Response: Returns the Jones matrix data in the form: 
 

Areal  Aimag    Breal  Bimag    Creal  Cimag  Dreal  Dimag 

... 
 

Note:                 Each Jones Matrix element (Areal, Aimag, etc.) is separated 

by a tab character, with each data point separated by a line 

break. 
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FETCh:XAXIs? 

 

Usage: FETC:XAXI? {x} 
 

Note: This same command works with different variables in the 

OFDR software (see page 187). 
 

Description: Queries the OVA for the X-axis (frequency domain or time 

domain) data. The number of data points expected should 

be determined by first using the FETC:FSIZ? query. 
 

The parameter x can take values from 0 to 4: 
 

0 - Frequency Domain (nm) 
 

1 - Frequency Domain (GHz) 
 

2 - Frequency Domain (THz) 
 

3 - Time Domain (ns) 
 

4 - Frequency Domain (m) 
 

The default query “FETC:XAXI?” will return values for the 

frequency domain in nanometers. 
 

Response:         Returns an array with each element in floating point format 

with ten significant digits and possible exponent field of the 

form [?]d.ddddddddd[e[?]ddd]. 
 

If space needs to be allocated for the receiving buffer the 

amount required for each element is 18, including a carriage 

return as the delimiter. 
 

If a successful scan has not been made before this query, 

the OVA will respond, “An attempt was made to retrieve 

data, when no data was acquired or loaded.” The cause of 

error can be retrieved by using the SYST:ERR? query. 
 

Examples: “FETC:XAXI? 0” or “FETC:XAXI?” 
 

Either of these queries returns the Frequency Domain X- 

axis data in nanometers, in the form: 
 

1509.97 

1509.99 

1510.01 
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1510.02 and so on. 

 

“FETC:XAXI? 3” 
 

This query returns the Time Domain Window X-axis data 

in nanoseconds, in the form: 
 

0.3250 

0.3255 

0.3260 

0.3265 and so on. 

 

Commands for OFDR only 
 

OFDR-only System Level Commands 
 

SYSTem:ACQuired? 

Usage: SYST:ACQ? 

Description: Queries whether data has been acquired. 

Response: Returns “1” if data has been acquired by the OFDR, “0” if 

not. 
 

SYSTem:CALibration 

Usage: SYST:CAL 

Description: Calibrates the system for either reflection or transmission, 

as set by the CONF:TEST command. 

A gold reflector must be connected to the OFDR before 

issuing this command. 

Response: None. 

Notes: This process may take several minutes to complete, so 

adjust application time-outs accordingly. 

Poll for *OPC? to see whether the operation is completed. 
 

SYSTem:CALibrationFile 
 

Usage: SYST:CALF {measurementType, filename} 

Description: Sets the name of the calibration file for the Type of 

Measurement specified: reflection (0) or transmission (1). 
If the filename is not specified, this command sets 
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calibration file to the default filename for reflection 

(ofdrCal_refl) or transmission (ofdrCal_trans). 

Response: None. 

Example: SYST:CALF 1, c_band 

This instructs the OFDR to use the “c_band” calibration file 

for transmission measurements. 

SYST:CALF 0 

This instructs the OFDR to use the default calibration file 

for reflection, ofdrCal_refl. 
 

SYSTem:CALibrationFile? 
 

Usage: SYST:CALF? {measurementType} 

Description: Retrieves the name of the calibration file for the Type of 

Measurement specified: reflection (0) or transmission (1). 

Response: Returns the name of the calibration file currently in use. 
 

SYSTem:COPY 

Usage: SYST:COPY {source, destination} 

Description: Copies data from the source trace to the destination trace. 

Response:  None. 

Example: SYST:COPY A, C 

Copies the data from Trace A to Trace C. 
 

SYSTem:SAVText 

Usage: SYST:SAVT {“filename.txt”, trace, domain, graphType, 

units, spatialResolution} 
 

Note: This same command works with different variables in the 

OFDR software (see page 158). 
 

Description: Saves the specified trace (A, B, C, D or E) data as a 

spreadsheet or text file using the specified filename. The file 

name must be in quotes, with the file type “.txt” inside the 
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quotes as well. If no trace is specified, Trace A will be 

saved. 

Domain can be set to 0 for time domain, or 1 for frequency 

domain. 

GraphType can take values from 0 to 2, as shown below. 

The assignment of graphType depends on which domain is 

specified. 

 
 Graph/Parameter Name 

Time Domain (domain = 0) Values 

0 Amplitude 

1 Phase Derivative 

2 Linear Amplitude 

Frequency  Domain (domain = 1) Values 

0 Insertion Loss 

1 Group Delay 

2 Phase 

 

Units for the time domain can be set to 0 for time (ns), 1 

for length (m), or 2 for length (ft). 

Units for the frequency domain can be set to 0 for 

wavelength (nm), 1 for frequency (GHz), or 2 for frequency 

(THz). 

SpatialResolution sets the spatial Resolution Bandwidth 

(mm). 

Response: None. 

Example: SYST:SAVT “C:\SavedFiles\measData.txt”, E 

Saves the data from Matrix E into the file “measData.txt.” 
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OFDR-only Configuration Commands 

 

CONFigure:FrequencydomainWINdow 

Usage: CONF:FWIN {0|1} 

Description: Sets the frequency domain window flag, indicating whether 

or not a frequency domain window is applied to new 

measurements. A value of 0 (do not apply window) or 1 

(apply window) must be specified as a parameter. 

Response: None 

Example: CONF:FWIN 1 

This command causes the frequency domain filter to be 

applied to all new measurement scans. 
 

CONFigure:FrequencydomainWINdow? 

Usage: CONF:FWIN? 

Description: Queries the frequency domain window flag, indicating 

whether or not a frequency domain window is applied to 

new measurement scans. 

Response: Returns a value of 0 (window is not applied) or 1 (window 

is applied). 

Example: CONF:FWIN? 

This query returns 0 or 1. 

8 CONFigure:GRouP 
Usage: CONF:GRP {groupIndex} 

Description: Sets the OFDR Group  Index. 

Response: None. 
 

CONFigure:GRouP? 

Usage: CONF:GRP? 

Description: Retrieves the OFDR Group  Index. 

Response: Returns the OFDR Group  Index. 
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CONFigure:INTegrationWidth 

Usage: CONF:INTW {integrationWidth} 

Description: Sets the OFDR integration width (m). 

Response: None. 

Note: The integration width, along with the integration start 

(CONF:INTS) or center set (CONF:INTC) commands, 

defines the area that will be used for data capture and 

retrieval commands such as FETC:MEAS. All frequency 

domain values are based on this integration width and start 

or center. Setting the integration width to 0 indicates that 

the entire measurement area should be used for such 

commands. 

Setting the integration width will cause the integration 

center to be adjusted to match the new integration width and 

the integration start set using the CONF:INTS command. 
 

CONFigure:INTegrationWidth? 

Usage: CONF:INTW? 

Description: Retrieves the OFDR integration width in meters. 

Response:  Returns the OFDR integration width in meters. 
 

CONFigure:INTegrationStart 

Usage: CONF:INTS {integrationStart} 

Description: Sets the OFDR integration area start (m). 

Response: None. 

Note: Setting the integration start will cause the integration center 

to be adjusted to match the new integration start and the 

integration width set using the CONF:INTW command. 
 

CONFigure:INTegrationStart? 

Usage: CONF:INTS? 

Description: Retrieves the OFDR integration area start in meters. 

Response:  Returns the OFDR integration area start in meters. 
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CONFigure:INTegrationCenter 

Usage: CONF:INTC {integrationCenter} 

Description:  Sets the OFDR integration center start (m). 

Response:  None. 

Note: Setting the integration center will cause the integration start 

to be adjusted to match the new integration center and the 

integration width set using the CONF:INTW command. 
 

CONFigure:INTegrationCenter? 

Usage: CONF:INTC? 

Description: Retrieves the OFDR integration area center in meters. 

Response: Returns the OFDR integration area center in meters. 

CONFigure:RESolutionGhz? 

Usage: CONF:RESG? 

Description: Retrieves the Resolution Bandwidth in GHz. 

Response: Returns the Resolution Bandwidth in GHz. 
 

CONFigure:RESolutionPicometers? 

Usage: CONF:RESP? 

Description: Retrieves the Resolution Bandwidth in picometers. 

Response: Returns the Resolution Bandwidth in picometers. 

8 CONFigure:SpatialresolutionFILter 

Usage: CONF:SFIL {0|1} 

Description: Sets the Spatial Resolution Filter, or smoothing filter, flag 

on (1), or off (0). 

Response: None. 

Note: Data can be filtered after a scan. 
 

CONFigure:SpatialresolutionFILter 

Usage: CONF:SFIL? 

Description: Retrieves the Spatial  Resolution Filter  flag. 

Response: Returns “1” if the Spatial Resolution Filter flag is on, “0” 

if it is off. 
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CONFigure:SpatialResolutionBandWidth 

Usage: CONF:SRBW {spatialResolution} Description:

 Sets the spatial Resolution Bandwidth  (mm). 

Response: None. 
 

CONFigure:SpatialResolutionBandWidth? 

Usage: CONF:SRBW? 

Description: Retrieves the spatial Resolution Bandwidth in millimeters. 

Response:  Returns the spatial Resolution Bandwidth in millimeters. 
 

CONFigure:SpatialResolutionFilterWidth 

Usage: CONF:SRFW {filterWidth} 

Description: Sets the Spatial  Resolution Filter  width (ns). 

Response: None. 
 

CONFigure:SpatialResolutionFilterWidth? 

Usage: CONF:SRFW? 

Description: Retrieves the Spatial  Resolution Filter  width in 

nanoseconds. 

Response: Returns the Spatial  Resolution  Filter  width in 

nanoseconds. 
 

CONFigure:XaxisUNIts 

Usage: CONF:XUNI {units} 

Description: Sets the X-axis units being used to specify the integration 

area. These are the units that will be used by the 

CONF:INTW, CONF:INTS, and CONF:INTC commands 

and queries to report or set the integration width, start, and 

center. The units parameter must have one of the following 

values: 

0 : nanoseconds 

1 : meters 

2 : feet 

Response: None 

Example: CONF:XUNI 0 

CONF:INTW? 
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Response: 15.010384 

The CONF:XUNI command sets the x-axis units to 

nanoseconds. This means that the CONF:INTW? response 

should be interpreted as 15.01 nanoseconds, and that any 

CONF:INTW, CONF:INTS, or CONF:INTC commands 

should specify their units in nanoseconds. 
 

CONFigure:XaxisUNIts? 

Usage: CONF:XUNI? 

Description: Queries the X-axis units being used to specify the 

integration area. These are the units that will be used by the 

CONF:INTW, CONF:INTS, and CONF:INTC commands 

and queries to report or set the integration width, start, and 

center. 

Response: Returns a number indicating the x-axis units used to define 

the integration area. The possible responses are: 

0 : nanoseconds 

1 : meters 

2 : feet 

Example: CONF:XUNI? 

Response: 1 

CONF:INTW? 

Response: 1.5 

The CONF:XUNI? response of 1 means that x-axis units are 

meters. This means that the CONF:INTW? response should 

be interpreted as 1.5 meters, and that any CONF:INTW, 

CONF:INTS, or CONF:INTC commands should specify 

their units in meters. 
 

OFDR-only Data Capture and Retrieval Commands 
 

FETCh:RAW? 

Usage: FETC:RAW? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the raw S and P data for the specified trace. 

The portion of the data that is returned is determined from 

the integration area previously specified with the 
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CONF:INTW, CONF:INTS, and CONF:INTC commands. 

If the integration width is set to 0, then the data is returned 

for the entire measurement area. 

Response: Returns a series of four tab-separated numbers, each set of 

numbers representing the S and P values for a single point. 

The number of points is the same as the value obtained by 

sending the FETC:RSIZ? request with the same trace 

parameter. 

The values for each point are formatted as: 

{S real <tab> S imaginary <tab> P real <tab> P imaginary} 

The string “///” is returned after the last data point to indicate 

that the response is complete. 

If no trace is specified, the data for Trace A will be returned. 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 

Example: FETC:RAW? C 

Returns the S and P data for Trace C in the form: 

-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 

-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 

... 

-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 

-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 

/// 
 

FETCh:RawdataSIZe? 

Usage: FETC:RSIZ? {trace} 

Description: Retrieves the size of the raw S and P data for the specified 

trace. This is the number of data points that will be returned 

by the FETC:RAW? query using the current integration area 

as specified by the CONF:INTW, CONF:INTS, and 

CONF:INTC commands. 

Response: Returns the size of the raw S and P data for the specified 

trace. 

If no trace is specified, the data size for Trace A will be 

returned. If a successful scan has not been made before this 

query, the OFDR responds with “Trace A (B, etc.) contains 

no data.” 
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FETCh:WaveLength? 

Usage: FETC:WL? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the starting wavelength (nm) for the specified 

trace. 

Response: Returns the starting wavelength, in nanometers, for the 

specified trace. If no trace is specified, the starting 

wavelength for Trace A is returned. If a successful scan has 

not been made before this query, the OFDR responds with 

“Trace A (B, etc.) contains no data.” 
 

FETCh:WaveLengthCenter? 

Usage: FETC:WLC? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the center wavelength (nm) for the specified 

trace. 

Response: Returns the center wavelength, in nanometers, for the 

specified trace. If no trace is specified, the center 

wavelength for Trace A is returned. If a successful scan has 

not been made before this query, the OFDR responds with 

“Trace A (B, etc.) contains no data.” 
 

FETCh:WaveLengthEnd? 

Usage: FETC:WLE? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the ending wavelength (nm) for the specified 

trace. 

Response: Returns the ending wavelength, in nanometers, for the 

specified trace. If no trace is specified, the ending 

wavelength for Trace A is returned. If a successful scan has 

not been made before this query, the OFDR responds with 

“Trace A (B, etc.) contains no data.” 
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FETCh:FrequencydomainDeTail? 

Usage: FETC:FDTL? {trace, graphType, decimate} 

Trace is specified as a single letter: A, B, C, D or E. 

GraphType should be set to 1 for Group  Delay, the only 

parameter which generates average. 

Decimate can be set to 1 to use decimation, or 0 to use all 

points when calculating the average delay. 

Description: Retrieves the average delay (ns) for the specified trace. 

Response:  Returns the average delay, in nanoseconds, for the specified 

trace. If no trace is specified, the average delay for Trace 
A is returned. 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 
 

FETCh:INTegrationLoss? 

Usage: FETC:INTL? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the loss of the current integration area for the 

specified trace. The integration area is the area previously 
specified by the CONF:INTW, CONF:INTS, and 

CONF:INTC commands. 

Response: Returns the loss in dB for the current integration area of the 

specified trace. If no trace is specified, the loss for Trace 

A is returned. If a successful scan has not been made before 

this query, the OFDR responds with “Trace A (B, etc.) 

contains no data.” 
 

FETCh:TIMeStart? 

Usage: FETC:TIMS? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the start time for the specified trace. 

Response: Returns the start time in nanoseconds for the specified trace. 

If no trace is specified, the start time for Trace A is returned. 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 
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FETCh:TIMEnd? 

Usage: FETC:TIME? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the end time for the specified trace. 

Response: Returns the end time in nanoseconds for the specified trace. 

If no trace is specified, the end time for Trace A is returned. 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 
 

FETCh:LENgthStart? 

Usage: FETC:LENS? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the start length for the specified trace. 

Response: Returns the start length in meters for the specified trace. If 

no trace is specified, the start length for Trace A is returned. 
If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 
 

FETCh:LENgthEnd? 

Usage: FETC:LENE? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 

Description: Retrieves the end length for the specified trace. 

Response: Returns the end length in meters for the specified trace. If 

no trace is specified, the end length for Trace A is returned. 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 

data.” 
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FETCh:XAXIs? 

 

Usage: FETC:XAXI? {trace, domain, units, decimate} 

Trace is specified as a single letter: A, B, C, D or E. 

Domain can be set to 0 for time domain, or 1 for frequency 

domain. 

Units for the time domain can be set to 0 for time (ns), 1 

for length (m), or 2 for length (ft). 

Units for the frequency domain can be set to 0 for 

wavelength (nm), 1 for frequency (GHz), or 2 for frequency 

(THz). 

Decimate can be set to 1 to use decimation, or 0 to return 

all points. 
 

Note: This same command works with different variables in the 

OFDR software (see page 174). 
 

Description: Retrieves the X-axis data for the specified parameters. 
 

All parameters must be specified. 

Response: Returns a series of numbers representing the X-axis data 

points for the requested area. The number of points is the 

same as the value obtained by sending the FETC:FSIZ? 

query with the same parameters. The string “///” is returned 

after the last data point to indicate that the response is 

complete. 
 

The data are returned as an array with each element in 

floating point format with ten significant digits and possible 

exponent field of the form [?]d.ddddddddd[e[?]ddd]. 
 

If space needs to be allocated for the receiving buffer the 

amount required for each element is 18, including a carriage 

return as the delimiter. 
 

If a successful scan has not been made before this query, 

the OFDR responds with “Trace A (B, etc.) contains no 
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data.” The cause of error can be retrieved by using the 

SYST:ERRD? query. 

Example: FETC:XAXI? C, 1, 0, 1 

This query returns the frequency domain X-axis data from 

Trace C, in nanometers, decimated, in the form: 
 

1509.97 

1509.99 

... 

1525.01 

1525.02 

/// 

 
Example Visual Basic Code 

This section provides sample code in Visual Basic to explain how the OVA behaves 

when accessed remotely. Users can write their own applications in Visual Basic using 

the sample code given below for multiple types of parameters. Note: Visual Basic 

is used only as an example, and users may use other programming languages of their 

choosing. 
 

Notes: 
 

• The device GPIB handle is “OVAGpibHandle” 
 

• To open an OVAGpibHandle use: OVAGpibHandle% = ildev 

(BOARD_INDEX, PRIMARY_ADDR, SECONDARY_ADDR, TIM- 

EOUT, EOTMODE, EOSMODE) 
 

• To clear an OVA GpibHandle use: ilclr OVAGpibHandle%. 
 

• To close an OVA GpibHandle use: ilonl OVAGpibHandle%, 0. 
 

• To write to the instrument board use: ilwrt OVAGpibHandle%, OVA- 

Command, Len(OVACommand). 
 

• To read the response from the instrument use: ilrd OVAGpibHandle%, 

Response, Len(Response). 
 

• To check response size use: ibcntl. 
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Sending Commands without Parameters 

 
Public Sub DoScan() 

 
Const OVACommand = “SCAN” 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

End Sub 

Sending Commands with Single Numeric Parameters 
 

Public Sub SetConfigureDutl(ByVal Dutl As Double) 

' check input parameter 

 
If (Dutl < 0) Then 

Exit Sub 

End If 

 
Dim OVACommand As String 

 
OVACommand = “CONF:DUTL” & CStr(Dutl) 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

 
End Sub 

 

Sending Commands with Single String Parameters 

Public Function CommandSystemLoadFile(ByVal FilePath As String) 8 
Dim OVACommand As String 

OVACommand = “SYST:LOAD “& FilePath 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

End Function 

Sending Commands with Two Numeric Parameters 
 

Public Sub ConfigureAxisIndeces(ByVal ParamString As String) 

Dim OVACommand As String 

OVACommand = “CONF:PDEC“& CStr(ParamString) 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

End Sub 
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Sending Queries which return Numeric Results 

 

Public Function QueryOperateComplete() As Integer 

 
Const OVACommand = “*OPC?” 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

Response = “” 

ilrd OVAGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 

End If 

 
If IsNumeric(Response) Then 

QueryOperateComplete = CInt(Response) 

Else 

QueryOperateComplete = 0 

End If 

 
End function 

 
Sending Queries which return Double Results 

 
Public Function QueryConfigureDutl() As Double 

 
Const OVACommand = “CONF:DUTL?” 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

Response = “” 

ilrd OVAGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 

End If 

 
If IsNumeric(Response) Then 

QueryConfigureDutl = CDbl(Response) 

Else 

QueryConfigureDutl = 0 

End If 

 
End function 

 
Sending Queries which return Two Double Results 
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Public Sub QueryFrequency(ByRef Frequency As Double, ByRef 

Increment As Double) 

 
Dim TabPos As Integer 

Dim TempStr As String 

Const OVACommand = “FETC:FREQ?” 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

Response = “” 

ilrd OVAGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 

End If 

 
TabPos = InStr(1, Response, vbTab) 

If (TabPos = 0) Then 

Exit Sub 

End If 

 
TempStr = Left(Response, TabPos - 1) 

If IsNumeric(TempStr) Then 

Frequency = CDbl(TempStr) 

Else 

Frequency = 0 

End If 

 
TempStr = Right(Response, Len(Response) - TabPos) 

If IsNumeric(TempStr) Then 8 
Increment = CDbl(TempStr) 

Else 

Increment = 0 

End If 

 
End Sub 

 
Sending Queries which return String Results 

 
Public Function QueryID() As String 

 
Const OVACommand = “*IDN?” 

ilwrt OVAGpibHandle%, OVACommand, Len(OVACommand) 

Response = “” 

ilrd OVAGpibHandle%, Response, Len(Response) 
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If ibcntl <= Len(Response) And ibcntl > 0 Then 

QueryID = Left(Response, ibcntl) 

Else 

QueryID = “” 

End If 

 
End function 

 
Sending Queries which return Arrays of Double Results 

Sample Basic for the “FETC:XAXI? x”, “FETC:MEAS? x” commands depends on 

the FetchData subroutine: 
 
 

Public OVAGpibHandle As Integer 

 
Const ElementLength = 18 

 
Global Const JonesArraySize = 8 

 
Const ArraySize = 1024 ' Size of read buffer 

 
Dim Response As String * ArraySize ' fixed-length string 

 
Private Sub FetchData(ByVal OVAQuery As String, ByRef _ DataArray() 

As Double, ByVal DataSize As Long) 

' DataArray is 1D array, that is, (0 To DataSize - 1) 

8 On Error Resume Next
 

Dim PrevCRPos As Long, CurCRPos As Long 

Dim DynamicResponse As String, TempStr As String 

Dim ArrayIndex As Long 

Dim ExitLoop As Boolean 

 
If DataSize <= 0 Then 

Exit Sub 

End If 

 
' Send Query 

ilwrt OVAGpibHandle%, OVAQuery, Len(OVAQuery) 

 
' Allocate Buffer Dynamically 

DynamicResponse = Space(DataSize * ElementLength) 

 
' Receive Data 
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ilrd OVAGpibHandle%, DynamicResponse, Len(DynamicResponse) 

 
If ibcntl <= Len(DynamicResponse) And ibcntl > 0 Then 

DynamicResponse = Left(DynamicResponse, ibcntl) 

Else 

Exit Sub 

End If 

 
PrevCRPos = 1 

ArrayIndex = 0 

ExitLoop = False 

 
Do 

CurCRPos = InStr(PrevCRPos, DynamicResponse, vbCr) 

 
If (CurCRPos = 0) Then 

CurCRPos = Len(DynamicResponse) + 1 

ExitLoop = True 

End If 

 
TempStr = Mid(DynamicResponse, PrevCRPos, CurCRPos - 

PrevCRPos) 

 

If IsNumeric(TempStr) Then 

DataArray(ArrayIndex) = CDbl(TempStr) 

Else 

DataArray(ArrayIndex) = 0 

End If 8 
PrevCRPos = CurCRPos + 1 

ArrayIndex = ArrayIndex + 1 

If ArrayIndex = DataSize Then 

ExitLoop = True 

End If 

Loop Until ExitLoop = True 

 
End Sub 

 

Command Errors 
When a command is ill-formed, such as when a required parameter is omitted, the 

OVA ignores the command. 
 

Use the SYST:ERR? query to retrieve the most recent error. 
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Execution Errors 

Execution errors indicate problems during the execution of a valid command, and 

may happen when: 
 

• The instrument fails to communicate to the control computer 

because of a problem with the instrument or cable connections. 

• A command is given in an improper sequence; for example, a com- 

mand to scan is given before the DUT length has been set. 
 

Like command errors, execution errors can only be retrieved if the controlling 

computer queries the OVA using the SYST:ERRD? query. 

 

OVA-Specific Application Notes 
 

Working With Time Domain Impulse Response 

The duration of the device impulse response is a useful piece of information that 

can be used to select the appropriate resolution bandwidth for the current 

measurement. The OVA provides a direct means to utilize this information using 

the Impulse Response Plot Window and the time domain filter. (See “The Time 

Domain Filter” on page 70.) 
 

The same functionality can be achieved through remote operation. It is necessary 

that the remote interface provides a means to view measured data graphically. Use 

the following sequence of commands to set the time domain filter after data has been 

acquired using the SCAN command: 
 

1 Fetch the time domain X-axis data in units of nanoseconds using 

FETC:XAXI? 3. (See “FETCh:XAXIs?” on page 174.) 
 

2 Fetch the time domain (amplitude) data using FETC:MEAS? 9. (See 

“FETCh:MEASurement?” on page 153) 
 

3 Plot the time domain (amplitude) vs. time, and determine the desired 

location of the time domain filter. 
 

4 Set the limits of the time domain filter using CONF:TLIM {lowerLimit, 

upperLimit}. (See “CONFigure:TimeLIMits” on page 170.) 
 

5 Set the value of Sigma (see “Examples: Setting the value of Sigma” on 

page 76) using CONF:TSIG {value}. (See 

“CONFigure:TimedomainSIGma” on page 169.) 
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6 Optional: Retain the time domain filter settings for subsequent 

measurements using CONF:TRET 1. (See 

“CONFigure:TimedomainsettingsRETain” on page 171). 
 

7 Fetch the desired frequency domain data using FETC:XAXI? and 

FETC:MEAS?. (See “FETCh:XAXIs?” on page 174 and 

“FETCh:MEASurement?” on page 153.) The result will have the time 

domain filter applied. 
 

Using the OVA as a Light Source 

The OVA may be used as a tunable light source using the SYST:SWEE command 

(see page 157). Following the command SYST:SWEE, the OVA opens the Source 

switch and performs a sweep of the user-specified wavelengths. Scanning and 

sweeping wavelengths may be set in the main window in the System Control area. 

They may also be set remotely using the CONF:CWL and CONF:RANG commands 

(see page 148). 
 

 
Important  The user must close the Source switch after a sweep 

before scanning by issuing the command “CONF:SOUR 

1” (see page 172). 
 

 

The user does not need to use the “CONF:SOUR 0” command to open the Source 

switch prior to sweeping; this is done automatically by the command SYST:SWEE. 

(Using the separate “CONF:SOUR 0” command will not cause errors; it will only 

slow OVA processing). 
 

The Source switch is set to its default closed state after calibration and after finding 

the DUT Length. The user may query the Source switch position using the 

CONF:SOUR? command (page 172). 

 
Setting Up a TCP/IP Console 

Use the following steps to install a TCP/IP remote controller for the OVA instrument: 
 

1 Copy the executable file named “SendCmd.exe” from the supplied CD 

to the local hard drive (usually the C:\ drive) of the host computer. 
 

2 Run SendCmd.exe from the DOS command prompt. 
 

3 Enter commands in the following format: 
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C:\SendCmd [CmdStr] [IPaddr] [PortNum] [Comment] 

 

where 
 

• [CmdStr] is the remote control command to be sent to the OVA. 

• [IPaddr] is the IP address of the OVA PC. 

• [PortNum] is the port number where OVA instrument is listen- 

ing (port number is ‘1’ by default, but this can be configured 

using pull down menu Options > Remote Interface Setup). 

• [Comment] is an optional comment to be passed with the com- 

mand. 
 

Notes: 
 

• Accessing the local machine does not require [IPaddr]. This option 

allows the console application to run on the OVA PC. 
 

• The argument [IPaddr] can be a system name or an IP address of a 

machine where the OVA software is running. 
 

• To ascertain the IP address of the OVA PC, select Run from the Win- 

dows® Start menu. Type in “ipconfig” in the text box and click OK. 

The IP address should be listed in the screen that opens. Or, the user 

may call “ipconfig” from the DOS command line to get the IP address. 
 

Example: 
 

SendCmd CONF:TEST? Ravi 

//Where “Ravi” is a machine name and “CONF:TEST?” is an 

OVA query. 

 
-OR- 

 
SendCmd CONF:TEST? 10.1.1.69 1 

//Where 10.1.1.69 is the IP address of the OVA computer 

and port number is 1. 

 
-OR- 

 
SendCmd CONF:TEST? 

//In this case the TCP/IP console application is running 

on the OVA computer rather than on a remote computer. Thus no 

IP address is needed. 
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• When accessing OVA remotely using TCP/IP, make sure to provide the 

port number. The OVA will be listening and responding at port 1 by 

default. The remote controller should use the same port number as the 

OVA. 
 

• Commands, queries, and arguments must be in quotes if they contain 

spaces. 
 

Example: 
 

SendCmd “CONF:AVGS 5” 10.1.1.69 2 
 

• To avoid problems in the parsing of commands, each optional argument 

must be replaced with “” in the command line if you do not want to give 

some optional arguments. 
 

Examples: 
 

SendCmd CONF:TEST? Ravi 2 “#Measurement Query” 

SendCmd CONF:TEST? “” “” “#Measurement Query” 

• The results of a command or query can be redirected to a file using “> 

Filename” or “>> Filename” at the end of the command. 
 

Examples: 
 

SendCmd “FETC:MEAS? 1" > GDdata.txt 

SendCmd “FETC:MEAS? 3" >> PMDdata.txt 
 

• The argument [Comment] may be up to 512 bytes in size and must be 

entered in quotes. If no comment is entered, a the default comment will 

-
 

appear, giving a general description of the command or query. Com 
ments are generally used to record the type of data when results of a 

command are saved to a file. (For example, one might comment “PMD 

data acquired with 10 measurement averages.”) 
 

• Multiple commands may be grouped together in scripts. 
 

Examples: 
 

systemSetup.sh is a shell script that runs all commands as a batch. 

{ 

SendCmd SYST:ALIG 10.1.1.69 1 

SendCmd “CONF:TEST 1,1” 10.1.1.69 1 

SendCmd “CONF:CWL 1550.0,1” 10.1.1.69 

SendCmd “CONF:RANG 80,1” 10.1.1.69 1 

SendCmd “CONF:AVGS 5,1” 10.1.1.69 1 
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SendCmd SYST:CAL 10.1.1.69 1 

SendCmd SYST:ERR? 10.1.1.69 1 

} 

acqMeasurement.sh is a shell script that runs all commands as a 

batch. 

{ 

SendCmd “CONF:STAR 1525.00" 10.1.1.69 1 

SendCmd “CONF:RANG 80" 10.1.1.69 1 

SendCmd “CONF:DUTM 1" 10.1.1.69 1 

SendCmd CONF:DUTL? 10.1.1.69 1 

SendCmd SCAN 10.1.1.69 1 

SendCmd FETC:GD? 10.1.1.69 1 > C:\80nmScan\acquireGD.txt 

SendCmd FETC:CD? 10.1.1.69 1 > C:\80nmScan\acquireCD.txt 

SendCmd FETC:PMD? 10.1.1.69 1 > C:\80nmScan\acquirePMD.txt 

} 
 

• All commands are case sensitive in this application, but the user may 

write applications without case sensitivity. 
 

• Note that some of the OVA commands (SYST:CAL, SCAN, 

SYST:ALIG, CONF:DUTL) may require a large amount of time to run. 

When writing a host or controller application, make sure to allow 

enough delay for these commands. After executing one of these com- 

mands, check to see if the operation is complete using the query 

*OPC?. 

 

Alphabetical Command Summaries 
The table below provides summaries of GPIB and TCP/IP commands, listed 

alphabetically by command. For detailed information about each command, see 

“Commands for OVA and OFDR Software” above, beginning on page 137. All 

commands are given in their truncated form, and are case-sensitive. They must be 

entered exactly as they appear in this chapter. However, the user may write 

applications without case sensitivity. 
 

 
Important  The OVA control software does not support multiple 

commands on a line, separated by semicolons. Enter each 

command on its own separate line. 
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Command Description Page OBR / OFDR 

IEEE  488.2 standard commands   

*CLS Clears the status register. 138 Both 

*ESE {mask 

value} 

Sets the value {0-255} of the Status Enable register. 
 

138 
 

Both 

*ESE? Queries the current value of the Status Enable 

register. 

 
138 

 
Both 

*ESR? Queries the value of the Status Event Status 

register. 

 
138 

 
Both 

*IDN? Queries the OVA for its identification string. 138 Both 

*OPC {0|1} Sets the event bit in the Standard Event Status 

register, enabling (1) or disabling (0) “operation 

complete” event notification. 

 
139 

 
Both 

*OPC? Queries the OVA to determine if the operation is 

complete. 

 
139 

 
Both 

*RST Instructs the OVA to reset all parameters to the 

power-on defaults. 

 
139 

 
Both 

*SRE {n} Sets the Service Request Enable register to n, 

where n = 1-255. 

 
139 

 
Both 

*SRE? Queries the current value of the Service Request 

Enable register. 

 
140 

 
Both 

*STB? Queries the value of the Status Byte register. 140 Both 

*TST? Performs a self-test query. 140 Both 

*WAI Prevents the OVA from executing any further 

commands or queries until all pending operations 

have been completed. 

 
140 

 
Both 

Configuration commands Page  

CONF:AAF {0|1} Enables (1) or disables (0) Always  Apply  Filter. 159 OVA 
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CONF:AAF? Retrieves the current status of Always  Apply 

Filter. 

 
159 

 
OVA 

CONF:AVGE 

{0|1} 

Enables (1) or disables (0) matrix averaging. 
 

159 
 

OVA 

CONF:AVGE? Retrieves the current status of matrix averaging. 159 OVA 

CONF:AVGS 

{number, 

operationType} 

Sets the number of averages for the specified 

operationType: measurement (0), full calibration 

(1), or internal calibration (2). 

 
160 

 
OVA 

CONF:AVGS? 

{operationType} 

Retrieves the number of averages for the specified 

operationType: measurement (0), full calibration 

(1), or internal calibration (2). 

 
160 

 
OVA 

CONF:CRBW? Queries the OVA for the current Convolved 

Resolution Bandwidth. 

 
169 

 
OVA 

CONF:CWL 

{wavelength, 

operationType} 

Sets the Center Wavelength (nm) for the specified 

operationType: measurement (0), full calibration 

(1), or internal calibration (2). Note: For OFDR, the 

user does not specify an operationType. 

 
 

146 

 
Both, but with 

different 

variables. 

CONF:CWL? 

{operationType} 

Queries the OVA for the current Center 

Wavelength  (nm) for the specified operationType: 

measurement (0) full calibration (1), or internal 

calibration (2). 

 
 

147 

 
 

Both 

CONF:DISP {x} Sets the average dispersion for pulse compression. 166 OVA 

CONF:DISP? Queries the average dispersion for pulse 

compression. 

 
167 

 
OVA 

CONF:DUTL 

{length} 

Sets the DUT length in meters. 
 

162 
 

OVA 

CONF:DUTL? Queries the OVA for the current DUT length. 162 OVA 

CONF:DUTM 

{0|1} 

Sets the method used to calculate the DUT length 

to Narrowband (0) or Broadband (1). 

 
163 

 
OVA 

CONF:DUTM? Queries the OVA for the current method of 

determining DUT length. 

 
163 

 
OVA 
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CONF:DUTN 

“{name}” 

Sets the Device Descriptor to the DUT name 

entered within quotes. 

 
163 

 
OVA 

CONF:DUTN? Retrieves the current DUT name. 164 OVA 

CONF:END? Queries the OVA for the current ending wavelength. 148 Both 

CONF:FDUT 

{0|1} 
Enables (1) or disables (0) the menu setting 

Options  > Automatically Find DUT Length. 

 
161 

 
OVA 

CONF:FDUT? Returns “0” if the status of Automatically Find 

DUT Length  is disabled, or “1” if enabled. 

 
162 

 
OVA 

CONF:FRBW 

{value} 

Sets the smoothing Filter Resolution Bandwidth 

in the units specified using CONF:RSBU {0|1}. 

 
167 

 
OVA 

CONF:FRBW? Queries the OVA for the current filter resolution 

bandwidth. 

 
168 

 
OVA 

CONF:FWIN 

{ 0 | 1 } 

Sets the frequency domain window flag. 
 

178 
 

OFDR 

CONF:FWIN? Retrieves whether or not a frequency domain 

window is applied to new measurement scans. 

 
178 

 
OFDR 

CONF:GRP Sets the OFDR Group Index. 178 OFDR 

CONF:GRP? Retrieves the OFDR Group Index. 178 OFDR 

CONF:INTC Sets the OFDR integration center start (m). 180 OFDR 

CONF:INTC? Retrieves the OFDR integration area center in 

meters. 

 
180 

 
OFDR 

CONF:INTS Sets the OFDR integration area start (m). 179 OFDR 

CONF:INTS? Retrieves the OFDR integration area start in 

meters. 

 
179 

 
OFDR 

CONF:INTW Sets the OFDR integration width (m). 179 OFDR 

CONF:INTW? Retrieves the OFDR integration width in meters. 179 OFDR 
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CONF:PDEC 

{x1, x2} 

Defines the effective channel for linear and 

quadratic phase deviation measurements, 

bounded by x1 and x2. A subsequent FETC:MEAS 

5? (linear phase deviation) or FETC:MEAS 6? 

(quadratic phase deviation) query will recalculate 

the phase deviation prior to returning the data. 

 
 
 

164 

 
 
 

OVA 

CONF:PULS 

{enabled, 

averageDispersi 

on, referenceWL, 

dispersionSlope} 

Sets the OVA's Pulse Compression settings. 

enabled enables (1) or disables (0) pulse 

compression. 

averageDispersion in ps/mm. 

referenceWavelength in nm. 

dispersionSlope in ps/nm2. 

This command will be ignored if the Pulse 

Compression option was not purchased with the 

OVA. 

 
 
 
 
 

165 

 
 
 
 
 

OVA 

CONF:PULS? Queries the OVA for the Pulse Compression 

settings (as listed above) separated by commas. 

This command will be ignored if the Pulse 

Compression option was not purchased with the 

OVA. 

 

 
 

166 

 

 
 

OVA 

CONF:RANG 

{scanRange, 

operationType} 

Sets the Scan Range in nanometers for the 

specified operationType: measurement (0), full 

calibration (1), or internal calibration (2). 

 
148 

 
Both 

CONF:RANG? 

{operationType} 

Queries the OVA for the current Scan Range for 

the specified operationType: measurement (0), full 

calibration (1), or internal calibration (2). 

 
149 

 
Both 

CONF:RSBU 

{0|1} 

Configures Resolution Bandwidth Units to pm (0) 

or GHz (1). 

 
167 

 
OVA 

CONF:RESG? Retrieves the Resolution Bandwidth in GHz. 180 OFDR 

CONF:RESP? Retrieves the Resolution Bandwidth in 

picometers. 

 
180 

 
OFDR 

CONF:RSBU? Queries for resolution bandwidth units. 167 OVA 

CONF:SFIL Sets the Spatial Resolution Filter, or smoothing 

filter flag on (1), or off (0). Data can be filtered after 

a scan. 

 
180 

 
OFDR 
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CONF:SFIL? Retrieves the Spatial  Resolution Filter flag. 180 OFDR 

CONF:SOUR 

{0|1} 

Sets the Source switch position to either Open (1) 

or Closed (0). 

 
172 

 
OVA 

CONF:SOUR? Queries the Source  Switch position. 172 OVA 

CONF:SRBW Sets the spatial Resolution Bandwidth (mm). 181 OFDR 

CONF:SRBW? Retrieves the spatial Resolution Bandwidth in 

millimeters. 

 
181 

 
OFDR 

CONF:SRES? Queries the OVA for the current Sample 

Resolution. 

 
169 

 
OVA 

CONF:SRFW Sets the Spatial  Resolution Filter width (ns). 181 OFDR 

CONF:SRFW? Retrieves the Spatial  Resolution Filter width in 

nanoseconds. 

 
181 

 
OFDR 

CONF:STAR 

{wavelength} 

This command has been replaced by CONF:CWL. 

Sets the start wavelength (nm) for the scan. 

 
147 

 
Both 

CONF:STAR? This command has been replaced by CONF:CWL?. 

Queries the OVA for the current start wavelength. 

 
148 

 
Both 

CONF:TDW 

{0|1} 
Enables (1) or disables (0) the menu setting 

Options  > Apply  Time Domain  Window. 

 
161 

 
OVA 

CONF:TDW? Returns “0” if Apply  Time Domain  Window  is 

disabled, or “1” if enabled. 

 
161 

 
OVA 

CONF:TEST 

{measurementTy 

pe, 

operationType} 

Sets the Type of Measurement  to reflection (0) or 

transmission (1) for the specified operationType: 

device measurement (0), full calibration (1), or 

internal calibration (2). 

 
 

149 

 
 

Both 

CONF:TEST? 

{operationType} 

Queries the OVA for the current Type of 

Measurement  for the specified operationType: 

device measurement (0), full calibration (1), or 

internal calibration (2). 

 
 

150 

 
 

Both 

CONF:THAN 

{0|1} 

Enables (1) or disables (0) the Hanning window 

applied to time domain data. 

 
171 

 
OVA 

CONF:THAN? Returns “0” if the Hanning window is disabled, or 

“1” if it is enabled. 

 
172 

 
OVA 
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CONF:TLIM 

{lowerLimit,uppe 

rLimit} 

Sets the Impulse  Response  X-axis limits to the 

input parameters in nanoseconds. 

 
170 

 
OVA 

CONF:TLIM? Queries the OVA for the current Time Domain 

Window  limits. 

 
170 

 
OVA 

CONF:TRET 

{0|1} 

Enables (1) or disables (0) the Retain Settings 

function in the Time Domain  Window. 

 
171 

 
OVA 

CONF:TRET? Queries the OVA for the Retain Settings  status in 

the Time Domain  Window. 

 
171 

 
OVA 

CONF:TSIG 

{value} 

Sets the Sigma value in nanoseconds to create the 

Time Domain Window. 

 
169 

 
OVA 

CONF:TSIG? Queries the OVA for the current value of Sigma (ns) 

from the Time Domain Window. 

 
170 

 
OVA 

CONF:TWRB? Queries the OVA for the current Time Domain 

Window  Resolution Bandwidth. 

 
168 

 
OVA 

CONF:WAVE Sets the wavelength to be used by the command 

SYST:SWEE. 

 
172 

 
OVA 

CONF:WAVE? Queries the OVA for the wavelength to be used by 

the command SYST:SWEE. 

 
173 

 
OVA 

CONF:XUNI Sets the x-axis units being used to specify the 

integration area. 

 
181 

 
OFDR 

CONF:XUNI? Queries the x-axis units being used to specify the 

integration area. 

 
182 

 
OFDR 

Data capture and retrieval commands Page  

FETC:FDTL? 

{trace, 

graphType, 

decimate} 

Retrieves the average delay (ns) for the specified 

trace (A-E) and graphType. Currently graphType 

can only be set to one (1) for group delay. Decimate 

determines whether this average is calculated from 

decimated (1) or undecimated (0) data. 

 

 
 

185 

 

 
 

OFDR 

FETC:FREQ? Queries the OVA for the starting frequency (GHz) 

and the increment size (nm). 

 
151 

 
Both 

FETC:FSIZ? Queries the OVA for the size of the data arrays. 152 Both 
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FETC:INTL? 

{trace} 

Retrieves the loss of the current integration area for 

the specified trace. 

 
185 

 
OFDR 

FETC:JONE? Queries the OVA for the raw Jones matrix 

elements, with real and imaginary parts separated 

by tabs. Each data point is separated by a line 

break. 

 
 

173 

 
 

OVA 

FETC:LENE? 

{trace} 

Retrieves the end length for the specified trace. 
 

186 
 

OFDR 

FETC:LENS? 

{trace} 

Retrieves the start length for the specified trace. 
 

186 
 

OFDR 

FETC:MDET? Queries the OVA for current measurement details 

for Matrix A. 

 
154 

 
Both 

FETC:MEAS? 

{x} 

Queries the OVA for the measured data array for 

the parameter specified by x. For definitions of x, 

see page 153. 

 
153 

 
Both 

FETC:PDF? 

{centerFrequenc 

y, threshold} 

Queries the OVA for the polarization dependent 

frequency (GHz) for the specified center frequency 

(GHz) and threshold (dB). 

 
173 

 
OVA 

FETC:RAW? 

{trace} 

Retrieves the raw S and P data for the specified 

trace. 

 
182 

 
OFDR 

FETC:RSIZ? 

{trace} 

Retrieves the size of the raw S and P data for the 

specified trace. 

 
183 

 
OFDR 

FETC:TIME? 

{trace} 

Retrieves the end time for the specified trace. 
 

186 
 

OFDR 

FETC:TIMS? 

{trace} 

Retrieves the start time in nanoseconds for the 

specified trace. 

 
185 

 
OFDR 

FETC:TINC? Queries the OVA for the time increment of the Time 

Domain X-axis in nanoseconds (ns). 

 
151 

 
Both 

FETC:WL? 

{trace} 

Retrieves the starting wavelength (nm) for the 

specified trace. 

 
184 

 
OFDR 

FETC:WLC? 

{trace} 

Retrieves the Center Wavelength  (nm) for the 

specified trace. 

 
184 

 
OFDR 
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FETC:WLE? 

{trace} 

Retrieves the ending wavelength (nm) for the 

specified trace. 

 
184 

 
OFDR 

FETC:XAXI? 

{trace, domain, 

units, decimate} 

Retrieves the X-axis data for the specified 

variables: 

Trace can be A, B, C, D or E. 

Domain = 0 for the time domain, 1 for frequency 

domain. 

Units for the time domain (0): 

0 = time (ns) 

1 = length (m) 

2 = length (ft) 

Units for the frequency domain (0): 

0 = wavelength (nm) 

1 = frequency (GHz) 

2 = frequency (THz). 

Decimate: 1 = use decimation, 0 = return all points. 

 

 
 
 
 
 
 
 
 

187 

 
 
 
 
 
 
 
 

OFDR version 

of FETC:XAXI? 

FETC:XAXI? {x} Queries the OVA for the X-axis (Frequency Domain 

or Time Domain) data. The parameter x can take 

values from 0 to 4: 

0 - Frequency Domain (nm) 

1 - Frequency Domain (GHz) 

2 - Frequency Domain (THz) 

3 - Time Domain (ns) 

4 - Frequency Domain (m) 

For further details, see page 174. 

 
 
 
 

 
174 

 

 
 
 
 

OVA version of 

FETC:XAXI? 

System level commands Page  

SCAN Tells the OVA to execute an optical scan based on 

the configured system parameters. 

 
141 

 
Both 

SYST:ACQ? Queries whether data has been acquired (1) or not 

(0). 

 
175 

 
OFDR 

SYST:ALIG Aligns the optics 142 Both 

SYST:ALIG? Queries the OVA if the optics are aligned 142 Both 
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SYST:CAL Calibrates  the system. (Use SYST:ICAL, 

SYST:FCAL or SYST:QCAL for OVA) 

 
175 

 
OFDR 

SYST:CAL? Queries the system calibration status. Returns “1” 

if the system is calibrated successfully or “0” if it is 

not. 

 
142 

 
Both 

SYST:CALF 

{measurementTy 

pe, filename} 

Sets the name of the calibration file for the Type 

of Measurement  specified: reflection (0) or 

transmission (1). If the filename is not specified, this 

command sets calibration file to the default 

filename for reflection (ofdrCal_refl) or transmission 

(ofdrCal_trans). 

 
 
 

175 

 
 
 

OFDR 

SYST:CALF? 

{measurementTy 

pe} 

Retrieves the name of the calibration file for the 

Type of Measurement  specified: reflection (0) or 

transmission (1). 

 
176 

 
OFDR 

SYST:COPY 

{source, 

destination} 

Copies data from the source trace (A-E) to the 

destination trace (A-E). 

 
176 

 
OFDR 

SYST:ERR? Returns a numeric error code. Zero (0) indicates no 

error; i.e. the last command or query completed 

successfully. Any non-zero number indicates that 

an error has occurred. A description of the error 

may be retrieved with the query SYST:ERRD? 

 

 
 

143 

 

 
 

Both 

SYST:ERRD? Retrieves the detailed error description for the most 

recent remote operation. 

 
144 

 
Both 

SYST:FCAL Performs a full calibration with the Calibrate for PDL 

option on. 

 
155 

 
OVA 

SYST:FILT Applies the resolution bandwidth smoothing filter to 

Matrix A data. 

 
156 

 
OVA 

SYST:ICAL Performs an internal calibration. 155 OVA 

SYST:LASE {0|1} Turns on the laser if the parameter is “1”, or turns 

it off if the parameter is “0”. 

 
144 

 
Both 

SYST:LASE? Queries if the laser is on (1) or off (0). 144 Both 
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SYST:LAST? Returns the name of the last command or query 

processed, without the parameters specified with 

that command. 

 
145 

 
Both 

SYST:LOAD 

“{filename.bin}” 

Loads the external file filename.bin as a source of 

data reference. 

 
145 

 
Both 

SYST:QCAL Performs a full calibration with the Calibrate for PDL 

option off. 

 
156 

 
OVA 

SYST:RDY? Queries if the OVA is ready to scan (1) or not (0). 144 Both 

SYST:RLDC Reloads a calibration file into memory. 143 Both 

SYST:SAVJ 

“{filename.bin}” 

Saves the current Jones matrix data in Matrix A as 

binary data in the filename.bin specified in quotes. 

 
157 

 
OVA 

SYST:SAVS 

“{filename.txt}” 

Saves the current Jones matrix data in Matrix A as 

text data in the filename.bin specified in quotes. 

 
158 

 
OVA 
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SYST:SAVT 

{“filename.txt”, 

trace, domain, 

graphType, units, 

spatialResolution 

} 

Saves the current data from the trace specified (A- 

E) as text or spreadsheet data in the path specified 

in quotes, based on the following variables: 

Trace can be A, B, C, D or E. 

Domain = 0 for the time domain, 1 for frequency 

domain. 

GraphType values for the time domain (0): 

0 = Amplitude 

1 = Phase Derivative 

2 = Linear Amplitude 

GraphType values for the frequency domain (1): 

0 = Insertion Loss 

1 = Group Delay 

2 = Phase 

Units for the time domain (0): 

0 = time (ns) 

1 = length (m) 

2 = length (ft) 

Units for the frequency domain (0): 

0 = wavelength (nm) 

1 = frequency (GHz) 

2 = frequency (THz). 

SpatialResolution sets the spatial Resolution 

Bandwidth (mm). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

176 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
OFDR version 

of SYST:SAVT 

SYST:SAVT 

“{filename.txt}” 

Saves text data of only the curves selected in the 

“Select Save Options” dialog in the OVA software. 

This commands is similar to SYST:SAVS, except 

that SYST:SAVS saves all available curve types, 

not just the selected curves. 

 

 
 

158 

 
 

OVA version of 

SYST:SAVT 

SYST:SWEE Opens the laser Source  switch and sweeps the 

laser through the through the user-specified 

wavelengths without performing a scan. 

 
157 

 
OVA 

SYST:VER? Returns the version of the OVA software. 145 Both 
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SYST:WARM? Queries if the laser is at operating temperature (1) 

or not (0). 

 
141 

 
Both 

SYST:WTIM? Displays the time remaining on the system one 

hour warm-up timer. 

 
141 

 
Both 
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Chapter 9 
 
 

 

Measurement Theory 
 

 
The OVA is the only fiber optic test instrument to use a rigorous linear systems 

approach to characterizing optical fiber components. This approach reduces the 

industry-standard multi-parameter characterization of fiber optic components to a 

single Jones matrix characterization. 
 

This chapter will cover the following topics: the Jones matrix and its use for system 

modeling and parameter calculations, how to use optical phase error data, the OVA 

device length finding methods, wavelength calibration, and filter theory. 

 

The Jones Matrix 
Fiber optic systems generally support two polarization modes. As a result, a simple 

fiber optic component having a single input fiber and a single output fiber must be 

modeled as a two port device: two polarization modes in and two polarization modes 

out. Generally, light may couple from any input mode to any output mode, giving 

rise to four complex transfer functions. These functions describe how the device 

affects the amplitude and phase of the light when it passes from the input to the 

output of the component. 
 

These four transfer functions can be placed into a matrix that serves as a useful tool 

for both analysis and modeling. This method of representing the effect of an optical 

component on the polarization state of light was first described by R. C. Jones in 

1941. Therefore, within the optical community, this linear transfer function for a two- 

input, two-output optical system is called the Jones matrix: 
 
 
 

J   = a   b  
. 

c   d  
 

The quantities a, b, c and d are the four scalar transfer functions, and  represents 

optical frequency. The term Jones matrix, however, is somewhat ambiguous. For a 
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Vertical linear polarizer 

 
0  0   

0  1   

 
 

Horizontal linear polarizer 

 
1  0   

0  0   

 
 

Linear polarizer at 45

 

1
--  1  1   
2  1  1   

 
 

Lossless fiber transmission 

 

e
i  

cos  –e
–i  

sin 

e
i  

sin   e
–i  

cos 

 
 

Right circular polarizer 

 

1
--  1  i 
2  –i 1 

 
 

Left circular polarizer 

 

1
--  1 –i 
2  i  1 

 

 
particular device, there exist several matrices that can be correctly termed the Jones 

matrix of the device, but convey various amounts of information. 
 

At a minimum, the Jones matrix describes the evolution of the polarization state as 

light passes through the device. In many cases the absolute amplitude and phase 

information is not needed, and the input vector is normalized. The matrices are then 

scaled such that the output vector is also normalized. This definition, which we will 

call the normalized Jones matrix, is often taught in introductory college optics 

courses. It leads to the familiar normalized Jones matrices for common devices 

shown in Table 9-1. 
 

Table 9-1: Normalized Jones Matrices of Common Optical Devices 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

9 
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Table 9-1: Normalized  Jones Matrices  of Common Optical Devices 

 
 
 

Quarter-wave plate, fast axis vertical 

 

e
i �  4   1  0 

0 –i 

 
 

Quarter-wave plate, fast axis horizontal 

 

e
i �  4   1  0   

0  i 

 

A more complete form of the Jones treatment of optical systems uses the full electric 

field vector to represent the input to the system. This is a two-element complex vector 

that contains both the amplitude and phase of each polarization component. Because 

phase is always measured relative to some reference point, the absolute phase of an 

optical wave is arbitrary. Therefore it is often ignored altogether, and the electric 

field is known only to within a constant phase. In this case, the absolute phase 

response of the device is often ignored as well. So the Jones matrix is then defined 

to include the amplitude response of the device and the relative phase between 

elements, but lacks the absolute phase response. 
 

This version of the Jones matrix is in fact the matrix measured by the original 

technique described by Jones himself.1 The more recent Jones matrix measurement 

technique of Heffner2 also lacks the absolute phase response. 
 

Without this phase information, the Jones matrix is an incomplete description of the 

operation of the device on the input signal. It contains insertion loss, polarization 

dependent loss, and polarization mode dispersion information, but will not yield 

group delay or chromatic dispersion. More importantly, it does not constitute the 

complete transfer function of the device. 
 

Jones and Heffner did not include the absolute phase response of the device in their 

versions of the Jones matrix because their measurement techniques were not 

equipped to measure it. The absolute phase of a device response is well-defined, 

however, and can be measured. The phase of the output can always be defined 
 
 

1  The original Jones papers on polarization are reprinted in Polarized Light, W. Swindell, ed. 

1975. 

2  B.L. Heffner, “Deterministic, analytically complete measurement of polarization-dependent 

transmission through optical devices,” IEEE Photonics Technology Letters 4:5, May 1992. 
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relative to the phase of the input. When absolute phase response is included, along 

with the amplitude response, the Jones matrix is equivalent to the transfer function 

of the device. This is the Jones matrix measured by the OVA. Any linear parameter 

describing the device can be calculated from this function. 
 

To summarize, there are three different matrix functions that all have been termed 

“the Jones matrix”: 
 

1 “Normalized” Jones matrix: The first understanding of the Jones matrix 

describes how the polarization state changes as light passes through a 

device, but says nothing of how the amplitude or phase of a signal is 

affected. Polarization dependent loss and polarization mode dispersion 

are the only two parameters that can be calculated from this normalized 

Jones matrix. 
 

2 “Common” Jones matrix: The most common understanding of the Jones 

matrix includes the amplitude response of the device in addition to the 

polarization information, but lacks the absolute phase response. In 

addition to PDL and PMD, insertion loss information is available. This 

is the matrix that is measured by most instruments that claim to measure 

the Jones matrix. However, it does not constitute the rigorous transfer 

function of the device. 
 

3 “Complete” Jones matrix: The most complete version of the Jones 

matrix includes all of the information contained in the first two, and 

contains the absolute phase response of the device as well. This Jones 

matrix is equivalent to the transfer function of linear systems theory, and 

contains all linear parameters, including insertion loss, group delay, 

PDL, and PMD. This is the matrix measured by the OVA. 
 

From this point onward and elsewhere in this manual, the term Jones matrix will 

be used to refer to the complete Jones matrix, the third definition above. 
 

System Modeling 

The Jones matrix of a device is an ideal tool for modeling how the component will 

operate in a system. Because it is a fully rigorous description of how light propagates 

through the device, the Jones matrix can be used to mathematically propagate a bit 

signal through the device, and an eye diagram can be calculated at the output. 
 

A bit stream input to a device can be represented by its electric field (E) as a function 

of time, Ein  t  . The spectrum of this signal is given by its Fourier transform, 
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Ẽ 
in    . The output signal spectrum, Ẽ 

ou t    , is easily calculated using the Jones 

matrix, J   : 

 

Ẽ 
ou t    = J  Ẽ 

in    . 
 

The output bit stream Eou t  t  is then found by taking the inverse Fourier transform 

of the output spectrum. 
 

Figure 9-1 shows the spectra for a 10 and 20 Gb/s signal transmitted with a center 

wavelength of 1534.5 nm. Overlaid on this plot is the amplitude response of an 

optical filter. Multiplication of the signal electric field by the measured Jones matrix 

of the component produces the output electric field. After transforming this output 

field back to the time domain, an eye diagram can be produced by calculating the 

detected optical power as a function of time. Figure 9-2 shows the computed eye 

diagrams for the 10 and 20 Gb/s signals. 
 

The Jones matrix approach also provides a simple, straightforward way to model 

systems composed of many components. A single system Jones matrix can be formed 

by multiplying together the component Jones matrices in the proper order. By placing 

arbitrary lossless transmission matrices between components in the numerical 

models, all possible states of the connecting fiber can be checked for acceptable 

operation. If other optical signals are present in the adjacent bands, the effects of 

cross-talk can also be modeled simply by adding these signals to the input. 
 

The Jones matrix, as measured by the OVA, provides a rigorous and complete model 

of device performance that is both direct and simple. It is much more straightforward 

than modeling system performance based on traditional parametric measurements, 

which provide only indirect clues as to how a device will perform. 
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Figure 9-1. Signal and grating spectra. 
 
 
 

9  
 

Figure 9-2. Eye diagrams for 10 and 20 Gb/s. 
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Parameter Calculations 

Despite the ability to directly model components and systems using the measured 

Jones matrix, it is still often useful to know the values of individual parameters for 

particular devices. Because the Jones matrix embodies the full mathematical 

description of a device, all linear parameters describing that device are contained 

in the Jones matrix. 
 

The OVA mathematically defines each parameter precisely by measuring the Jones 

matrix and then extracting parameters. This is in contrast to traditional means of 

performing measurements. For example, it may not be clear whether the result of a 

traditional insertion loss measurement yields the loss for a particular input 

polarization state, or for some type of average over polarization states. With the 

complete Jones matrix, it is possible to calculate the loss for any input state, so one 

may define the loss in the most useful fashion, and use that definition to perform 

the loss calculation. 
 

The OVA control software performs several built-in parameter calculations using the 

definitions presented below. These definitions were chosen to produce results that 

agree with nearly all implementations of traditional measurements for each 

parameter. If other definitions are necessary for particular applications, the Jones 

matrix data is available for users to perform their own parameter calculations. Keep 

in mind that the parameters are mathematical constructs, and that the true description 

of the device lies in the Jones matrix itself. 
 

The following parameter definitions are written in terms of the Jones matrix Ji 

expressed as 
 

 
 

Ji  = 
ai   bi   

, 
9 

ci  d i 

 
where i indicates the index location in the data array, and corresponds to optical 

frequency (wavelength). 

 
Insertion loss 

 

Insertion loss (IL) is the ratio of optical power output by the device to the optical 

power input to the device, and is expressed in dB. In terms of the Jones matrix 

elements, it is defined as 



218   Chapter 9 

Measurement  Theory 

 

9 

 

 
2 

+ 
2 

+
 
c 

2 
+ d 

2
 

= log  
ai

 bi---------------i---------------i--- .
 

ILi 10  
---------------------  

2 

 
This definition yields the average insertion loss over all input polarization states (for 

example, a polarizer would measure as -3 dB). The measured insertion loss for a 

thin film filter appears in Figure 9-3. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-3. Insertion loss measurement of a thin film filter. 

 

Group  delay 
 

Group delay (GD) is defined to be the rate of change of phase as a function of 

frequency. Physically, this property corresponds to the delay experienced by the 

sinusoidal envelope of a modulated optical signal as it propagates through the device. 

In terms of the Jones matrix elements, it is defined as 

 

arg  ai + 1 ai
� + b i + 1 bi

� + ci + 1 ci
� + di + 1 d i

� 
GDi   = --------------------------------------- ------------------------------------------------------------- , 

�
 

where arg  z  denotes the argument (phase) of the complex number z , and �  is 

the change in optical frequency from index i to index i + 1 . This definition yields 

a weighted average group delay over polarization states, where the weighting 

function is the amplitude response for each state. 
 

An example group delay measurement for one channel of a thin film filter appears 

in Figure 9-4. 
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i i 

 
-------


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Figure 9-4. Group delay measurement for a single channel of a thin film filter. 

 
Chromatic dispersion 

 

Chromatic dispersion (CD) is the derivative of the group delay with respect to 

wavelength. The group delay is calculated first from the Jones matrix using the 

definition above, and then chromatic dispersion is found using 

 
 

CDi   = 
GD – GD 
------------------------------- , 

�
 

where � is the change in wavelength from index i to index i+1. 

 

Polarization dependent  loss 
 

Polarization dependent loss (PDL) is the ratio of the maximum transmitted power 

to the minimum transmitted power over all polarization states, where each state 

contains the same launched power. To express the PDL in term of the Jones matrix 

Ji , first define i 1 and i 2 to be the eigenvalues of the matrix J † J , where  †
 

denotes the conjugate transpose. The PDL is then given by3
 

 
 

PDLi   =   10 log  
i 1  . 
i 2 

 
 

3  B.L. Heffner, “Deterministic, Analytically Complete Measurement of Polarization-Depen- 

dent Transmission Through Optical Devices,” IEEE Photonics Tech. Lett. 4, pp. 451-454, 

1992. 
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 
-------



 
Examples of PDL measurements appear in Figure 9-5. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-5. Polarization dependent loss of a ~0 dB fiber patch cord. 

 

Polarization mode dispersion 
 

Polarization mode dispersion (PMD), or differential group delay (DGD), is the 

maximum difference in group delay over all polarization states. Equivalently, PMD 

is a measure of the maximum rate of change of the polarization state. To express 

the PMD in terms of the Jones matrix Ji , first define  i 1 

–1
 

and  i 2 to be the 

eigenvalues of the matrix Ji + 1 J i . The PMD is then given by 

 
 

 
PMDi   = 

9 

arg  
 i 1
 i 2 

--------------------- , 
�

where � is the change in optical frequency from index i to index i + 1 .4 
 

Examples of PMD measurements appear in Figure 9-6. 
 
 
 
 
 
 
 
 
 

4  B. L. Heffner, “Automated Measurement of Polarization Mode Dispersion Using Jones 

Matrix Eigenanalysis,” IEEE Photonics Tech. Lett. 4, pp 1066-1069, 1992. 
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ˆ = � 
dq 

, 

  --------- 

9 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 9-6. PMD measurements for a 0.42 ps nominal PMD standard 

and a ~0 ps SMF patch cord. 

 
Second Order Polarization Mode Dispersion 

 

Second order PMD (SOPMD) is defined as the frequency derivative of the PMD 

vector,    = �   q̂    ,5 where  �   is the differential group delay 

(DGD = first-order PMD) between the two principal states of polarization (PSPs), 

and q̂  is a unit vector that points in the direction of the fast principle axis. Hence, 

the second-order PMD is given by 

 

SOPMD 
d  


d�  


dq̂   



=  ---------------- = ------------------ q̂    + �   --------------- . 
d d d

 

The two terms in the above equation are often treated separately by breaking the 

second-order PMD into parallel and perpendicular components: 

 
 

 ||   = 
d�  
--------- q and   

d

ˆ 
------- 
d

 
where  ||  causes polarization dependent chromatic dispersion, and    represents a 

frequency dependent rotation of the PSP’s of the DUT, both of which, in turn, cause 

signal depolarization. Also, we have used the short-hand     =  
d� . 

d

 
5  J. P. Gordon and H. Kogelnick, “PMD fundamentals: Polarization mode dispersion in optical 

fibers,” Proc. Nat. Acad. Sci. 97, pp. 4541–4550, 2000. 
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We can use the Jones matrix to calculate a components second-order PMD.6 If s1
–1

 

and s2 are the eigenvectors of the product Ji + 1 Ji
 , then they are also the PSP’s 

of the DUT.7 The unit vector q̂  is found by identifying the eigenstate associated 

with the fast principal axis and casting that state in a Stokes space. If 
 
 

ax e
 i  x 

s1= , 
i  y

 

ay e 

 
then the Stokes vector corresponding to that PSP is 

 
 

a
2  

–   
2 

S  = ax ay sin   , 

ax ay cos 

 
where  = x – y ,  is the relative optical phase of the vector, and ax and ay are 

the amplitudes of the x and y components, respectively.8 

This yields the value of the unit vector q̂ : 
 

q̂  = --
S
--- . 
S 

 
The control software plots the square root of the sum of the squares of the two second 

order PMD components, i.e.: 
 

 

SOPMD =  ||     +      , 
 

 
 
 

6  H. Kogelnick, L. E. Nelson, J. P. Gordon, and R. M. Jopson, “Jones matrix for second-order 

polarization mode dispersion,” Opt. Lett. 25, pp. 19–21 2000. 

7  B. L. Hener, “Automated measurement of polarization mode dispersion using Jones matrix 

eigenlysis,” IEEE Photon. Technol. Lett. 4, pp. 1066–1069, 1992. 

8  M. Born and E. Wolf, Principles of Optics (Cambridge University Press, Cambridge, Massa- 

chusetts, 1999), seventh edn. 
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where 

 
 

 || 

d�
=  --------- and   

d


------- 
d

 

and  is the PSP orientation angle. The term d is calculated as 

 

di   = cos
–1

  q̂ 
 
i – 1  q̂ 

i  . 
 

For a more complete explanation of how the OVA calculates SOPMD, please to refer 

to the paper “Second-Order PMD in Optical Components” by B. J. Soller, posted 

on the Luna Technologies website: 

http://www.lunatechnologies.com/applications/2nd%20Order%20PMD.pdf. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-7. Second Order PMD measurement of three segments 

of PM fiber spliced together. 
 

The user should note that when PMD nears zero, the frequency derivative of PMD 

may become discontinuous and the omega parallel term may exhibit abrupt change. 

Also, when PMD is near zero, the Stokes vector is prone to rotate rapidly, since the 

orientation of the fast axis is ill-defined. For these reasons, the SOPMD calculation 

may produce large values that are best to disregard when the PMD approaches zero. 

 
Linear phase deviation 

 

Linear phase deviation (LPD) is the deviation of the optical phase vs. frequency from 

a linear function. In terms of the Jones matrix elements, the optical phase  through 
the device is defined as 

http://www.lunatechnologies.com/applications/2nd%20Order%20PMD.pdf
http://www.lunatechnologies.com/applications/2nd%20Order%20PMD.pdf
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k   = 
k 

� arg  ai + 1 ai
� + bi + 1 b i

� + ci + 1 ci
� + d i + 1 di

�  .
 

i = 0 

 

A line fk   is then fit to k , and the linear phase deviation is given by 
 

LPDk = k – fk  . 

 
The line fk   is typically fit over the passband of the device under test. See 

“Recalculating Phase Deviation” on page 68 for information on how to select the 

passband for this curve fit. An example linear phase deviation plot for a chirped 

Bragg grating appears in Figure 9-8. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-8. The linear phase deviation for a chirped Bragg grating. 

9 Quadratic  phase deviation 

Quadratic phase deviation (QPD) uses the same definition of the optical phase  
as the linear phase deviation. However, instead of fitting a line, a parabola pk  is fit 

to the phase, and the QPD is given by 

 

QPDk = k – pk . 

 

See “Recalculating Phase Deviation” on page 68 for information on how to select 

the curve fit region for the parabola pk . 
 

Figure 9-9 displays the quadratic phase deviation for the same chirped Bragg grating 

that appears in Figure 9-8. 
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Figure 9-9. The quadratic phase deviation for a chirped Bragg grating. 

 
Jones matrix  element amplitudes 

 

Selecting Jones matrix element amplitudes produces four curves per data set, where 

each curve is the amplitude of one of the Jones matrix elements:  a ,  b ,  c , and 

d . 
 

Jones matrix  element phases 
 

Selecting Jones matrix element phases produces four curves per data set, where each 

curve is the phase of one of the Jones matrix elements: arg  a  , arg  b  , arg  c  , 
and arg  d  . 

 

Time domain  (amplitude) 
 

The time domain (amplitude) plot selection displays the amplitude of the impulse 

response of the device in the time domain. It is expressed in terms of the impulse 

response matrix, 
 

 

H  = 
ã j  b̃

 
j 

c̃ 
j  d̃

 
j 

 

where ã j  is the discrete Fourier transform of ai , and likewise for the other matrix 

elements. The index j indicates the location in the data array, and corresponds to time. 
 

The plotted impulse response amplitude  hj    is defined as 
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hj     = ã j     + b̃ 
j     + c̃ 

j     + d̃ 
j     . 

 
This definition yields an average impulse response over all input polarization states. 

The result is scaled such that 

 
 

 
 
 

for a lossless device. 

� hj     = 1 
j 

 

An example time domain (amplitude) plot appears in Figure 9-10. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-10. The time domain (amplitude) data for a chirped Bragg grating. 

 

Time domain  (wavelength) 
 

The time domain (wavelength) plot is the derivative of the phase of the impulse 

response with respect to time. Note that the time derivative of phase is the definition 

of optical frequency, so this derivative can be scaled as a wavelength. For a device 

with a distributed impulse response, the time domain (wavelength) shows the 

wavelength distribution as a function of time for an infinitely short pulse as it is 

dispersed by the device. 
 

In terms of the impulse response matrix Hj   defined above, the time domain 
(wavelength) response TDWj is defined as 

 

2�c�t
 

TDWj  = ------------------------------------------- 

�
- , 

˜ ˜ �

-------------------------------------------------------- arg  ã j + 1 ã j� + b̃ 
j + 1 b̃

 
j + c̃ j + 1 c̃ j� + dj + 1 dj   
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where c is the speed of light in a vacuum and �t is the difference in time between 

index j and index j + 1 . 
 

An example time domain (wavelength) plot appears in Figure 9-11. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9-11. The time domain (wavelength) data for a chirped Bragg grating. 

 

Minimum  and maximum  transmitting states (Min/Max Loss) 
 

The Min/Max Loss graph displays the polarization dependent minimum and 

maximum transmission as a function of wavelength. The difference between the 

minimum and maximum transmission states constitutes the PDL of the DUT. The 

minimum and maximum states are derived from the eigenvalues of the matrix J † J 

where  †   denotes the conjugate transpose. At a given wavelength, the greater 

eigenvalue represents the maximum transmission and the smaller eigenvalue 

represents the minimum transmission. An example of the Min/Max Loss curves for 

a fiber Bragg grating are shown in the figure below. 
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Figure 9-12. The Min/Max Loss plot, showing maximum (blue) and 

minimum (purple) transmission states. 

 
Phase Ripple 

 

Phase Ripple Linear and Phase Ripple Quadratic represent parameter calculations 

from the Jones Matrix data of the linear and quadratic phase ripple over a user- 

specified channel width. 
 

Selecting  the Channel Width 
 

The channel width is set by entering a value in the Channel Width field that appears 

below the graph when either of the phase ripple parameters are selected. The units 

of the channel width are determined by the units of the graph display. The units can 

be changed by selecting a different x-axis unit in the pull-down menu below each 

9 
graph.

 

Linear Phase Ripple Calculation 
 

Linear phase ripple is calculated from the average phase of the JM based on a user- 

specified Channel  Width.  Phase is calculated as the integral of group delay (see 

“Group delay” on page 218). This results in a weighted average of the DUT phase 

response over polarization states, again as described for the group delay calculation. 

For each wavelength (frequency) value in the data, the following process is used to 

calculate the phase ripple: 
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1 The phase is fit to a linear curve over the channel width, centered at 

the wavelength associated with the data point. 
 

2 The linear fit is subtracted from the phase data. 
 

3 The maximum value of the resulting phase deviation is calculated. 
 

4 This maximum is recorded as the phase ripple for this wavelength. 
 

This calculation results in a curve for linear phase ripple as a function of wavelength 

that contains the same number of data points as contained in the other parameter 

curves. The linear phase ripple data, then, represents the maximum deviation from 

linear phase over the specified channel width at each data point. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9 
 

 
 

Figure 9-13. Insertion loss (upper graph) and phase ripple linear of an interleaver. 

 

Quadratic  Phase Ripple Calculation 
 

The quadratic phase ripple is calculated in the same way as the linear phase ripple, 

except the linear fit is replaced with a quadratic fit. This results in a phase ripple 

that represents the maximum deviation from quadratic phase over the specified 

channel width at each data point. 
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Figure 9-14. Insertion loss (upper graph) and phase ripple quadratic of the same 

interleaver data shown in Figure 9-13. 

 

Saving  Phase Ripple Data 
 

The phase ripple data curves can be saved by checking next to those parameters in 

the File > Select Save Options configuration window. 
 
 

Note  
The Channel  Width specified below the upper graph is 

used to calculate these data curves for saving to the text 

               file. The channel width is reported in the header of the 
resulting text file. 

 
 

Using Optical Phase Error 
The OVA is the first instrument capable of providing optical phase measurements 

for fiber-optic components. Without optical phase information, group delay and 

chromatic dispersion measurements must be carefully interpreted to predict the 

effects of an optical filter on a transmission system. Optical phase measurements 

make the characterization of the dispersive effects of components significantly less 

complicated than it has been in the past. 
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A system with a strictly linear phase response will delay a signal without distorting 

it. Any deviation from the linear phase within the signal bandwidth will begin to 

cause distortion. If this deviation from linearity exceeds 90 degrees, the signal will 

become unrecognizable. 
 

The acceptable phase distortion does not change with bit rate (i.e., the noise penalty 

for a 0.1 radian phase error is the same for a 2.5 Gb/s and a 40 Gb/s system). The 

only parameter that changes between systems is the bandwidth over which the phase 

error must be maintained. It is therefore possible to specify a single tolerance on 

the phase (e.g., 0.1 radians) and then pass or fail components based upon this single 

limit. A further advantage of optical phase measurements is that the component may 

be evaluated for performance at any bit rate based on this single measurement. In 

other words, the process, equipment, and tolerances for qualifying a part for 40 Gb/ 

s operation will be identical to the process for qualification a 10 Gb/s. As component 

quality is increased, component characterization can remain the same, which 

tremendously simplifies documentation and process control. 
 

A dispersion compensating device is expected to have a group delay that varies 

linearly with optical frequency, and an optical phase that is parabolic. Therefore, a 

parabolic curve fit would be used on such a device instead of the linear fit for 

nominally nondispersive components. 
 

Optical Phase Error: References 

For more information on optical phase error, please see the following references: 
 

M. Froggatt, E. Moore, and M. Wolfe, “Interferometric measurement of dispersion 

in optical components,” WK1, Optical Fiber Communication Conference, March 

2002. 
 

H. Yoshimi, Y. Takushima, and K. Kikuchi, “A simple method for estimating the 

eye-opening penalty caused by group-delay ripple of optical filters,” 10.4.4, 28th 

European Conference on Optical Communication, Sept. 2002. 

 
Fiber Optic Interferometry 

The OVA uses swept-wavelength coherent interferometry to measure the Jones 

matrix. Here this technique is presented at an introductory level. For more 

information see the references at the end of this section. 
 

The two basic types of fiber interferometers are shown in Figure 9-15. A Mach- 

Zehnder design uses one 3 dB coupler to split the light, and another 3 dB coupler 
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to recombine the light. In general, the two paths between the couplers are of different 

lengths. A detector is placed at the output of the second coupler. A Michelson 

interferometer uses a single 3 dB coupler to both split and recombine the light. 

Mirrors are placed at each of the outputs on one side of the coupler, and in general 

the two paths are of different lengths. On the other side of the coupler, one lead is 

used to inject the light, and the other is directed to a detector. 

 

 
 

Figure 9-15. Two basic types of fiber interferometers: 

(a) Mach-Zehnder and (b) Michelson. 

 
Both of these interferometer designs can be treated in a basic way using the same 

set of mathematics. Consider an input field of the form 

 

Ein   = E0  t e
–i   t  t , 

 
where  is angular optical frequency, and  t  describes the instantaneous 

frequency of the tunable laser source. 

 
The spatial dependence of the signal may be ignored because the light is detected 

only at a single point. At the first coupler, the input field is split into two fields, E1 

and E2 . After propagating through different lengths of fiber, the two fields are 

recombined, and the resulting field at the detector is 

 
Eou t = E0  t + 1 e 

–i   t + 1  t + E0  t + 2 e 
–i   t + 2  t ,

 

 

where  1   and  2   are the delays through the two paths of the interferometer. 

The electrical output of the detector is proportional to the optical intensity, I, which 

is given by the square magnitude of the electric field: 

 
I   = E0  t  

2 + E0  t –   2 + 2E0  t E0  t –   cos   t   , 
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where the time delay difference between the interferometer paths   = 1 – 2 . 

 

Optical Network for OVA 

This basic idea can then be applied to device characterization by including a device 

under test (DUT) in one arm of the interferometer,9 as shown in Figure 9-16. 
 

 
 

Figure 9-16.  A Mach-Zehnder interferometer with a device under test in one arm. 
 

We can describe the DUT by its frequency domain linear transfer function, H   ; 
the linear transfer function contains information about the amplitude,    , and 

phase,    , response of the DUT and is given by H   =   e i     . Given 

the amplitude and phase response, the detected power is proportional to the intensity, 

I, given by 

 
I  =  E0  t  

2 + E0  t –   2   2
 

+ 2  E0  t E0  t –   cos    t  –     . 

 
Next a Fourier transform is performed allowing the three terms in the above 

expression to be separated spectrally. Note that the first two terms will have only 

low frequency characteristics, and thus will appear at or near t = 0 in the time- 

domain. The device information resides in the third term of this expression, called 

the interference term. The interference term oscillates at the frequency  t  , while 
the other terms do not oscillate. Its location in the time-domain will be determined 

by the delay difference    between the two arms of the interferometer. Provided 

that   is large enough, the device response will be separable from the low frequency 
terms, and thus measurable. The Luna OVA is designed such that the internal delay 
path through the device under test is long enough such that the low frequency terms 
will not influence the measurement, even for very short devices. Thus the OVA 
operates with no dead zone. 

 

 
9  For a more complete description of the OVA network, see D. K. Gifford et al., “Optical vec- 

tor network analyzer for single-scan measurements of loss, group delay, and polarization 

mode dispersion,” Applied Optics, vol. 44, no. 34, 1 Dec. 2005. 
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The Fourier transform of reflected optical intensity (I) for a short length of single- 
mode fiber as the DUT is plotted in Figure 9-17 (a). Figure 9-17 (b) shows the 
selected segment that contains the device information. Because the initial data was 

acquired as a function of optical frequency,  , the transformed data is a function of 
time. For this reason, the transformed data is referred to as time domain data. 

 

 

Figure 9-17. (a) The Fourier transform of interference fringes. 

9 (b) The segment of the time domain data that contains device information.

 

If there are multiple reflecting interfaces within the device under test, each interface 
will contribute a term to the interference pattern and a peak in the time-domain 

located at the corresponding delay. 
 

In order to more easily locate the source of reflections within a device, the time- 

domain data can be scaled in units of length, using the speed of light and the group 

index of the DUT. 
 

To arrive at a measure of the frequency response of the device, an inverse Fourier 

transform is performed on only the section of the time-domain data that contains 

the device response. The OVA software allows the user to select any portion of the 
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time-domain data so the response due to different optical paths or interfaces can be 

separated and measured independently. 
 

Once the data has been transformed back into the frequency-domain, the calibrated 

amplitude response yields the loss of the test device. The derivative of the phase 

response yields the group delay. 
 

Triggering and Resolution 

In a practical measurement system, the function  I    must be sampled at a set of 

discrete points, and the Fast Fourier Transform (FFT) algorithm is used to convert 

to the time domain. In order to perform the FFT, it is necessary that  I    be 

sampled at equal increments of optical frequency. It is not sufficient to use time 
synchronous sampling and rely on a constant tuning rate of the laser. Instead, a 

second interferometer is used for triggering. The trigger interferometer must have 

a delay difference between its two paths that is at least twice as long as the delay 

difference in the device interferometer to avoid undersampling. Thus it is the length 

of the trigger interferometer that determines the device length limit for the OVA. 
 

The length of the segment in Figure 9-17 (b) can be controlled by the user by simply 

scaling the X-axis (see “Scaling Plot Axes” on page 63). This length determines the 

sample resolution of the frequency domain data according to the Fourier transform 

relationship 

 

� 
2� 2�


=  ---------  = 

N�t 
------ . 
T 

 

Here � is the sample spacing in the frequency domain, �t is the sample spacing 

in the time domain, N is the number of points, and T is the range in the time domain, 
or equivalently, the time segment length. 

 
Fiber Interferometry: References 

M. Froggatt, T. Erdogan, J. Moore, S. Shenk, “Optical frequency domain 

characterization (OFDC) of dispersion in optical fiber Bragg gratings,” FF2, Special 

Meeting on Bragg Gratings, Photosensitivity, and Poling in Glass Waveguides, Sept. 

1999. 
 

B. Soller, D. Gifford, M. Wolfe and M. Froggatt, “High resolution optical frequency 

domain reflectometry for characterization of components and assemblies,” Optics 

Express, 13:666-674, Jan. 2005. 
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B. J. Soller, M. Wolfe, M. E. Froggatt, “Polarization resolved measurement of 

Rayleigh backscatter in fiber-optic components,” paper NWD3, OFC Technical 

Digest, Los Angeles, March 2005. 
 

M.M. Ohn, S.Y. Huang, S. Sandgren, R. Measures, T. Alavie, “Measurement of fiber 

grating properties using an interferometric and Fourier-transform-based technique,” 

WJ2, Optical Fiber Communication Conference, March 1997. 
 

M. Froggatt, J. Moore, and T. Erdogan, “Full complex transmission and reflection 

characterization of a Bragg grating in a single laser sweep,” WB1, Optical Fiber 

Communication Conference, March 2000. 
 

M. Froggatt, E. Moore, and M. Wolfe, “Interferometric measurement of dispersion 

in optical components,” WK1, Optical Fiber Communication Conference, March 

2002. 
 

U. Glombitza and E. Brinkmeyer, “Coherent frequency-domain reflectometry for 

characterization of single-mode integrated-optical waveguides,” J. Lightwave Tech. 

11, 1377-1384, 1993. 

 

The OVA Device Length Finding Methods 
 

In order to properly perform a full Jones matrix characterization, the data processing 

algorithm in the OVA control software must be provided with the length of the device 

under test (DUT). The OVA can measure the length of the DUT, or it may be entered 

manually. This section will explain why the device length is necessary, and provide 

detail on how the OVA performs a measurement of the device length. 
 

Why is the device length necessary? 

When the OVA performs a measurement scan, the raw data is acquired in the form 

of interference fringes on two detector channels. The Fourier transform of these 

fringes produces a time domain representation of the measurement interferometer 

where each optical path produces a peak. The location of each peak corresponds to 

the delay through its corresponding optical path. For a typical Jones matrix 

measurement, each of the four Jones matrix elements appears as a peak, or impulse 

response, in the time domain. Two matrix elements are measured on each of the two 

detector channels. The peaks on each channel are separated by a fixed delay, which 

is determined by the hardware design of the OVA measurement network. 
 

In order to process the Jones matrix correctly, the two impulse responses on each 

channel must be separated. Therefore it is necessary to select only a portion of the 



Optical  Vector Analyzer    237 

User Guide 

 

 
time domain data around each of the four impulse responses. This results in four 

data sets, which become the measured Jones matrix elements after an inverse Fourier 

transform and application of calibration data. The length of the selected section 

around each impulse response depends on the sample resolution setting, or time 

segment length. (For more information, see “High Dynamic Range Averaging” on 

page 48.) Note that this segment length cannot be greater than the fixed separation 

delay between the impulse responses. 
 

The length of the DUT must be provided to the software algorithm that performs 

this segmenting process in order for it to position the selection windows properly 

in the time domain. If the length of the DUT is entered incorrectly, the selection 

windows will not contain the four impulse response functions; instead they will 

contain only noise. See Figures 9-18 and 9-19 for graphic illustrations of the 

windowing process for both correct and incorrect values of the device length. Figure 

9-18 represents a correct and accurate measurement of the DUT. Figure 9-19 depicts 

incorrect positioning of the selection regions due to an incorrect DUT length setting. 

This will yield a measurement where all parameters are returned as nothing but noise. 
 
 
 
 
 
 
 
 
 
 

 

9 
 

 
Figure 9-18. Illustration of the impulse response selection process on one detector 

channel. The two peaks correspond to two elements of the Jones matrix. The 

bold regions represent the selected sections of the time domain, and their loca- 

tions are determined by the DUT length setting. 
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Figure 9-19. Illustration of the impulse response selection regions for an incorrect 

value of the DUT length. 
 

In addition to the situations illustrated in Figures 9-18 and 9-19, there exists a special 

case where an incorrect DUT length setting will yield measurement data that contains 

device information, and therefore does not appear as noise, but is nevertheless 

incorrect. If the device length setting is off from the correct value by an amount 

equivalent to the fixed separation delay between impulse responses, then only one 

of the two impulse responses on each detector channels will be included by the 

windowing process. This situation is illustrated in Figure 9-20. In this case two of 

the four Jones matrix elements are measured to be essentially zero, so this situation 

can be diagnosed by noting that the measured PDL will be greater than 40 dB across 

the entire measurement spectrum. Note however that an impulse response will appear 

in the Time Domain Window (accessed by the Time Domain button), since this 

9 plot displays the sum of the four measured device impulse response functions.
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Figure 9-20. Illustration of the special case where the entered device length differs 

from the actual value by an amount equivalent to the fixed separation delay. 

 
Entering the DUT length manually 

For the majority of fiber optic devices, entering the physical length of the device 

(including leads) with an accuracy of 0.1 m will lead to accurate Jones matrix 

characterization by the OVA. For devices with long impulse responses that approach 

the length of the Time Domain Window (such as some dispersion compensators), 

the length will need to be known more accurately. This is because a longer impulse 

response will begin to extend outside of the Time Domain Window for a smaller 

displacement from the center of the window than a short impulse response. 
 

Entering the correct length for a given device will place the impulse response in the 

center of the Time Domain Window. It is a good idea to open the Time Domain 

Window (by clicking the Time Domain button) after a measurement to ensure that 

the full impulse response in contained in the window. If the impulse response extends 

outside of the window in one or both directions, it may be necessary to change some 

measurement parameters and perform the measurement again. See “To adjust data 

that extends out of the Time Domain Window” on page 72 for information on how 

to address this situation. 
 

It is important to note that while the position of the selection windows is determined 

using a control scaled in units of length, it is actually the delay through the DUT 

that determines the location of the impulse response peaks in the time domain. The 

OVA control software converts between length and delay assuming an index of 

refraction of 1.5. This is an appropriate assumption for most fiber optic devices. For 

the case of a device with a refractive index that differs significantly from 1.5, entering 
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the precise physical length of the device may cause the time domain selection 

windows to be positioned incorrectly, and the measurement will fail. In this case it 

would be advisable to allow the OVA software to measure the length. The length 

returned by the software will deviate from the actual physical length, but it will be 

the appropriate value to correctly position the time domain selection windows for 

an accurate Jones matrix characterization of the DUT. 
 

Choosing the DUT length finding method 

To measure the length of the DUT, the OVA configures the internal optical network 

such that a single scalar device impulse response is measured in the time domain, 

rather than the four impulse response functions that correspond to the four Jones 

matrix elements. The position of the impulse response in the time domain is 

determined by the length of the DUT, so it is possible to invoke a numerical algorithm 

to locate the impulse response, and thus measure the DUT length. 
 

Unfortunately, a single algorithm will not successfully locate the impulse response 

for all types of devices. Two different methods are necessary to cover the majority 

of fiber optic components. The appropriate method for a particular component is 

determined primarily by the optical bandwidth passed by the component. For this 

reason, the two methods are termed Broadband and Narrowband within the OVA 

control software. A broadband device is one that passes light at a large range of 

wavelengths, and blocks only small set of wavelengths, if it blocks any at all. (See 

Figure 4-9 “Typical broadband and narrowband loss curves” on page 46.) The 

converse is a narrowband device, which passes only a small wavelength range, while 

blocking all other wavelengths. In the context of OVA measurements, the relative 

terms broad and narrow refer to how much of the current measurement spectrum 

is passed by the device. 
 

Note that many devices can be either broadband or narrowband depending on how 

they are used in a system. For example, a fiber Bragg grating is a narrowband device 

when used in reflection, but it is a broadband device when used in transmission. 

For other examples of broadband and narrowband devices, see Table 4-1 on page 45. 

 
The Broadband method 

 

Because a broadband device passes the majority of the wavelengths incident upon 

it, the amplitude of its impulse response is large. Its location can be determined by 

simply finding the location of the maximum amplitude value in the time domain 

data array. 
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The Narrowband method 

 

A narrowband device, on the other hand, passes only a small subset of the incident 

wavelengths, leading to an impulse response with a relatively small amplitude. It is 

entirely possible that small broadband reflections in the system, such as those that 

occur at fiber optic connectors, could produce an impulse response peak with a larger 

amplitude than the DUT. Therefore simply searching for the maximum amplitude 

could yield erroneous results for the DUT length. 
 

Instead of using the amplitude of the time domain data, the OVA software finds the 

length of narrowband devices using the phase of the impulse response. The phase 

is defined only where the impulse response has nonzero amplitude, so the phase of 

the time domain data will be purely noise except where an amplitude peak is located. 

If the impulse response is narrow, it can be difficult to locate a small region of well- 

defined phase. However, the narrow spectral response of a narrowband device 

necessarily implies that its impulse response has an appreciable width. Therefore, 

the impulse response can be located by searching for an area of well-defined phase. 
 

The OVA software locates a region of well-defined phase by first calculating a 

numerical derivative of the time domain phase data. It then uses a small sliding 

window over which it calculates the standard deviation of the phase derivative. In 

regions of noise, the standard deviation will be large, but in regions of well-defined 

phase it will be much lower. The location of the impulse response is then taken to 

be the point where the standard deviation is minimum. This yields the device length 

for a narrowband device. 
 

It is important to note that the OVA uses the current center wavelength and 

wavelength range settings when executing a device length measurement. Therefore 

it is critical that these values are set such that they include the pass band of a 

narrowband device. If the wavelength range does not include the pass band, the 

device will not pass any light and the length measurement will fail. 

 

Wavelength Calibration 
The OVA measurement network includes a hydrogen cyanide (HCN) gas cell to 

calibrate wavelength during each measurement scan. The HCN gas cell is NIST 

Standard Reference Material #2519, and is used for wavelength calibration over the 

C-band. This section will describe how the HCN cell is used for wavelength 

calibration within the OVA. 
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R Branch Wavelength  (nm) P Branch Wavelength  (nm) 

25 1528.0541 1 1543.1148 

24 1528.4862 2 1543.8094 

23 1528.9271 3 1544.5147 

22 1529.3762 4 1545.2314 

21 1529.8376 5 1545.9563 

20 1530.3061 6 1546.6902 

19 1530.7856 7 1547.4354 

18 1531.2764 8 1548.1904 

17 1531.7738 9 1548.9554 

16 1532.2825 10 1549.7302 

15 1532.8024 11 1550.5149 

14 1533.3291 12 1551.3106 

13 1533.8671 13 1552.1157 

 

 
Hydrogen cyanide has a very well known absorption spectrum that appears in Figure 

9-21. Each absorption line occurs at a precise wavelength that is known to within 

1.5 pm. Table 9-2 lists the wavelength for each absorption line. 
 

 
 

 
Figure 9-21. The HCN absorption spectrum. 

 

Table 9-2: HCN absorption line wavelengths at 100 Torr 
 

9 
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Table 9-2: HCN absorption line wavelengths at 100 Torr 

 

R Branch Wavelength  (nm) P Branch Wavelength  (nm) 

12 1534.4159 14 1552.9308 

11 1534.9723 15 1553.7560 

10 1535.5401 16 1554.5892 

9 1536.1170 17 1555.4346 

8 1536.7034 18 1556.2919 

7 1537.2997 19 1557.1573 

6 1537.9069 20 1558.0329 

5 1538.5224 21 1558.9185 

4 1539.1494 22 1559.8143 

3 1539.7855 23 1560.7185 

2 1540.4314 24 1561.6344 

1 1541.0872 25 1562.5625 

 

The Automatic Laser Calibration Utility (see “Packing and Shipping the OVA” on 

page 260) uses all of the HCN absorption lines to calibrate the tuning function of 

the laser. This tuning function provides wavelength accuracy of approximately 50 

pm. During each measurement scan, the OVA acquires transmission data through 

the HCN cell and uses that data to refine the wavelength accuracy. 
 

The wavelength calibration routine that occurs during each measurement scan is 

illustrated in Figure 9-22. The illustration is for a 2.5 nm scan centered at 1551.25 

nm. Because data is sampled at intervals of equal optical frequency (see “Fiber Optic 

Interferometry” on page 231), it is sufficient to calibrate the absolute wavelength at 

a single point in the data array. Relative wavelength accuracy within the data array 

is ensured by interferometric triggering. The laser tuning function need only be 

accurate enough to determine which HCN absorption line will be used for 9 
calibration. The absorption lines are separated by roughly 0.5 nm, so 50 pm 

accuracy is sufficient. Data is acquired over a range somewhat larger than the 

requested scan range, and the HCN line nearest to the center of the scan is then used 

to determine the absolute wavelength at one point in the data array. Counting data 

points in either direction determines the points in the extended data array that 

correspond to the requested beginning and end wavelengths. The remaining data 

points outside this range are dropped. 
 

Because the HCN gas cell absorption lines lie only within the C-band, special 

consideration must be made to calibrate the wavelength of scans that occur within 

the L-band. In the case of an L-band scan, the laser sweep is begun in the C-band 

such that at least one absorption line is included in the scan range. This line is used 
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to calibrate the wavelength, and then the data set is truncated to include only the 

requested L-band scan range. 

 

 
 

Figure 9-22. An illustration of the wavelength calibration routine 

for a measurement scan from 1550 nm to 1552.5 nm. 

 

Filter Theory 
 

The time domain filter function 

The illustration of the Time Domain Window shown in Figure 5-11 on page 72 is 

reproduced in Figure 9-23 below. The time domain filter function appears as the 

purple curve. It is a flat-top Gaussian function, and it is multiplied by the discrete 

Fourier transform of each Jones matrix element before the matrix is transformed back 

into the frequency domain for parameter calculations. The flat center region has a 

value of unity between the two points defined by the two yellow vertical cursors. 

The user may drag these cursors to change the portion of the time domain data passed 

by the filter. By default the cursors are located at 10% and 90% of the time domain 

range. 
 

Outside of the area between the cursors the filter function has a value given by 

 
2 

e
–  t – t1 2       

, 
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where t1 2 are the positions of the two cursors, and  is defined in the data field 

labeled Sigma (ns) in the Window Parameters area of the Time Domain Window. 

The shape of the Gaussian edges can be controlled by changing the value of  . For 
display purposes, the filter function is scaled according to the maximum value of 
the impulse response. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figure 9-23. The Time Domain Window, showing the impulse response (in white) 

of a fiber Bragg grating in reflection (sample file “Bragg Reflection.dat”). The 

time domain filter function is shown in purple, and the cursors are yellow. 

 

Calculating the time domain resolution bandwidth 

Because the Jones matrix and the impulse response are related to one another by a 
discrete Fourier transform, the width of the filter function in the time domain 
determines the resolution of the data in the frequency (wavelength) domain. If the 

full width at half maximum of the filter function is denoted �tf   and given in units 

of nanoseconds, then the resolution bandwidth (RBW) is given by 
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RBW [GHz] = --
1
---- 
�tf 

 

or 

 
 

RBW [pm] = 


2 

--------- , 
c�t f 

 

where  is the center scan wavelength and c is the speed of light in a vacuum. 
 

Time Domain Hanning Window 

The operating software for the OVA allows the user to choose whether or not to 

apply a Hanning window, or raised cosine window, to the data. It is applied by 

selecting Options > Apply Time Domain Hanning  Window. The purpose of the 

Hanning window is to “sharpen” narrow peaks in the time domain. This window 

should therefore be used when measuring components that have broadband features 

(and hence narrow features in the time domain). 
 

If ai represents one entry of the Jones matrix, where the subscript “i” denotes 

frequency, the Hanning-windowed data is of the form 
 

a    0.5a [1 � cos( 
2� i 

)] ,
 

hi i 
n 

 

for i = 0,1,2,…,n-1, where n is the number of elements in ai. 

The window is applied separately to each Jones matrix element and is only applied 

when viewing time-domain data. An example below shows both windowed and 

unwindowed data of the impulse response of a short length of fiber. Note the 

"sharpening" effect of the Hanning window. 
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Figure 9-24. Hanning windowed (red dashes) and unwindowed (blue) impulse 

response amplitude of a short length of single-mode fiber. 

 

Smoothing filter operation 

For all data quantities upon which it operates except polarization mode dispersion 

(i.e. IL, GD, CD, PDL, and phase ripple), the smoothing filter operates by taking a 

discrete Fourier transform of the data, multiplying by an acausal Gaussian filter 

function, and then inverting the Fourier transform. The filter operation on 

polarization mode dispersion data will be discussed in the following subsection. 
 

The width of the Gaussian curve applied to the data is determined by the setting of 

Filter  Resolution BW (pm or GHz) in the Data Processing  area of the main 

window. As mentioned earlier, one can change all resolution bandwidth units from 

the default setting of picometers to gigahertz by selecting Options > Resolution BW 

Units > Gigahertz (GHz). 

The 1  e width � ts  of the Gaussian filter function is given by the reciprocal of the 

resolution bandwidth setting in GHz. The following plot illustrates a 10 pm 
resolution bandwidth filter applied to the insertion loss data for a fiber Bragg grating: 
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Figure 9-25. A 10 pm resolution BW smoothing filter (shown in red) applied to the 

insertion loss data (shown in white) for a fiber Bragg grating. 

 
The transform of the insertion loss data appears in white, and the filter function 

appears in red. Note that this type of plot does not appear anywhere in the OVA 

control software. It is included here only to illustrate how the smoothing filter 

operates. 
 

Smoothing filter operation on PMD and SOPMD data 

When applied to polarization mode dispersion data, the smoothing filter performs 

another step in addition to applying the Gaussian filter described above. Calculation 

of PMD involves a numerical derivative, for which a frequency step size must be 

specified. (See “Polarization mode dispersion” on page 220.) With no smoothing 

filter applied, this step size is set to the current sample spacing as determined by 

the setting of the time segment length. (See “High Dynamic Range Averaging” on 

page 48.) Application of the smoothing filter causes the PMD calculation to use the 

setting of Filter Resolution BW (pm or Ghz) as the step size. Therefore, when the 

smoothing filter is applied, the control software re-executes the PMD calculation 

using the new step size. 
 

Following the updated PMD calculation, the acausal Gaussian filter is applied to 

the PMD data in the transform domain in the same manner as it is applied to the 

other parametric data sets. 

 

High Dynamic Range Averaging 
The OVA may be purchased with an option for enhanced dynamic range averaging, 

which extends the loss measurement range. (See the specifications given on our 

website at www.lunatechnologies.com.) This mode of operation is designed to allow 

the user to measure weak signals in the presence of strong signals. A bandpass filter 
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is an example of a DUT that displays such behavior. In the “pass” or “in-band” 

spectral region, most of the input light is transmitted. This represents the strong 

signal. In the “stop” or “out-of-band” regions, very little or no light will be passed, 

depending on the design of the filter. One might then be interested in the rejection 

ratio, or the ratio of the amount of light passed to the amount of light “stopped.” 

High dynamic range mode allows the OVA user to measure this rejection ratio to 

greater than the normal specification levels. Figure 9-26 displays the difference in 

measurement results for an optical filter using the standard (blue curve) and high 

dynamic range (red curve) averaging modes of operation, 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 9-26. Insertion Loss of an optical fiber measured with standard (blue curve) 

and high dynamic range (red curve) averaging modes. 
 

One might ask, why not always use the extended dynamic range operational mode? 

A very sophisticated, proprietary phase averaging technique is employed to achieve 

the enhanced dynamic range. The technique is, as stated above, specifically tailored 

to measurement applications that require high dynamic range. The algorithm can 

generate small insertion loss errors for DUTs that do not require high dynamic range 

(>60dB) capability. This is illustrated in Figure 9-27, where a 0.1 dB “bowing” error 

is evident when Options > Enable  High Dynamic Range Averaging  is used to 

measure a nominally lossless fiber patch cord. Thus high dynamic range averaging 

should only be used when measuring filters with greater than 60 dB rejection ratio. 
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Figure 9-27. “Bowing” errors are evident when using high dynamic range averaging 

(red curve) on nominally lossless fiber patch cord, where the 

normal dynamic range would suffice (blue curve). 

 

Pulse Compression 

The OVA may be purchased with the option to perform pulse compression on the 

data, according to the values set before a scan under Options  > Specify 

Compression  Settings. Compressing the impulse response allows coherent 

interferometric Jones matrix measurements of highly dispersive devices.10
 

 

The available range in the time domain is determined by the acquisition step size 

in the frequency domain. This range is generally much longer than the duration of 

the scalar impulse response of the device under test, so the unused portion of the 

range can be utilized to simultaneously measure the four Jones matrix elements.11
 

When measuring multiple elements, however, a stricter limit exists on their duration 

because they must not overlap in the time domain. This limit is usually not a problem 

except for dispersion compensating devices, which tend to have very long impulse 

responses. Compressing the impulse response of dispersive devices expands the 

applicability of coherent interferometric measurement. 
 

In order to measure multiple elements, the measurement system must be constructed 

such that a temporal separation exists between each response. This is accomplished 
 

 
10E. Moore et al., “Impulse response compression for vector characterization of highly disper- 

sive devices,” OFC, 2004. 

11D. K. Gifford et al., “Optical vector network analyzer for single-scan measurements of loss, 

group delay, and polarization mode dispersion,” Applied Optics, vol. 44, no. 34, 1 Dec. 2005. 
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by careful selection of the optical path length, which determines the separation 

between each impulse. The separation time is chosen such that the impulse responses 

for most devices can be measured without overlapping. Most fiber optic components 

have impulse response durations on the order of 1 ns or less, so a separation time 

of several ns will suffice. In the OVA, this separation is set at 7 ns. 
 

While this fixed separation time of 7 ns will work for nearly all fiber optic 

components, the one notable exception is dispersion compensators. In the case of 

seamless whole-band dispersion compensation devices, the change in group delay 

across the band can approach 100 ns, which translates to an impulse response of 

approximately the same length. This overlap can be eliminated by utilizing prior 

knowledge about the approximate average dispersion and dispersion slope of the 

device. This value is typically known by design. (For instructions on using OFDR 

software to calculate these values for your DUT, see “Calculating Average 

Dispersion and Dispersion Slope” on page 54.) 

The phase response of the device,    may be expressed as 

 

   = 0 + g   – 0  + O . 

 

Here 0   is a chosen point in the device spectrum, 0   is a constant phase offset, 

and g   is the group delay at 0 . Note that the first two terms will not affect the 

duration of the impulse response. The constant phase offset is arbitrary, and a 

constant group delay only shifts the position of the impulse response without 

otherwise affecting it. Broadening of the impulse response, and distortion of a bit 

signal, is caused by terms of order 2 and higher (O2). For most dispersion 

compensators the broadening of the impulse response is dominated by the second 

order term, average dispersion (da). In some cases, the third order term, dispersion 

slope (ds) also plays a significant role. 
 

In order to compensate for these broadening factors, we calculate a correction term 
which subtracts out the user-input values for the second and third order terms, 

average dispersion and dispersion slope, respectively. Given that wavelength   is 

related to the change in frequency � of the device by: 
 
 

i   = ----------
c
----------- , 
�  

--------- 
0 2�
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we integrate the phase with respect to frequency. This yields a correction term c n   

specific to the DUT: 
 

 
n 

2
 

c n   = � �   da  i + ds  i   . 
i = 0 

 
To compress the impulse response, the OVA subtracts this correction term from the 

phase of the device response, yielding much narrower impulse response peaks. 
 

If desired, the impulse responses can be expanded back to their original states after 

being separated by multiplying by the complex conjugate of c    in the frequency 

domain. If this is not done, it simply must be noted that a quadratic factor has been 

removed from the phase when calculating parameters from the measured transfer 

function. For instance, the resulting measured dispersion will be 

 
CD   –  da + ds   , 

 
rather than the actual device dispersion CD   . Equivalently, the group delay will 

have a slope removed that corresponds to da . When using the measured transfer 

function directly for modelling purposes, it is imperative that the phase factor be 
replaced. 

 

Pulse Compression Example 

Impulse response compression using the design values for both chromatic dispersion 

and dispersion slope was used to measure a full-C-band dispersion compensating 

grating (DCG). The nominal dispersion value was -225 ps/nm at a wavelength of 

1545 nm, and the nominal dispersion slope was -7.8 ps/nm2. The interferometric 

characterization measured the full grating Jones matrix, with a fixed separation delay 

of approximately 7 ns. The impulse response duration of the grating was 

approximately 9 ns. Both the compressed and uncompressed versions of the scalar 

impulse response appear in Figure 9-28. The compressed impulse response is 

narrower than the original by a factor of 35. 
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Figure 9-28. The compressed and uncompressed impulse response for a 

full-band dispersion compensating grating. 

 
The Jones matrix characterization of the grating allows all linear grating parameters 

to be calculated. Impulse response compression does not affect the amplitude (loss) 

parameters in any way, as it involves only a phase factor. The measured grating 

insertion loss and polarization dependent loss appear in Figure 9-29. 
 

 

                                      9 
 

Figure 9-29. Measured insertion loss and PDL of the DCG. 
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Because the compression used both dispersion and dispersion slope, the measured 

group delay has a parabola removed and is thus termed the residual group delay. In 

many cases the residual group delay is desirable, as it is otherwise difficult to discern 

group delay ripple due to the large group delay changes in dispersion compensators. 

A 25 pm resolution bandwidth filter was applied to the data set. 
 

The differential group delay (DGD) measurement is also unaffected by compression, 

and this data appears in Figure 9-30, along with the residual group delay data for 

the entire bandwidth of the device. 
 

 
 

 
 

Figure 9-30. Group delay and differential group delay of the DCG. 

9 
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Chapter 10 
 
 

 

Maintenance 
 
 

Cleaning Connectors 

It is extremely important to clean connectors before attaching optical fibers to the 

OVA for testing. Failure to do so may result in erroneous or noisy data. 
 

Optical fiber connectors on devices should be cleaned before every connection to 

the OVA. The bulkhead connectors on the front panel of the OVA should be cleaned 

frequently, roughly once every 25 connections. 
 

The optical fiber connector cleaner is used for cleaning connectors: 
 

 
 

 
 

Mini foam swabs are used for cleaning the OVA bulkhead connectors: 
 

 
 

                                                                     10 
 

The cleaning supplies used with the OVA are: 
 

• CLETOP connector cleaner - P/N F1-6270 

• CLETOP connector cleaner replacement reel - P/N F1-6271 

• Mini foam swabs (50/package) - P/N F1-0005 
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These supplies can be ordered from: 

 

FIS Incorporated 

161 Clear Road 

Oriskany NY 13424 

Web: www.fiberinstrumentsales.com 

E-mail: info@fiberinstrumentsales.com. 
 

 
 
 

Important 

Use only cleaners approved for use with fiber optic 

bulkheads and fiber connectors. Do not use any type of 

cleaning fluid, cotton swabs, or cloths. 

Using unapproved cleaning tools or fluids may result in 

erroneous or noisy data, or may damage the fibers and 

OVA components. 
 

 

Cleaning Optical Fiber Connectors 
 
 

 
Important  

Optical fiber connectors on devices should be cleaned 

                 before every connection to the OVA. 
 

 

1 Expose the cleaning tape by pushing down the cover release lever. 
 
 

Cleaning tape cover closed Cleaning tape cover open 
 
 
 
 

10 
 

 
 
 
 

cover release lever tape cover cleaning tape 

http://www.fiberinstrumentsales.com/
mailto:info@fiberinstrumentsales.com
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The cleaner tape has two cleaning strips: 

 
 

cleaning strips 
 
 
 
 
 
 
 
 
 

2 Holding the fiber connector perpendicular to the cleaner tape surface, 

swipe the tip of the connector down the first cleaning strip, then swipe 

on the second strip. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3 Close the cleaning tape cover before swiping another connector. This 

advances the cleaning tape. 
 

Cleaning Bulkhead Connectors 10 
Important  

All three bulkhead connectors (source, detector, and aux) 

                should be cleaned about once every 25 connections. 

 
1 Either turn off the OVA, or turn off the laser by selecting Tools > Turn 

Laser  OFF. 
 

2 Make sure that no devices are connected to the OVA. 
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3 Turn the white cap counterclockwise to remove it. Gently insert one of the 

supplied mini foam swabs, as shown below. Twist the swab in one direction, 

and then remove. Discard miniswabs after single use. 
 

 
 

 
 

Figure 10-1. Remove plastic cap from the bulkhead connectors. Gently insert sup- 

plied mini foam swab, rotate in one direction, then remove. Use a new swab for the 

next connector. 
 

4 Replace the cap to protect the connector. 

 

Cleaning the Case 
Keep the unit free of dust and debris. Clean the case by wiping it with a soft cloth 

dampened with water or a mild, non-abrasive cleaning fluid such as window cleaner. 

 
Caution  

Do not spray any fluid directly on case surfaces. It may 

                 seep into the interior of the case and damage components. 

10 
Replacing Fuses 

The fuse drawer is located on the power module on the instrument case back panel: 
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fuse drawer 

 
 
 
 

power module 
 

 
 
 
 
 
 

Warning  To avoid the risk of serious injury or death, ensure that the 

power cord is disconnected from the instrument when 

               checking or replacing fuses. 
 

 
To replace  fuses 

 

1 Disconnect the instrument power cord. 
 

2 Place the blade of a screwdriver or similar tool in the slot at the bottom 

of the fuse drawer, then gently pry the drawer out of the power module. 
 

 
 
 
 
 
 

10 
 

 
 
 
 
 
 

3 Replace fuses with Bussmann AGC-2 type 2A @ 250VAC 1 ¼” x ¼” 

fast acting (FA) fuses, rated FS01008. 
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4 Push the drawer back into the power module until it snaps into place. 

 

5 Reconnect the power cord. 

 
Packing and Shipping the OVA 

The OVA should only be packed and shipped in its original packing materials. If 

these have been discarded, contact Luna Technologies for packing material. To 

minimize physical shock during shipping, the OVA system should always be shipped 

via air instead of ground, by a reputable shipping service provider. 
 

Required Packing Materials 
• OVA Shipping Box (#1) 

• Dell CPU Box (#2) 

• Dell Monitor Box (#3) 

• OVA Shipping Foam 

• Dell Monitor Shipping Foam 

• Dell CPU Shipping Foam 

• OVA Accessory Box 

• CPU Accessory Box 

• Plastic Caps 

• Sturdy packaging tape to seal the boxes 
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Packing Procedure 

1 Check that all materials to be shipped are ready to be packed using the 

“Components List” on page 7. 
 

2 Place the supplied caps over all bulkhead ports, turning them clockwise 

until tightened. 
 

3 Obtain an OVA Shipping Box (#1). 
 

4 Seal the bottom center and edges of the box. 
 

5 Pack the OVA in the OVA Shipping Box using the original styrofoam 

insert on each side of the OVA. 
 

6 Pack the User Software, the User Guide, the OVA Accessory Pack, the 

GPIB Cable, and the USB Cable in the OVA Accessory Box. 
 

7 Place the OVA Accessory Box on top of the OVA. 
 

8 Seal the top of the box, taping the center and open edges. 
 

9 Obtain a Luna CPU Shipping Box (#2). 
 

10 Seal the bottom center and edges of the box. 
 

11 Pack the CPU in the CPU Shipping Box using the original styrofoam 

inserts on each side of the CPU. 
 

12 Pack the DELL Software and Manuals, as well as the mouse, keyboard, 

and CPU Power Cord in the CPU Accessory Box. 
 

13 Place the CPU Accessory Box on top of the re-packaged CPU. 
 

14 Seal the top of the box, taping the center and open edges. 
 

15 Obtain a Luna Technologies Monitor Shipping Box (#3). 
 

16 Seal the bottom center and edges of the box. 
 

17 Pack the monitor in the Luna Technologies Monitor Box using the 

original styrofoam inserts on each side of the monitor. The Monitor Box 

should contain the monitor, the monitor software and manuals, the power 

supply and the power cord. 
 

18 Seal the top of the box, taping the center and open edges. 
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263  

Error Message Solution(s) 

 This indicator will be displayed if the laser is not ready 

to perform a measurement. If this indicator does not go 

off within several minutes of turning on the instrument, 

please see “Laser Ready light does not come on within 

several minutes” on page 265. 

 

 

 

Chapter 11 
 
 

 

Troubleshooting 
 

 
This chapter describes how to troubleshoot OVA hardware and software errors. The 

first section describes what to do when the various Status  Bar Messages appear. 

General  Troubleshooting contains procedures for problems that occur without 

accompanying error messages. Error Message Troubleshooting explains error 

messages which appear in dialog boxes. The middle two sections are organized 

roughly in the order in which a user would operate the equipment and software. The 

last section describes Luna’s Self-Diagnostic Software. 
 

If you have problems or error messages not listed here, or if the solutions provided 

here do not resolve a problem, please run the Self-Diagnostic software and send the 

resulting text file to Luna (as described beginning on page 272). Then contact Luna 

Technologies toll free at 1-866-LUNAOVA (1-866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

Status Bar Messages 
Please note that status bar messages are not “fatal” error messages. Rather they 

advise the user of the status of the instrument. 
 
 
 
 
 
 
 

11 
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Error Message Solution(s) 

 Realign, wait an hour, then recalibrate. For instructions, 

see “Aligning the OVA Optics” on page 33, and 

“Calibrating the System” on page 34. 

Measurements may still be performed if this indicator is 

displayed on the screen, but the data may not meet the 

documented specifications. 

 Recalibrate. If an internal calibration (see “To perform an 

internal calibration” on page 40) does not clear the 

indicator light, perform a full calibration (see “To perform 

a full calibration” on page 37). 

Measurements may still be performed if this indicator is 

displayed on the screen, but the data may not meet the 

documented specifications. 

 This message is displayed if a measurement cannot be 

calibrated to the wavelength. This simply means that the 

data acquired is accurate in terms of the parameter 

displayed on the screen, but the data is shifted in either 

direction in terms of wavelength. This problem may 

occur once in a while, but the occurrences should be 

fairly sparse. 

First try to scan again or try scanning over a different 

wavelength range to see if the warning indicator is 

displayed again. 

If the error light persists, it generally means that the laser 

(not just the instrument) needs to be recalibrated. Run 

the Self-Diagnostic software and send the resulting text 

file to Luna (as described beginning on page 272). Then 

you may contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 
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General Troubleshooting 
 

The OVA will  not power on 

 
Cause(s) Solution(s) 

The OVA is not plugged in or 

turned on. 

Plug in the OVA. Turn on the power switch on the front 

of the instrument. 

Blown fuse. Replace the fuse. For instructions, see “Replacing 

Fuses” on page 258. 

 

Laser Ready light  does not come on within  several minutes 

 
Cause(s) Solution(s) 

The OVA has not stabilized to 

room temperature. 

Allow time for the entire system to stabilize at room 

temperature before trying to operate. 

Laser overheated because air 

flow to the OVA is restricted. 

Move the OVA away from objects or surfaces that restrict 

air flow through the fan duct on the back of the OVA. 

Laser overheated because of 

excessively high ambient 

temperature. 

Move the OVA to a cooler environment or decrease the 

ambient temperature to within the OVA operating range 

of 10–35oC. 

If all of the above conditions are met and the Laser 

Ready light still does not come on, please run the Self- 

Diagnostic software and send the resulting text file to 

Luna (as described beginning on page 272). Then you 

may contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

Control  software  will  not load 

 
Cause(s) Solution(s) 

Generally this occurs when 

other software is installed on 

the PC. 

Remove any software not originally installed on the OVA 

PC, then restart. 

If the problem persists, reinstall the OVA control software 

from the OVA software CD. 

mailto:support@lunatechnologies.com
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Cause(s) Solution(s) 

Laser not on. Turn the laser on by selecting Tools >Turn Laser ON. 

Then realign after the Laser Ready light comes on. For 

instructions on aligning the optics, see “Aligning the OVA 

Optics” on page 33. 

 

 
All software  controls are disabled  or unavailable 

 
Cause(s) Solution(s) 

The instrument is not properly 

connected to the PC. 

Ensure that the cable connecting the instrument to the 

PC is securely attached. 

The instrument could not be 

configured properly due to a 

communication error. 

Reboot the PC. Turn the instrument off and then back 

on again. Restart the OVA control software. 

If the problem persists, reinstall the OVA control software 

from the OVA software CD. 

 

Control  software  seems to lock  up 

 
Cause(s) Solution(s) 

The hardware may have 

stopped responding to the 

software. 

Exit the software, using the Windows® Task Manger if 

necessary. [Click Ctrl + Alt + Del, then click the Task 

Manger button, then select the OVA software, and click 

End Task.] Turn the instrument off and then back on 

again. Restart the OVA control software. 

Multiple Luna Technologies 

software applications may be 

running at the same time. 

Ensure that you are only running one control software 

program at a time. Software applications cannot share 

the OVA instrument, so running more than one at a time 

will produce undesirable results. 

The PC has entered an 

unusable state. 

Reboot the PC. Turn the instrument off and then back 

on again. Restart the OVA control software. 

If the problem persists, reinstall the OVA control software 

from the OVA software CD. 

 

Cannot align  the OVA 
 

11 
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Cause(s) Solution(s) 

Wrong DUT length setting. Reset the DUT length. For detailed information, see 

“Finding the DUT Length” on page 44. 

Wrong type of measurement 

selected. 

Select the correct type of measurement, either 

Transmission or Reflection. 

 

 
Alignment unsuccessful 

 
Cause(s) Solution(s) 

Normal alignment procedure 

occasionally fails. 

Retry. See “Aligning the OVA Optics” on page 33. 

 

OVA will  not scan 

 
Cause(s) Solution(s) 

Laser not on or ready. If the laser is not on, turn it on by selecting Tools > Turn 

Laser ON. Then re-scan after the Laser Ready light 

comes on. If the laser is on but the ready light is not lit, 

the laser is still warming up. Wait until the Laser Ready 

light comes on, then scan. 

If the Laser Ready indicator does not light within several 

minutes of turning on the instrument, see “Laser Ready 

light does not come on within several minutes” on 

page 265. 

Optics not aligned. (The “Out of 

Alignment” indicator should be 

lit in this case.) 

Realign, wait an hour, then recalibrate. See “Aligning the 

OVA Optics” on page 33, and “Calibrating the System” 

on page 34. 

The instrument is not 

calibrated. (The “Out of 

Calibration” indicator should be 

lit in this case.) 

Recalibrate. For instructions, see “Calibrating the 

System” on page 34 

The instrument is not properly 

connected to the PC. 

Ensure that the cable connecting the instrument to the 

PC is securely attached. 

 

Excessive  noise  in data 

11 
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Cause(s) Solution(s) 

Incorrect time domain filter 

setting. 

Reset the filter parameters. For detailed information, see 

“The Time Domain Filter” on page 70. 

Mechanical vibration. Move, remove, or shut down any sources of vibration 

such as fans or other motor-driven equipment. Isolate 

the OVA from those sources. 

Loose DUT connection. Tighten the DUT (device under test) connections. 

Dirty DUT or bulkhead 

connections. 

Clean all connections. For instructions, see “Cleaning 

Connectors” on page 255. 

OVA not aligned. Realign, wait an hour, then recalibrate. For instructions, 

see “Aligning the OVA Optics” on page 33, and 

“Calibrating the System” on page 34. 

OVA not calibrated. Recalibrate. For instructions, see “Calibrating the 

System” on page 34. 

Wrong fiber connector type. Ensure that the fiber connectors interfacing with the front 

panel of the OVA are FC/APC connectors. 

Incorrect or out-of-date 

calibration file loaded on 

startup. 

Recalibrate. For instructions, see “Calibrating the 

System” on page 34. 

DUT too long. Shorten the leads or replace the DUT to comply with the 

length limit of the OVA. 

Cracks in bulkhead connector 

alignment sleeve. 

Contact Luna Technologies at 1-866-LUNAOVA 

(866-586-2682) or support@lunatechnologies.com for 

service. 

OVA not warmed up. In order to achieve accurate results within published 

specifications, the system should be allowed a full hour 

to warm up and settle after powering on. Check the menu 

item Tools > Check Warm-Up Timer to verify that the 

full hour has elapsed. 
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No data after scan 
 

 
Cause(s)  Solution(s) 
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Incorrect graph range settings. Rescale the plot axes. For detailed information, see 

“Scaling Plot Axes” on page 63. 
 

 

Unexpected  or abnormal  data 
 

See “Excessive noise in data” on page 267. 

 
Instrument drifts  out of calibration 

 
Cause(s) Solution(s) 

Temperature changes will 

cause the instrument to drift. 

Recalibrate. For instructions, see “Calibrating the 

System” on page 34. Or see “Automatic Calibration” on 

page 42 to set the OVA for automatic calibration. 

 

Error Message Troubleshooting 
 

Errors can occur while operating the OVA software. These errors will be described 

on the screen in a standard Microsoft® Windows® dialog box, showing the numerical 
error code as well. 

 

However, if the instrument is being operated remotely, error messages will not be 

displayed in a dialog box. The user will need to query the instrument for errors to 

ensure that the previous action was completed successfully. For more details, see 

“Controlling the OVA Remotely” on page 135. 
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Cause(s) Solution(s) 

The USB cable connections 

could be loose. 

Check the connections to ensure that the cable is 

connected properly to both the instrument and the PC. 

The instrument is not turned 

on. 

Ensure that the instrument is plugged into the proper 

type of outlet and turn on the power switch. 

The software is in an unknown 

state. 

Exit and restart the software. 

The hardware is in an unusable 

state and is not responding to 

the software. 

Exit the software. Turn the instrument off and then back 

on again. Restart the PC and the control software. 

The USB cable is faulty. If the above solutions do not work, run the Self- 

Diagnostic software and send the resulting text file to 

Luna (as described beginning on page 272). Then you 

may contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com to obtain a replacement 

cable if the problem persists. 

 

 
Errors on Software Startup 

 

Instrument not calibrated 

 
Cause(s) Solution(s) 

On startup, the software 

attempts to load calibration 

data from a file. If this message 

is displayed, the file was not 

found or was found to be 

corrupted. 

Calibrate the instrument. Once the instrument is 

calibrated successfully for both transmission and 

reflection, the user will never see this message again 

(unless the calibration data files are deleted manually). 

 

Configuration information could not be loaded from the instrument; the 
software  goes into  "Desktop Analysis" mode 
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Cause(s) Solution(s) 

This is just a warning letting the 

user know that the optics are 

not aligned properly. 

The user will have the option of continuing with the 

calibration even without the optics aligned. 

It is preferable to realign, wait one hour, then recalibrate. 

For instructions, see “Aligning the OVA Optics” on 

page 33, and “Calibrating the System” on page 34. 

 

 
Remote interface (i.e. GPIB or Ethernet) could not be initialized properly 

 
Cause(s) Solution(s) 

Either there is a problem with 

the GPIB board or it is not 

installed in the PC. 

Ensure that the name of the GPIB board installed in the 

PC has not been changed from the default of “GPIB0” 

(using the “Measurement and Automation” shortcut on 

the desktop). If the card is not found in the system, 

please contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

Errors During Calibration 
 

Wavelength  calibration failed while acquiring data 

 
Cause(s) Solution(s) 

None of the requested scans 

that were acquired were 

properly adjusted to 

wavelength. Although this is 

not a major error when 

performing a measurement, it 

is a problem when calibrating 

the instrument. 

Attempt the operation again. If the problem persists, run 

the Self-Diagnostic software and send the resulting text 

file to Luna (as described beginning on page 272). Then 

you may contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

The optics  were detected  to not be aligned  properly 
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Cause(s) Solution(s) 

There may be a problem with 

the hardware. 

If this problem occurs more than once at any time, exit 

the software. Turn the instrument off and then back on 

again. Restart the PC and the control software. 

If none of these actions fix the problem, run the Self- 

Diagnostic software and send the resulting text file to 

Luna (as described beginning on page 272). Then you 

may contact Luna Technologies toll free at 866- 

LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

 
Calibration data contains invalid  values 

 
Cause(s) Solution(s) 

The calibration was 

unsuccessful due to some 

problem in the hardware or 

software. 

Attempt the calibration again. If the problem persists, 

please run the Self-Diagnostic software and send the 

resulting text file to Luna (as described beginning on 

page 272). Then you may contact Luna Technologies toll 

free at 866-LUNAOVA (866-586-2682) or by e-mail at 

support@lunatechnologies.com. 

 

Errors During Scanning or Calibration 

Any number of errors can be displayed during a scan. However, many of the errors 

are not major problems and most will be isolated incidents. In those cases, the error 

message will be displayed during one scan and the subsequent scans will be 

performed without any error. If any error occurs consistently, please run the Self- 

Diagnostic software and send the resulting text file to Luna (as described beginning 

on page 272). Then you may contact Luna Technologies toll free at 866-LUNAOVA 

(866-586-2682) or by e-mail at support@lunatechnologies.com. 

 
The specified timeout  occurred before all of the requested  data could 
be acquired 

 
 
 
 
 
 
 
 
 
 
 
 

11 
 

Self-Diagnostic Software 
Each Luna Technologies PC is loaded with both operating and Self-Diagnostic 

software. If the above-described error messages and solutions do not solve issues, 

please run the Self-Diagnostic software before contacting Luna. The Self-Diagnostic 

mailto:support@lunatechnologies.com
mailto:support@lunatechnologies.com
mailto:support@lunatechnologies.com
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software outputs a text file (c:\selfdiag:txt) which will help Luna’s support staff 

correct errors. 

 
Running the Self-Diagnostic Software 

1 Exit the OVA software (by selecting File > Exit) and any other software. 
 

2 Go to the Windows® Start menu and select Programs > Luna 

Technologies > Self-Diagnostic. 
 

The following window box appears: 
 
 
 
 
 
 
 
 
 
 
 
 

3 Click the blue Start button. 
 

4 Follow instructions as they appear. 
 

5 When the diagnosis is finished, the window will change appearance, as 

shown below: 
 

 
 
 
 
 
 
 
 
 

6 You may view the results and then click the red Exit button. 11 
7 As instructed in the above window, send the resulting text file 

(c:\selfdiag:txt) as an attachment to support@lunatechnologies.com. 

Luna’s support staff will examine the file and contact you. 

mailto:support@lunatechnologies.com
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Appendix A 
 
 

 

Specifications 
 

 
 
 

Specification  Units 

PC I/O   
Input/Output devices •   IEEE-488/GPIB 

•   Ethernet port 

•   3.5-inch HDD 

•   CDRW drive 

•   Printer port 

•   Keyboard/Mouse 

•   Display 

 

   
Input voltage range 100-240 VAC 

Input frequency range 50-60 Hz 

Operating power 100 VA 

Environmental Requirements   
Operating temperature range 10-35 ºC 

Storage temperature range 0-40 ºC 

Relative humidity (non-condensing) < 80 % 

Physical  Characteristics   
Weight (PC not included) 16.2 

35.8 

kg 

lbs 

Case size (W X D X H) 510 X 420 X 200 

20.1 X 16.5 X 7.9 

mm 

inches 

For current performance specifications, check our website at 

www.lunatechnologies.com. 

A 

http://www.lunatechnologies.com/
http://www.lunatechnologies.com/
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Minimum PC Requirements 

Pentium 4 or Core 2 Processor 
 

1 GB RAM 

USB 2.0 port 

Windows 2000/XP (Vista not supported) 

Screen Resolution: 1280 x 1024 

(Laptop resolution setting must be > 1280 x 1024) 

 
Class 1 Laser Product 

The Luna Technologies OVA is a Class 1 Laser  Product, which meets the 

requirements of Class 1 in standard IEC 60825-1: 2007 and complies with 

21CFR1040.10. 
 

Maximum rated output power: 2.4 mW 
 

Internal laser module maximum rated output power: 10.0 mW 

Emitted wavelengths: 1265–1335 or 1525–1610 nm 

 

CAN/CSA Testing 
 

This product has been tested to the requirements of CAN/CSA-C22.2 No. 61010- 

1, second edition, including Amendment 1, or a later version of the same standard 

incorporating the same level of testing requirements. 

 

IP Rating: IP 20 
According to EN60 529/IEC 529, the OVA is rated IP 20, meaning the OVA is 

protected against solid foreign objects with a diameter of 12.5mm and greater; the 

OVA is not protected against water. 
 
 

A 
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A 
align optics 32–33, 105 

OFDR 104 

always apply smoothing filter 21, 30 

amplitude 95, 121 

remote command 177 

Apply Filter button 22 

apply spatial resolution filter 103 

apply time domain hanning window 30, 246 

apply time domain window 30, 74–79 

assembling the OVA 7–16 

auto calibration settings 30 

automatic calibration 30, 42–44 
automatically find DUT length 31 

autoscale plot axes 31, 103 

auto-update lower graph 103 

aux connector 33 

average dispersion 53–54 

average loss 97 
 

 

B 
binary files 57–60, 116, 119 

Bragg grating 45, 72, 75–78, 224–227, 240, 245, 247–248 

broadband 20, 45–48, 50, 163, 200, 240 

buttons 18, 25–28, 56, 63–70 

details 114–115 

filter 21 

graph control 19, 25–28, 56, 63–70, 98 
 

 

C 
cables 7–12 

calculation method 92 

calibrate 98, 105, 107 

OFDR 104 
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reload calibration data 104 

reload calibration data, OFDR 110 

remote command 207 

storing multiple calibration files, OFDR 109 

calibration 16, 19, 37–44 

automatic 42–44 

checking 41 

checking validity remotely 142 

checking, OFDR 109 

conditions requiring 35 

files and file locations 35 

files and file locations, OFDR 106 

full 32, 37–40 

information on last 32, 44 

internal 31, 40–41 

laser. See laser calibration 

remote commands 142, 155, 207–208 

troubleshooting 264, 267–269, 271 

types 35 

calibration filenames 104 

calibration information 104 

CAN/CSA testing 276 

CD. See chromatic dispersion 

channel width 228 

check warm-up time 32 

chromatic dispersion 1, 4, 85, 91, 95, 213, 219, 230 

PAS 91 

remote command 153 

smoothing filter 79 

spreadsheet output 61, 89 

Class 1 laser product 276 

cleaning 

case 258 

connectors 38, 47–49, 108, 111, 255 

supplies 255 

*CLS 138, 199 

color palette 104 

components list 7–10 
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compression 53, 250–254 

CONFigure:AlwaysApplyFilter 159, 199 

CONFigure:AlwaysApplyFilter? 159, 200 

CONFigure:AVeraGE 159, 200 

CONFigure:AVeraGE? 159, 200 

CONFigure:AVeraGeSet 160, 197, 200 

CONFigure:AVeraGeSet? 160, 200 

CONFigure:CenterWaveLength 146, 195, 200 

CONFigure:CenterWaveLength? 147, 200 

CONFigure:ConvolvedResolutionBandWidth? 169, 200 

CONFigure:DISPersion 166, 200 

CONFigure:DISPersion? 167, 200 

CONFigure:DUTLength? 162, 190, 200 

CONFigure:DUTlengthfindMethod 163, 200 

CONFigure:DUTlengthfindMethod? 163, 200 

CONFigure:DUTLengthset 162, 200 

CONFigure:DUTName 163, 201 

CONFigure:DUTName? 164, 201 

CONFigure:ENDwavelength? 148, 201 

CONFigure:FilterResolutionBandWidth 167–168, 201 

CONFigure:FilterResolutionBandWidth? 168, 201 

CONFigure:FindDUTlengthautomatically 161, 201 

CONFigure:FindDUTlengthautomatically? 162, 201 

CONFigure:FrequencydomainWINdow 178, 201 

CONFigure:FrequencydomainWINdow? 178, 201 

CONFigure:GRouP 178, 201 

CONFigure:GRouP? 178, 201 

CONFigure:INTegrationCenter 180, 201 

CONFigure:INTegrationCenter? 180, 201 

CONFigure:INTegrationStart 179, 201 

CONFigure:INTegrationStart? 179, 201 

CONFigure:INTegrationWidth 179, 201 

CONFigure:INTegrationWidth? 179, 201 

CONFigure:PhaseDEviationCursor 164, 202 

CONFigure:PULSecompression 165, 202 

CONFigure:PULSecompression? 166, 202 

CONFigure:RANGe 148, 195, 198, 202 

CONFigure:RANGe? 149, 202 
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CONFigure:ReSolutionBandwidthUnits 167, 202 

CONFigure:ReSolutionBandwidthUnits? 167, 202 

CONFigure:RESolutionGhz? 180, 202 

CONFigure:RESolutionPicometers? 180, 202 

CONFigure:SampleRESolution? 169, 203 

CONFigure:SOURce 157, 172, 195, 203 

CONFigure:SOURce? 172, 195, 203 

CONFigure:SpatialResolutionBandWidth 181, 203 

CONFigure:SpatialResolutionBandWidth? 181, 203 

CONFigure:SpatialresolutionFILter 180, 202 

CONFigure:SpatialresolutionFILter? 180, 203 

CONFigure:SpatialResolutionFilterWidth 181, 203 

CONFigure:SpatialResolutionFilterWidth? 181, 203 

CONFigure:STARtwavelength 147, 198, 203 

CONFigure:STARtwavelength? 148, 203 

CONFigure:TEST 149, 203 

CONFigure:TEST? 150, 196, 203 

CONFigure:TimedomainHANning 171, 203 

CONFigure:TimedomainHANning? 172, 203 

CONFigure:TimedomainsettingsRETain 171, 195, 204 

CONFigure:TimedomainsettingsRETain? 171, 204 

CONFigure:TimedomainSIGma 169, 194, 204 

CONFigure:TimedomainSIGma? 170, 204 

CONFigure:TimeDomainWindow 161, 203 

CONFigure:TimeDomainWindow? 161, 203 

CONFigure:TimedomainWindowResolutionBandwidth? 168, 204 

CONFigure:TimeLIMits 170, 194, 204 

CONFigure:TimeLIMits? 170, 204 

CONFigure:WAVElength 157, 172–173 

CONFigure:XaxisUNIts 181, 204 

CONFigure:XaxisUNIts? 182, 204 

connectors 33, 35, 38, 44, 47, 49, 241 

attaching to bulkhead 38, 108 

cleaning 255–257 

OFDR 108, 112 

splicing 36, 42 

continuous scan. See scanning, continuous mode 

Convolved Filter 22 
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resolution bandwidth 21, 81, 169, 200 

units 73 

cursors 19, 22, 25–27, 64, 66–67, 82, 98, 103 

attaching to a trace 123 

default location 27, 66 

moving 26, 66, 74 

phase deviation calculations 27, 63 

phase deviation remote calculations 164 

time domain 22, 73, 75–76, 244–245 
 

 

D 
data 

abnormal 269 accuracy 

38, 41 acquiring. See 

scanning 

capture commands 151–155, 173, 182, 204 

decimation 103 

decimation (OFDR only) 124–125 

details 23 

displaying. See plotting 

files 58–61, 116, 118–119 

filters. See filters 

Jones matrix 217 

loading from memory 29, 60–61, 119, 145 

loading from memory, OFDR 102 

matrices. See matrices 

moving data in local memory 55, 114 

no data 23, 268 

noise 255–256, 267 

plotting. See plotting 

processing 18, 21 

raw 59, 236 

retrieval commands 151–155, 173, 182, 204 

saving 29, 55, 57–60, 116–119, 157–158 
scanning. See scanning 

spreadsheet 58–59, 61, 118 

traces. See traces 

Data Processing area 21, 100 
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DCG. See dispersion compensating grating 

decimation 103, 124 

remote command 185, 187 

details 56–57, 114–115 

detector connector 33, 38, 44, 47, 49 

OFDR 108, 112 

device descriptor 29 

printing 82 

remote entry 163–164, 201 

DGD. See differential group delay 

differential group delay 220, 254 

dispersion compensating devices 250–251 
dispersion compensating grating 252 

dispersion slope 53–54 

display options 103 

Display Options area 22, 100, 114 

disposal 2 

DUT length 20, 267 

changing to adjust Time Domain Window 72 

entering manually 49, 239 

find automatically 20, 31, 50–51, 53, 201 

find method 44–48, 50, 236–241 

invalid 267 

not found automatically 51, 53 

remote commands 161–162, 194–195, 200 

remote find method 163, 200 

why necessary 236–239 
 

 

E 
edit menu 29 

eigenvalues 219–220, 227 

eigenvectors 222 

enable high dynamic range averaging 30, 248 

*ESE 138, 199 

*ESE? 138, 199 

*ESR? 138, 199 

eye diagrams 216 
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F 
Fast Fourier Transform 131, 235 

FETCh:FREQuency? 151, 191, 204 

FETCh:FrequencydomainDeTail? 185, 204 

FETCh:FSIZe? 152, 204 

FETCh:INTegrationLoss? 185, 205 

FETCh:JONesElements? 173, 205 

FETCh:LENgthEnd? 186, 205 

FETCh:LENgthStart? 186, 205 

FETCh:MEASurement? 153, 205 

FETCh:MeasurementDETails? 154, 205 

FETCh:PolarizationDependentFrequency? 173, 205 

FETCh:RAW? 182, 205 

FETCh:RawdataSIZe? 183, 205 

FETCh:TimedomainINCrement? 151, 205 

FETCh:TIMEnd? 186, 205 

FETCh:TIMeStart? 185, 205 

FETCh:WaveLength? 184, 205 

FETCh:WaveLengthCenter? 184, 205 

FETCh:WaveLengthEnd? 184, 206 

FETCh:XAXIs? 174, 187, 206 

file menu 29 

OFDR 102 

files 

see also data 

files. See data 

filter resolution bandwidth 

remote commands 201 

filters 55, 57, 59, 70–71, 82, 215, 230 

Always Apply Filter 21, 30, 52, 80, 159, 199–200 

Apply Filter button 21–22 

box-car 128 

Convolved. See Convolved Filter 

Gaussian. See Gaussian filter 

remote commands 156, 168, 180, 209 

resolution 18, 21, 30, 70, 167–168 

smoothing 29, 79–80, 248 

spatial resolution 100, 103, 128, 180 
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time domain. See time domain 

units 21, 73, 167 

Fourier transform 126, 131, 233, 245 

fast 235 fringes 236 

smoothing filter 247 

theory 214–215 

time domain (amplitude) 225 

time domain filter 71, 244 

frequency 61 

frequency domain 95 

remote command 177, 187–188 

full calibration 32 

fuses 

replacing 258–260 
 

 

G 
gain 115 

Gaussian filter 21, 70, 79, 247–248 

remote commands 170 

Gaussian function 74, 76, 244–245 

GD. See group delay 

GPIB commands. See remote control commands 

Graph areas 24 

on/off control 25 

graph areas 101 

graphing. See plotting 

grating spectra 216 

group delay 1–2, 4, 62, 81, 85, 91, 95, 129, 213–214, 218–220, 230–231 

differential 220 

PAS 90 

remote command 152–153, 177 

smoothing filter 79 

spreadsheet output 61, 89 

group index 115, 124 

remote command 178, 201 
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H 
Hanning window 30, 74, 203 

applying 74 

remote commands 171 

theory 246–247 

hardware wizard 13 

help menu 32 

high dynamic range averaging 48, 248 

hydrogen cyanide (HCN) gas cell 241–244 
 

 

I 
icons 

desktop 105 

*IDN? 138, 199 

IL. See insertion loss 

impulse response 85, 131–132, 226, 237–240 

amplitude 225 

compression 250 

DUT length 236–241 

Hanning window 247 

time domain window 245 

insertion loss 1–2, 4, 36, 42, 62, 91, 95, 97, 122, 129, 213–214, 217–218, 247–248 

OFDR 109 

PAS 90 

PAS spreadsheet output 89 

remote command 152–153, 177 

smoothing filter 79 
spreadsheet output 61 

integrated loss 123 

integration width 100, 123, 128 

remote command 179–180, 201 

integration width (OFDR) 121 

interferometry 231–236 

internal calibration 31, 40–41 
 

 

J 
Jones matrix 1–2, 20, 29, 48, 85, 211–227, 244–245, 250 
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elements 213, 217–218, 223, 225, 236–238, 240 

modeling 214 

parameter calculations 216–217 

parameters. See parameters 

saving raw data 60 

scalar transfer functions 211 

Jones matrix element amplitudes 4, 91, 225 

remote command 153 

smoothing filter not applied 80 

spreadsheet output 61 

Jones matrix element phases 4, 91, 154, 225 

remote command 153 

smoothing filter not applied 80 

spreadsheet output 61 
 

 

L 
laser 

Class 1 ratings 276 

laser calibration 

selecting a calibration file 104 

laser off 31 

OFDR 104 

laser on 31 

OFDR 104 

Laser On LED 33 

laser ready LED 32 

LED 

indicators on front panel 33 

legends 27, 66–68, 82, 123 

light source 

remote command 157, 195 

linear amplitude 132 

remote command 177 

linear phase deviation 4, 27, 91, 223–224 

cursors 63, 202 

recalculate 27, 63, 68 

remote command 153 

remote cursors 164 
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smoothing filter not applied 79 

spreadsheet output 61 

load data file 29 

OFDR 102 

loss  
average 97 

insertion 36, 95, 97, 122, 129, 213–214, 217, 247–248 

insertion, OFDR 109 

integrated 123 

polarization dependent 35, 213–214, 219 

return 95, 97, 103, 128 

loss. See insertion loss, polarization dependent loss, etc. 

lower graph 

two plots 101, 103 

updating 121 

updating in OFDR 120 

LPD. See linear phase deviation 
 

 

M 
main window 18 

matrices 19, 23, 135 

displaying multiple matrices 56 

moving data in local memory 55 

Matrix Memory Functions area 23, 56 

max loss 

spreadsheet output 61 

menu items 29–32 

OFDR 102–104 

min loss 

spreadsheet output 61 

Min/Max loss 4, 92, 227 

remote command 153 

Min/Max State 91 
 

 

N 
narrowband 20, 45–48, 50, 163, 200, 240–241 
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O 
*OPC 139, 199 

*OPC? 139, 199 

optical frequency 2, 86, 130, 132, 211, 217–218, 220, 226, 231 

optical network 126–127, 233–235, 240 

optical phase error 230–231 

optical time domain reflectometry 95, 97 

options menu 30 

OFDR 103 
 

 

P 
parameters 2, 4, 24, 29, 96, 101, 153, 217 

calculations 217 

menu 24 

OFDR 101, 111 

plotting 62, 121 

remote commands 139, 141, 153, 171, 189, 199 

saving 29 

spreadsheet 58, 61 

time domain window 245 

two in one graph (OFDR only) 122 

PAS. See Polarization Analysis Software 

PDL. See polarization dependent loss 

phase 95, 130 
remote command 177 

phase derivative 132 

remote command 177 

phase ripple linear 4, 92 

remote command 153 

smoothing filter not applied 80 

spreadsheet output 61 

theory 228, 230 

phase ripple quadratic 4, 92 

remote command 153 

smoothing filter not applied 80 

spreadsheet output 61 

theory 228 

phi 86, 92 
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plotting 19, 98 

autoscaling 31, 50, 52, 63, 103 

changing colors 68 

colors 24, 56, 68, 71–72, 74, 76, 114, 244–245 

manual scaling 63 

synchronizing 22, 64 

Time Domain Window scale 245 

units 71 

X-axis 25, 63 

Y-axis 25, 63 

zooming 65 
PMD. See polarization mode dispersion 

polarization 131 

Polarization Analysis Software (PAS) 85–93 

polarization beam splitter 126 

polarization dependent loss 1–2, 4, 35, 85, 91, 213–214, 219–220 

calibrating for 37 

remote command 153 

smoothing filter 79 

spreadsheet output 61 

polarization mode dispersion 1–2, 4, 85, 91, 213–214, 220 
remote command 153 

smoothing filter 79, 247 

spreadsheet output 61 

principal states of polarization 93, 221 

printing 11–12, 29, 82, 102 

device descriptor 29 

PSPs. See principle states of polarization 

pulse compression 31, 53, 73, 250–254 

remote commands 165–167 
 

 

Q 
QPD. See quadratic phase deviation 

quadratic phase deviation 4, 27, 91, 224 

cursors 63, 164, 202 

recalculate 27, 63, 68 

remote command 153 

smoothing filter not applied 80 
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spreadsheet output 61 

*QUIT 140 
 

 

R 
real-time mode. See scanning, real-time mode 

recalculate 

OFDR 121 

reference wavelength 53–54 

reload cal data file 32 

reload calibration data 104 

remote control commands 135–210 

alphabetical listing 199–210 

case sensitive 198 

delay required 198 

GPIB 135–210 

setup 31, 136 

spaces in 197 

TCP/IP 135–210 

see also individual commands 

remote interface setup 31, 104 

Reset Hardware 32 

resolution 18, 97, 235 

spatial, OFDR 107 

spatial. See spatial resolution 

resolution bandwidth 5, 21–22, 30, 59, 70, 73, 80–82 

OFDR 103 

units 103 

return loss 95, 97, 103, 123, 128 

displaying 123 

*RST 139, 199 
 

 

S 
save data 29 

polarization analysis software (PAS) 87 

save data file 

remote command 209 

save data files 116–119 
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OFDR 102 

save software options 102 

OFDR 111 

save software settings 29 

saving data 55, 57–60 

scalar transfer functions 2, 211 

scale 131–132, 212, 226 

SCAN 141, 206 

scanning 

after changing DUT length 73 

averaging 20, 31, 50, 159–161, 197, 200 

button 21, 53, 99 

continuous mode 20, 25, 31, 51, 99, 135 

continuous mode, OFDR 112–113 

failed 267 

indicator light 33 

modes 4 

new scans to Matrix A 23, 55, 113 

range 20, 78, 99 

real-time mode 25, 31, 52–53, 135 

remote command 141 

single 49–50 

single, OFDR 111–112 

stopping 50–51, 53, 113 

second order PMD 4, 92, 221–223 

remote command 153 

smoothing filter 79 

spreadsheet output 61 

select data save options 29 

select file options 118–119 

OFDR 102 

self-diagnostic software 263, 272–273 

shipping the OVA 260–261 

show integration area 103 

show integration area (OFDR) 121 

sigma 73–74, 76, 78 

remote commands 169–170 

signal spectra 216 
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smoothing filter 22, 29–30, 55, 59, 70, 79–82 

remote commands 156, 159, 167, 201, 207 

software 

installation 12 

SOPMD. See second order PMD 

source connector 33, 38, 44, 47, 49 

OFDR 108, 112 

spaces in commands 197 

spatial resolution 

filter 100, 103, 128, 180 

OFDR 107 

remote commands 176–177, 180, 202, 209 

specifications 20, 248, 275 

specify calibration filenames 104 specify 

compression settings 31, 250 spreadsheet 

files 55, 57–61, 116, 119–120 

remote command 176, 209 

*SRE 139, 199 

*SRE? 140, 199 

State 1 90 

State 2 90 

*STB? 140, 199 

step size 97, 248, 250 

Stokes vector 222 

synchronizing graphs 19, 22, 64 

System Control area 19, 99 

SYSTem:ACQuired? 175, 206 

SYSTem:ALIGn 142, 206 

SYSTem:ALIGn? 142, 206 

SYSTem:CALibration 175, 207 

SYSTem:CALibration? 142, 175–176, 207 

SYSTem:CALibrationFile 175, 207 

SYSTem:CALibrationFile? 176, 207 

SYSTem:COPY 176, 207 

SYSTem:ERRor? 143, 207 

SYSTem:ERRorDescription? 144, 207 

SYSTem:FILTer 156, 207 

SYSTem:FullCALibration 155, 207 
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SYSTem:InternalCALibration 155, 207 

SYSTem:LASEr 144, 207 

SYSTem:LASEr? 144, 207 

SYSTem:LAST? 145, 208 

SYSTem:LOAD 145, 208 

SYSTem:QCALibration 155–156, 208 

SYSTem:ReaDY? 144, 208 

SYSTem:ReLoaDCalibration 143, 208 

SYSTem:SAVeJonesmatrix 157, 208 

SYSTem:SAVeStextfile 158, 208 

SYSTem:SAVeText 209 

SYSTem:SAVText 158, 176, 209 

SYSTem:SWEEp 157, 209 

SYSTem:VERsion? 145, 209 

SYSTem:WARM? 141, 146, 210 

SYSTem:WarmupTIMeremaining? 141, 210 
 

 

T 
TCP/IP commands. See remote control commands 

text file 

OVA software 57–61 

PAS software 89 

theta 86, 92 

time domain 95 

adjusting plot 71 

adjusting to fit window 72 

applying TD filter 74–75 

button 21–22 

definition 127, 234–235 

filter 70–79 

filter function 244 

Hanning window 74, 246 

remote command 177 

remote commands 170, 194 

resolution 22, 73, 245 

retaining settings 78 

retaining settings remotely 171 

sigma 74, 76, 78 
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synchronizing TD settings for all matrices 79 

window 72–79, 245 

time domain (amplitude) 4, 92, 131, 225 

PAS 91 

PAS spreadsheet output 89 

remote commands 153 

smoothing filter not applied 80 

spreadsheet output 61 

time domain (wavelength) 4, 92, 226 

remote commands 153 

smoothing filter not applied 80 

spreadsheet output 61 

time domain phase derivative 132 

time segment length 

defined 235 

setting resolution 169, 237, 248 

tools menu 31, 104 

trace 121 

traces 113 

displaying multiple traces 114 

moving data in local memory 114 

remote command 176, 182–187, 209 

triggering 126, 235 

troubleshooting 263 

*TST? 140, 199 

tunable laser source 232 

tunable light source 

remote command 157 

remote commands 195 

two plots (OFDR) 122 

two plots in one graph 101, 103 
 

 

U 
units 

OFDR 102 

remote commands 187, 206 

resolution bandwidth 21, 30, 73, 247 

spreadsheet file 120 
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synchronizing 64 

time domain 74, 245 

X-axis 19, 25, 98 

Y-axis 71 

USB 33 

LED indicator on front panel 33 
 

 

W 
*WAI 140, 199 

warm-up time 32, 141 

wavelength 1, 46, 49, 61, 70, 79, 81, 240, 246 

calibration 241–244 

center 20, 38, 41, 47, 49, 99, 108, 146–147, 200 

center, OFDR 112 

ending 148, 201 

OFDR 111 

range 20, 38, 41, 47, 49, 99, 108, 147 

range, OFDR 112 

remote commands 141, 147, 157, 195 

starting 203 
 

 

X 
X-axis 194 

adjusting in full screen view 69 

adjusting in Time Domain Window 28 

menu 25 

OFDR 102 

remote commands 151–152, 170, 174–175, 181–182, 187, 194, 204–206 

scaling 25, 63 

synchronizing 22, 64 

units 25 

zooming 65 
 

 

Y 
Y-axis 

adjusting in full screen view 69 

adjusting in Time Domain Window 28 
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OFDR 102 

scaling 25, 63 

zooming 65 
 

 

Z 
zooming 26, 64–66 


